On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Window opens outside screens

  • 5 svar
  • 1 har dette problemet
  • 37 views
  • Siste svar av FredMcD

more options

Firefox opens a new window outside my two screens. Firefox is configured to open link in another tab. A web page that automatically open another page seems to be able to overrule that setting and can open a new window. That window is outside my screens. The website I have the problem with kayak.com. Search for flights with having at least one other site selected under "Compare vs Kayak " Windows 10 Pro. Firefox 48.0.2

Arrow key method from problem 980358 allows me to recover the window but is a nuisance. Jon

Firefox opens a new window outside my two screens. Firefox is configured to open link in another tab. A web page that automatically open another page seems to be able to overrule that setting and can open a new window. That window is outside my screens. The website I have the problem with kayak.com. Search for flights with having at least one other site selected under "Compare vs Kayak " Windows 10 Pro. Firefox 48.0.2 Arrow key method from problem 980358 allows me to recover the window but is a nuisance. Jon

Valgt løsning

Some links can be set by the sender to open a new window.

This may help; Type about:config<enter> in the address bar. If a warning screen comes up, press the Be Careful button. At the top of the screen is a search bar. Enter dom.disable_window From this list, set everything to True.


As to the hidden window, try this; You may have corrupt xulstore.json or Localstore.rdf file.

Type about:support in the address bar and press enter.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Locate the above file. Then rename or delete it. Restart Firefox.

Les dette svaret i sammenhengen 👍 0

All Replies (5)

more options

Valgt løsning

Some links can be set by the sender to open a new window.

This may help; Type about:config<enter> in the address bar. If a warning screen comes up, press the Be Careful button. At the top of the screen is a search bar. Enter dom.disable_window From this list, set everything to True.


As to the hidden window, try this; You may have corrupt xulstore.json or Localstore.rdf file.

Type about:support in the address bar and press enter.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Locate the above file. Then rename or delete it. Restart Firefox.

more options

FredMcD thank you for your reply. I have more information but first my reaction to your message. 1) Would setting all dom.disable_window prevent all windows from popping up? I want to see those windows, so that is not the desired solution. 2) I removed xulstore.json and still have the same problem.

The problem is reproducible with kayak.com. I have two screens. My left screen (HDMI) is set as primary but is marked as 2 in Settings->System->Display. My right screen (DVI) is marked 1. If I have Firefox on the left screen and do the search on Kayak, the second window pops up on the same screen and stays there. The problem occurs if I move Firefox to the right screen. With the search in Kayak, the second window pops up on the right screen also, but disappears of the screen to the right as soon as the page is completed.

I can live with this situation but I think Firefox should not doing this. It may be related to the screen numbering by Windows 10.

more options

http://kb.mozillazine.org/Dom.disable_window_open_feature.status The Dom.disable_window settings takes away the websites ability to set up new windows in a way that takes away user controls.

JonEw said

I removed xulstore.json and still have the same problem.

How about the Localstore.rdf file?

I have two screens.

I don't know about two screens. If you need more help, I will call out.

more options

Hello FredMcD Problem solved. 1) I set all dom.disable_window True. The second window popped up but stayed on the screen. All seems to be working as I want. I may want to try which parameter solved the problem and return all others to their default 2) I don't have a Localstore.rdf in the profile directory. Is that important? Thank you for your help. Jon

more options

Some files are only created if Firefox needs them. Don't worry about not finding it.

Hello,

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily.

Thank you for contacting Mozilla Support.