Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why doesn't my Firefox browser on my pc stay logged on to my google account?

  • 4 svar
  • 2 har dette problemet
  • 15 views
  • Siste svar av jscher2000

more options

The Firefox browser on my laptop always connects to my google account and I don't have to enter any passwords. However, on my pc, if I want to get to my gmail, I have to enter my gmail address and password. The "Keep me logged in" box is always checked. How do I get it to REMEMBER my google account ??

All Replies (4)

more options

There may be a difference in the way cookies for google.com are handled on the two systems. The "Keep me logged in" checkbox tells Google to set a persistent cookie that is available in a new session after you exit and start Firefox up again, but there are a few ways that Firefox can be set to remove the cookie, and some add-ons and some external utility/security/privacy software also could be removing it.

Let's start in the Privacy options:

"3-bar" menu button (or Tools menu) > Options

In the left column, click Privacy. On the right side:

(A) If the selector is set to "Firefox will: Remember history" change that to "Firefox will: Use custom settings for history" and click the "Exceptions" button. In this box, make sure google.com doesn't have an exception such as Block or Allow for Session. If it has Allow, that's okay.

(B) If the selector is set to "Firefox will: Never remember history" then most likely you are using automatic private browsing and it's normal for cookies to be destroyed between sessions. With this setting, you will always need to log in.

(C) If the selector is set to "Firefox will: Use custom settings for history" then there are a few things to check:

(i) Cookie lifetime - If "Keep until" is set to "I close Firefox" then Firefox will not keep cookies between sessions.

(ii) Exceptions - Click the "Exceptions" button. In this box, make sure google.com doesn't have an exception such as Block or Allow for Session. If it has Allow, that's okay.

(iii) Clear history at shutdown - If this box is checked, click the Settings button to the right to make sure Cookies are not included in what is cleared at shutdown.

Does that help?

more options

A detail like a website remembering you (log you in automatically) is stored in a cookie.

You can use these steps to make a website recognize and remember you:

  • Create a cookie 'allow' exception to keep such cookies, especially in case of secure websites and when cookies expire when Firefox is closed.
  • Tools > Options > Privacy > "Use custom settings for history" > Cookies: Exceptions

Removing cookies from a website makes the website forget about you.


In case you use "Clear history when Firefox closes" or otherwise clear history.

  • do not clear the Cookies
  • do not clear the Site Preferences
  • Clearing "Site Preferences" clears all exceptions for cookies, images, pop-up windows, software installation, passwords, and other website specific data.
  • Clearing Cookies will remove all selected cookies including cookies with an allow exception that you want to keep.
more options

I am having same/similar problem behavior with Firefox and some but NOT all websites. ... Since upgrading to Firefox 42 (Mac), browser does NOT keep me logged in to Verizon webmail account even though I repeatedly click to "Keep Me Signed-in". It logs me out BOTH if I quit that Firefox session and restart later --AND-- if Firefox is left running, the webmail browser window/tab is "inactive" for a period of time THEN I go back to it later.

This behavior did NOT occur in previous version of FF. This behavior also does NOT occur under these same circumstances when using Safari browser. ... I have read posts & replies by others experiencing this same or similar problem behaviors. I DID try : - clearing cache, - deleting all Verizon cookies for possible corruptions, - checking Privacy Settings, being sure to use "Custom Settings" and NOT using Private Browsing - writing exception for cookies to verizon.com & webmail.verizon.com. ... Don't know what else to do. Curious that this does NOT seem affect *most* other sites (that I've noted) AND that it did NOT occur with earlier version of Firefox nor with other browsers. ...

more options

Hi SSStrippoli, since you already posted this as a new question, I suggest continuing there: https://support.mozilla.org/questions/1120032