Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox ignores settings to open homepage on start, and opens previous tabs instead

  • 11 svar
  • 6 har dette problemet
  • 57 views
  • Siste svar av csdaly

more options

On opening Firefox the browser displays my previous session, despite my selecting "show home page" or "show blank screen" on opening.

Valgt løsning

You can check if you have a user.js file in the Firefox profile folder (the System Detail list shows that you have it) that sets the browser.sessionstore.resume_session_once pref to true.

(I notice that the mozillaZine knowledge base is down at the moment of posting this)

The user.js file will only be present if you or other software has created this file and normally won't be present. The user.js file is read each time Firefox is started and initializes preferences to the value specified in this file, so preferences set via user.js can only be changed temporarily for the current session.

You can delete the user.js file if you didn't create this file yourself.

You can use this button to go to the current Firefox profile folder:

Windows hides some file extensions by default. Among them .html and .ini and .js and .txt and you may only see a file name without file extension. You can check the file extension (type) in the properties of the file in Windows Explorer via the right-click context menu.

Les dette svaret i sammenhengen 👍 3

All Replies (11)

more options

Valgt løsning

You can check if you have a user.js file in the Firefox profile folder (the System Detail list shows that you have it) that sets the browser.sessionstore.resume_session_once pref to true.

(I notice that the mozillaZine knowledge base is down at the moment of posting this)

The user.js file will only be present if you or other software has created this file and normally won't be present. The user.js file is read each time Firefox is started and initializes preferences to the value specified in this file, so preferences set via user.js can only be changed temporarily for the current session.

You can delete the user.js file if you didn't create this file yourself.

You can use this button to go to the current Firefox profile folder:

Windows hides some file extensions by default. Among them .html and .ini and .js and .txt and you may only see a file name without file extension. You can check the file extension (type) in the properties of the file in Windows Explorer via the right-click context menu.

more options

I have a similar problem. When I close Firefox I am given the option to "save and quit" or "quit". Regardless of which option I select, the next time I open Firefox it does not open in my home page (as set in options) but attempts to open the tabs from the previous session. It usually tells me that it is unable to recover previous windows and tabs (screenshot attached). Why is this happening?

more options

Hi smcc

Use one of these to close Firefox if you are currently doing that by clicking the close X on the Firefox title bar.

  • "3-bar" menu button > Exit (Power button)
  • Windows: File > Exit
  • Mac: Firefox > Quit Firefox
  • Linux: File > Quit

If you use "Clear history when Firefox closes" to clear Cookies then exclude cookies and instead let the cookies expire when Firefox is closed to make them session cookies.


You can check for problems with the sessionstore.js file in the profile folder that stores session data. When sessionstore.js is deleted you lose App Tabs and Tab Groups and open tabs and you will have to recreate them, so if necessary make a note or bookmark them.

You can use this button to go to the current Firefox profile folder:

See also:

more options

Hi, Cor-el,

Very interesting but not very helpful. When I opened Firefox this morning it came up with the "This is embarrassing" page containing the one tab that I had open when I closed it last night using the top right "X". I used the "Close" button to reach my home page and then used several other web sites before closing Firefox without saving any tabs. I then re-opened Firefox and it opened in my home page.

Your suggestion about closing cookies and history is irrelevant, as I have not altered the settings (which remove cookies on some sites at the end of a session and keep them on other sites) that I have used for years without producing the behaviour I described in my first post.

more options

Having the same problem. All started a few days ago when, for the first time, I selected Firefox to remember my browsing history. Since then, despite selecting 'show my home page' when Firefox starts, it always starts with the last tabs visited. Have tried File -> Exit. Only way I can stop it, is deselecting 'Remember my browsing and download history'. A plain English solution would be appreciated.

more options

The problem continues. Is there really no solution???

more options

A post was flagged as Solved Problem. Please remove that flag. If you don’t, others that can help may not read this post.


Your system details shows; User JS: Yes

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

more options

Note that the last posts are not from the thread owner (Jet3270), but from others (csdal and smc).

Did you check my above reply about a possible user.js file that sets browser.sessionstore.resume_session_once to true?

You can use this button to go to the current Firefox profile folder:

Windows hides some file extensions by default. Among them .html and .ini and .js and .txt and you may only see a file name without file extension. You can check the file extension (type) in the properties of the file in Windows Explorer via the right-click context menu.

more options

Deleting the user.js file through Explorer has worked for me. So thanks very much.

more options

Glad to help. Safe Surfing.

Hello,

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily.

Thank you for contacting Mozilla Support.

more options

cor-el's response is already marked as "chosen solution", so I guess this is taken care of