Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox not saving form history

  • 15 svar
  • 5 har dette problemet
  • 73 views
  • Siste svar av FredMcD

more options

I recently cleared recent history including form and search history. I have now unchecked this box and am using a particular form evey week but it continues not to remember the details I have input several times since I cleared the history. In the Privacy option it is set to "Remember History". If I change this to "use custom settings for history" it shows that "remember form history" is checked.

This seems to be a fault or do I need to keep the privacy setting on "use custom settings for history"? I am using Windows 7 on a 64 bit Toshiba Laptop.

Thank you.

I recently cleared recent history including form and search history. I have now unchecked this box and am using a particular form evey week but it continues not to remember the details I have input several times since I cleared the history. In the Privacy option it is set to "Remember History". If I change this to "use custom settings for history" it shows that "remember form history" is checked. This seems to be a fault or do I need to keep the privacy setting on "use custom settings for history"? I am using Windows 7 on a 64 bit Toshiba Laptop. Thank you.

Valgt løsning

Firefox only has this form fill related pref that is controlled via the setting in Options > privacy

  • browser.formfill.enable

If you have more (other) prefs then they must have been added by an extension.

Les dette svaret i sammenhengen 👍 1

All Replies (15)

more options

Please ensure that you do not have clear history when Firefox closes checked. Also ensure that you do not have a third party program that is clearing this data from Firefox.

more options

Wesley Branton said

Please ensure that you do not have clear history when Firefox closes checked. Also ensure that you do not have a third party program that is clearing this data from Firefox.
more options

Thanks Wesley, But as stated Firefox is set to remember history and the "clear history when FF closes", is not checked.

I think the problem may be in the "about:config" entries concerning forms but I don't know which or what the settings should be. I have recently started using sync as I have another computer, could that have anything to do with it?

I think this is probably afault with FF as my settings in the options concerning history are correct and it is not the website that is preventing the form from auto filling the entries.

Endret av Steven

more options

Does Firefox remember your form history until it closes or just not at all?

more options

Wesley Branton said

Does Firefox remember your form history until it closes or just not at all?
more options

Firefox remembers my browsing history etc., just not an online form that I use regularly. I only use this form so I cannot say whether the problem is isolated to this particular website or not but I can say that the problem has followed my deleting history including form history.

As I have used the form concerned several times since I performed this operation and my settings are all correct for form history to be saved FF should by now have re- remembered my entries for that form. It has not. This indicates a possible fault with FF, not with any of my settings and I suggest this is passed to Mozilla technicians to look into. Thanks for looking into this, Wesley.

more options

No problem. Sorry for any inconvenience.


If you would like to get in touch with someone from our development team, please file a bug report at Bugzilla.

Endret av Wesley Branton

more options

Thanks again Wesley, I will consider filing a Buzilla report if this problem continues.

more options

I have now corrected this problem by changing a setting in about:config.This is a fault with FF and needs to be corrected.

more options

What is the setting you are talking about?

more options

Unfortunately I can't remember exactly but it looked something like "save form history" and it was well down the list. I reset it to default and the next but one time I filled in a regular form I found that when I entered the first letter of each line it offered my details as it had done before the problem arose.

more options

That was very good work. Well Done. Please flag your last post as Solved Problem so other will know.

more options

Valgt løsning

Firefox only has this form fill related pref that is controlled via the setting in Options > privacy

  • browser.formfill.enable

If you have more (other) prefs then they must have been added by an extension.

more options

This might have been the setting that I changed in about:config a few days ago but I'm not sure. I am sure that the "remember form history function" did not work for a number of weeks and that after I had done the change in about:config it started working again- perhaps this was coincidence- i don,t know. I consider the problem to be solved from my point of view but there is clearly something wrong as others have this problem and the fact that it arose with myself in the first place.

more options

There are some programs that change things on the computer without you knowing of the change. Not until something goes wrong.

These add-ons can help;

Settings Guard for Firefox {web link} Detects and resets changes to settings that are frequently done by add-ons and application installers.


These add-ons can be a great help by backing up and restoring Firefox

FEBE (Firefox Environment Backup Extension) {web link} FEBE allows you to quickly and easily backup your Firefox extensions, history, passwords, and more. In fact, it goes beyond just backing up -- It will actually rebuild your saved files individually into installable .xpi files. It will also make backup of files that you choose.

OPIE {web link} Import/Export extension preferences