Zoeken in Support

Vermijd ondersteuningsscams. We zullen u nooit vragen een telefoonnummer te bellen, er een sms naar te sturen of persoonlijke gegevens te delen. Meld verdachte activiteit met de optie ‘Misbruik melden’.

Learn More

Deze conversatie is gearchiveerd. Stel een nieuwe vraag als u hulp nodig hebt.

Trouble with SSL Errors

  • 3 antwoorden
  • 5 hebben dit probleem
  • 4 weergaven
  • Laatste antwoord van MaryFaerie

more options

For the past 48 hours, I have visited multiple websites such as Facebook, Yahoo, Google, and YouTube, and three things have happened: Either the web page has not fully loaded, or I get these two errors - Secure Connection Failed, SSL received a record with an incorrect Message Authentication Code. (Error code: ssl_error_bad_mac_read) and SSL received a record that exceeded the maximum permissible length. (Error code: ssl_error_rx_record_too_long).

I previously asked this question here: https://support.mozilla.org/en-US/questions/991444. The solutions in that question worked for the time being. However, the problem has resurfaced today. Since I have "No Proxy" selected and have IPv6 disabled, is there anything else that could be causing this issue? Thanks.

Alle antwoorden (3)

more options

(Error code: ssl_error_rx_record_too_long)

Last November, the ISP Shaw had a problem that caused this issue for many of their Firefox users on all HTTPS sites. It eventually cleared up.

During the time of the problem, the only effective workaround was to fall back to the older, less secure SSL 3.0 protocol instead of using the newer, more secure TLS protocols. You could try that as a test, but I would change it back as soon as possible.

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste tls and pause while the list is filtered

(3) Double-click the security.tls.version.max preference and change it from 3 to 0 and click OK.

For future reference, the possible values are:

  • 3 = TLS 1.2 (default)
  • 2 = TLS 1.1
  • 1 = TLS 1.0
  • 0 = SSL 3.0 (oldest / weakest)

Does that make any difference?

more options

(Error code: ssl_error_bad_mac_read)

The threads I can find on this indicate it more often is a system problem, although multiple reloads sometimes bypass it. If you haven't already, try turning your router/modem off and on, and shut down/restart Windows. If it persists, consider possible malware.

more options

If it helps anyone I did this:

I reset my DNS to Google's own. Instructions here:

https://pandapow.co/how-to/win-change-dns/

The important thing to note is to disable your internet connection after changing this, then re-enable.

I also followed this to try to clean up whatever caused the problem:

http://www.yourprivatevpn.com/dns_poisoning_en

Don't know how much use it was... but I don't like the idea of some wiley virus lurking around in my cache...