X
Tik hier voor de mobiele versie van de website.

Ondersteuningsforum

Deze conversatie is gearchiveerd. Stel een nieuwe vraag als u hulp nodig hebt.

Fix the following Error code: ssl_error_illegal_parameter_alert

Geplaatst

After upgrading to FF26 I get sites like Yahoo and Facebook that won't open properly. Passwords for yahoo mail won't initially take. I have to recycle the pages 2 and three times before they will operate correctly. I occasionally get the "An error occurred during a connection to www.facebook.com. SSL peer rejected a handshake message for unacceptable content. (Error code: ssl_error_illegal_parameter_alert)".

I have tried doing the recommended fixes posted on the site by deleting the cache and history however, the problem still exists. Additionally, I have completely wiped FF off the computer and reinstalled and nothing has changed. I have Kaspersky Pure 2.0 as my antivirus, but this issue is only occurring on one of my three computers.

After upgrading to FF26 I get sites like Yahoo and Facebook that won't open properly. Passwords for yahoo mail won't initially take. I have to recycle the pages 2 and three times before they will operate correctly. I occasionally get the "An error occurred during a connection to www.facebook.com. SSL peer rejected a handshake message for unacceptable content. (Error code: ssl_error_illegal_parameter_alert)". I have tried doing the recommended fixes posted on the site by deleting the cache and history however, the problem still exists. Additionally, I have completely wiped FF off the computer and reinstalled and nothing has changed. I have Kaspersky Pure 2.0 as my antivirus, but this issue is only occurring on one of my three computers.

Gekozen oplossing

I have this problem without any additional security software beside microsoft one (as described in bugzilla entry) .

I see no point in creating new question. Bugzilla entry clearly describes the problem, shows what server side (apache) sees, too. It just needs some developer that understands SSL to look into it.

Creating another question won't really help. It's not a matter of invalid usage. Also if you google for this error you will find that tons of people have this problem in various conditions (and no solution, only workarounds relying on messing with internal firefox TLS settings)

Dit antwoord in context lezen 6

Aanvullende systeemdetails

Geïnstalleerde plug-ins

  • Shockwave Flash 11.9 r900
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.05
  • 5.1.20913.0
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Motive Plugin for Mozilla Browsers
  • Motive Management Plug-in for Mozilla Browsers
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Toepassing

  • Useragent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0

Meer informatie

kobe 441 oplossingen 5048 antwoorden

Hello,

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that turns off some settings and disables most add-ons (extensions and themes).

(If you're using an added theme, switch to the Default theme.)

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu by clicking on the Restart with Add-ons Disabled... menu item:
FirefoxSafeMode

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

Once you get the pop-up, just select "'Start in Safe Mode" Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

Thank you.

Hello, '''Try Firefox Safe Mode''' to see if the problem goes away. [[Troubleshoot Firefox issues using Safe Mode|Firefox Safe Mode]] is a troubleshooting mode that turns off some settings and disables most add-ons (extensions and themes). ''(If you're using an added theme, switch to the Default theme.)'' If Firefox is open, you can restart in Firefox Safe Mode from the Help menu by clicking on the '''Restart with Add-ons Disabled...''' menu item:<br> [[Image:FirefoxSafeMode|width=520]]<br><br> If Firefox is not running, you can start Firefox in Safe Mode as follows: * On Windows: Hold the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * On Mac: Hold the '''option''' key while starting Firefox. * On Linux: Quit Firefox, go to your Terminal and run ''firefox -safe-mode'' <br>(you may need to specify the Firefox installation path e.g. /usr/lib/firefox) ''Once you get the pop-up, just select "'Start in Safe Mode"'' [[Image:Safe Mode Fx 15 - Win]] '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, and you need to figure out which one. Please follow the [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] article to find the cause. ''To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' When you figure out what's causing your issues, please let us know. It might help others with the same problem. Thank you.

Vraageigenaar

Tried all of that, and there was no change. Is there a way to revert back to a previous version of FF, as this wasn't a problem until FF26 came on line. By looking at other posts, it appears this is a more wide spread problem. Other suggestions?

Tried all of that, and there was no change. Is there a way to revert back to a previous version of FF, as this wasn't a problem until FF26 came on line. By looking at other posts, it appears this is a more wide spread problem. Other suggestions?
jscher2000
  • Top 10 Contributor
8899 oplossingen 72800 antwoorden

In Kaspersky PURE 2.0, try turning off Encrypted connection scanning in the Additional/Network options. This article shows where that checkbox is: http://support.kaspersky.com/7935

In Kaspersky PURE 2.0, try turning off Encrypted connection scanning in the Additional/Network options. This article shows where that checkbox is: http://support.kaspersky.com/7935

Vraageigenaar

That function was already disabled, still having problems.

That function was already disabled, still having problems.
jscher2000
  • Top 10 Contributor
8899 oplossingen 72800 antwoorden

Hi shsmaster40, could you dig into the objectionable certificates in a little more detail?

If you have already added exceptions:

orange Firefox button (or Tools menu) > Options > Advanced > Certificates mini-tab > "View Certificates" button > Servers tab

Click a certificate and use the View button. The kind of issuer ("Issued by") you might find is:

  • Name associated with your security software, such as ESET, BitDefender, Kaspersky, etc.
  • Sendori (indicates unwanted software from Sendori)
  • FiddlerRoot (indicates unwanted software named similarly to BrowserSafeguard, BrowserSafe, SafeGuard)
  • Something else

If you haven't added any exceptions:

You can view the site's certificate if you click the Add Exception button and then the View button. (If View is grayed, click Get Certificate above it first.)

Hi shsmaster40, could you dig into the objectionable certificates in a little more detail? ''If you have already added exceptions:'' orange Firefox button (or Tools menu) > Options > Advanced > Certificates mini-tab > "View Certificates" button > Servers tab Click a certificate and use the View button. The kind of issuer ("Issued by") you might find is: * Name associated with your security software, such as ESET, BitDefender, Kaspersky, etc. * Sendori (indicates unwanted software from Sendori) * FiddlerRoot (indicates unwanted software named similarly to BrowserSafeguard, BrowserSafe, SafeGuard) * Something else ''If you haven't added any exceptions:'' You can view the site's certificate if you click the Add Exception button and then the View button. (If View is grayed, click Get Certificate above it first.)

Vraageigenaar

So that didn't work, so I tried to upgrade my Kaspersky Pure to 3.0 and it appears to have fixed the problem. It seems there is some issues between FF26 and some of Kaspersky programs. Thanks for the help!

So that didn't work, so I tried to upgrade my Kaspersky Pure to 3.0 and it appears to have fixed the problem. It seems there is some issues between FF26 and some of Kaspersky programs. Thanks for the help!
arekm 1 oplossingen 4 antwoorden

Nuttig antwoord

It looks to be firefox bug - tracked here https://bugzilla.mozilla.org/show_bug.cgi?id=951156

(and unfortunately people still claim it is kaspersky fault while it happens for users not using kaspersky, too)

It looks to be firefox bug - tracked here https://bugzilla.mozilla.org/show_bug.cgi?id=951156 (and unfortunately people still claim it is kaspersky fault while it happens for users not using kaspersky, too)
jscher2000
  • Top 10 Contributor
8899 oplossingen 72800 antwoorden

Hi arekm, do you have this problem with some other security software, other than Kaspersky, that intercepts secure connections? You may want to start a new question and provide details on some certificates that Firefox rejecting to see whether we can spot the pattern.

You can start a new question at the following link. Scroll down past the suggestions to continue with the form (I think it has 3 different screens). https://support.mozilla.org/en-US/questions/new/desktop/websites

Hi arekm, do you have this problem with some other security software, other than Kaspersky, that intercepts secure connections? You may want to start a new question and provide details on some certificates that Firefox rejecting to see whether we can spot the pattern. You can start a new question at the following link. Scroll down past the suggestions to continue with the form (I think it has 3 different screens). https://support.mozilla.org/en-US/questions/new/desktop/websites
arekm 1 oplossingen 4 antwoorden

Gekozen oplossing

I have this problem without any additional security software beside microsoft one (as described in bugzilla entry) .

I see no point in creating new question. Bugzilla entry clearly describes the problem, shows what server side (apache) sees, too. It just needs some developer that understands SSL to look into it.

Creating another question won't really help. It's not a matter of invalid usage. Also if you google for this error you will find that tons of people have this problem in various conditions (and no solution, only workarounds relying on messing with internal firefox TLS settings)

I have this problem without any additional security software beside microsoft one (as described in bugzilla entry) . I see no point in creating new question. Bugzilla entry clearly describes the problem, shows what server side (apache) sees, too. It just needs some developer that understands SSL to look into it. Creating another question won't really help. It's not a matter of invalid usage. Also if you google for this error you will find that tons of people have this problem in various conditions (and no solution, only workarounds relying on messing with internal firefox TLS settings)
adminii 0 oplossingen 1 antwoorden

I found the root cause of this error in my case. It looks like the certificate error was due to an old/expired intermediate certificate. After deleting the old intermediate certificate the firefox displayed without error.

I found the root cause of this error in my case. It looks like the certificate error was due to an old/expired intermediate certificate. After deleting the old intermediate certificate the firefox displayed without error.