Zoeken in Support

Vermijd ondersteuningsscams. We zullen u nooit vragen een telefoonnummer te bellen, er een sms naar te sturen of persoonlijke gegevens te delen. Meld verdachte activiteit met de optie ‘Misbruik melden’.

Learn More

Deze conversatie is gearchiveerd. Stel een nieuwe vraag als u hulp nodig hebt.

HTML 5 videos (like Vine) won't play

  • 45 antwoorden
  • 883 hebben dit probleem
  • 184832 weergaven
  • Laatste antwoord van nyet

more options

Some HTML5 videos won't play in my Firefox browser.

This vine for example (https://vine.co/v/b3v5h3Piwt7) only shows up as a static image. I can click the mute/audio button though, but it won't play. When I look at the webconsole when I load the page then 2 javascript warnings show up, the first one say that the Mediasource [long url here] can't be encoded and another one says loading of all candidate sources failed. loading media paused.

I'm using Firefox 21.0 and I tried to run Firefox in safe mode with disabled add-ons, and I also tried to reinstall it, but without success.

Thanks in advance.

Gekozen oplossing

You can try to set the media.windows-media-foundation.enabled pref to false on the about:config page to disable the built-in mp4 media player.

Dit antwoord in context lezen 👍 253

Alle antwoorden (20)

more options

speedo, I don't know anything about instagram but even so, I think it would be better to ask a new question and if possible, post a link to a problem video, since this question is "solved". You can use this article as a starting point: Get community support.

more options

Problem solved! I downloaded and installed Firefox 24.0 Beta. Apparently Mozilla programming team made all the right changes in the new release. Now all videos starting working on Vine, Youtube, Yahoo and BBC, etc

Link: http://www.mozilla.org/en-US/firefox/channel/#beta

more options

Cor-el's about:config page solution worker for me on firefox 23. Thanks man, nice work.

more options

Read what I just posted. There is an issue with the latest upgrade to Firefox. It does not allow a link to work at an unprotected site if from a protected site. It is referred to as a mixed page from what I was told. It has created havoc for me. There is a fix that you must do each time you use the link and it doesn't remember it. If you sign out and come back into your protected site, you have to start all over. What a disaster...

more options

A way to prevent this could be to disable this new feature by setting the security.mixed_content.block_active_content pref to false on the about:config page.

You can contact the website(s) and point them to this article:

You can also look at this extension:

Bewerkt door cor-el op

more options

If you make the fix that you suggested, it may compromise the security of your system. I'm not suggesting that for my students because I don't want them to potentially be exposed to a risk.

more options

this "fix" just caused a world of other problems. going the about:config route. ruins twitter homepage where it loads incorrectly. we need a real fix to this vine issue.

more options

I don't understand why this is ONLY a problem for FireFox and SeaMonkey, and that nobody is recognizing that it is a Mozilla thing, not a System thing.

All the other browsers I have (Chrome, IE, Safari) have NO ISSUES with playing vines without having to make changes to the system configuration file.

This sort of idiocy makes me want to drop Firefox as my preferred browser, and just get rid of it, while morons continue to suggest that I hack into my security settings, rather than FIXING THE BUG IN FIREFOX.

And yes, it is still there in v. 24.0, both the beta and official release.

By the way, I dug my old Win-XP SP3 laptop out of the graveyard, loaded the latest Firefox, and that antique plays vines just fine. So again, it is a problem specifically with FF under Win-Vista (and maybe other more recent Windows).

Bewerkt door TrainerSteve op

more options

Disabling embedded html5 video is NOT a solution.

http://userscripts.org/scripts/review/176997

more options

Actual useful information about this bug is here:

https://bugzilla.mozilla.org/show_bug.cgi?id=881072

Seems as though the src attribute on the vine embedded video object is not being set properly by the js interpreter

more options

Fix is apparently in github.

https://github.com/heff/video-js/commit/1d82ea7d2aa075e5f4990574378c15207c30dc4f

Unclear why vine doesn't seem terribly concerned about the fact that their entire site is useless in firefox

more options

On the 3 Vine pages I saw linked in this thread, the necessary information is in the document, so you can use a bookmarklet to fix the broken video tag. For those of you unfamiliar with the term, a bookmarklet is a script you run by clicking a bookmark, typically on your Bookmarks Toolbar.

I posted a sample button on this page for testing: http://dev.jeffersonscher.com/bookmarklets.html

When you see the video isn't working, click the button and the script fills in the missing information and the video should play.

Note #1: I tested on Windows 7 with MPEG support enabled.

Note #2: The tags in the pages I tested all referenced Twitter, so I used that exact information. If Vine is used for other sites, the bookmarklet may not work in those pages. Please post example URLs and I'll see whether I can generalize the bookmarklet to work there, too.

Well, maybe it's better than nothing.

Bewerkt door jscher2000 op

more options

Unfortunately, it doesn't seem that vine has any intention of fixing their js.

more options

An easy way of doing it manually while still maintaining HTML5 support, is to add /card at the end of the web addresses. ie https://vine.co/v/hpPHmntzMjY doesn't work. But https://vine.co/v/hpPHmntzMjY/card does. :)

more options

Hi Tomgeek, that's a great discovery. It seems when I view the /card page Firefox doesn't resize the video, so to see the example, I used full screen (F11 to enter and exit). Not sure if this is a setting I have or an issue with the page.

more options

Just found another way of loading vines defiantly works on ver. 25. If you click the embed button it will give you some copy and paste code but also a preview window that works perfectly.

more options

Can verify that it finally also works for me in Firefox 26 beta 1 (Vista 32 platform), and in Seamonkey 2.21 and 2.22 - without tampering with security settings, config files, of embedding anything. Just click and it plays. Problem finally solved for me.

But why did it take so long to solve such a basic problem??? Months and months this has been a complaint. Was it complete denial and laziness at the code writing and working level, combined with a random choice to try to get Users to fix a bug in the code by screwing around with their sensitive MS config file and security settings? When all the other non-Mozilla browsers worked just fine without user tampering? Really? C'mon!

Bewerkt door TrainerSteve op

more options

Because it wasn't a mozilla bug. It was a bug in vine's javascript.

more options

Oh Really? A "bug in Vine's javascript" that ONLY affected Firefox and Seamonkey? All other browsers had no such issue - Chrome, Safari, and even IE had no problem playing Vines. Only Firefox and Seamonkey had the problem. And the problem only went away with the latest releases of the two. How fascinating.

Bewerkt door TrainerSteve op

more options

Read the whole thread. The source of the bug is bad javascript. This sort of thing is very common; some implementations of the js interpreter react differently to bugs in the source.

As I posted above, the true fix is here:

https://github.com/heff/video-js/commit/1d82ea7d2aa075e5f4990574378c15207c30dc4f

Just because there is a js interpreter side workaround for the bug does not mean the bug isn't in the source.

  1. 1
  2. 2
  3. 3