X
Tik hier voor de mobiele versie van de website.

Ondersteuningsforum

Deze conversatie is gearchiveerd. Stel een nieuwe vraag als u hulp nodig hebt.

Everytime I open up Firefox, two tabs open up. The first is a Firefox page and the other is my home page. How do I stop the first tab from opening?

Geplaatst

I would like to stop the firefox tab (what I assume is the firefox home page) and only want one tab to open when I bring up my browser.

I would like to stop the firefox tab (what I assume is the firefox home page) and only want one tab to open when I bring up my browser.

Gekozen oplossing

I had this happen after I updated Firefox. I got rid of the second Mozilla "home Page" by doing the following: Click Tools Click Options Click General Tab In the "When Firefox Starts" drop-down menu, choose "Show My Home Page". Just below that, you will see; Home Page, with a space for the URL of the home page you want to use typed into it. Check it carefully. My second pop-up page was caused because of an improper URL. It was showing the following: http://www.abcdef.com/ (my home page), HOWEVER, there was additional information on the right of the forward slash after .com All I did was delete this additional information, closed my browser, restarted it, and the second "Home Page" NEVER came back. Note: If you restore your browser defaults, you may have to fix the issue again.

Dit antwoord in context lezen 1

Aanvullende systeemdetails

Geïnstalleerde plug-ins

  • Google Update
  • Shockwave Flash 11.6 r602
  • iTunes Detector Plug-in
  • 5.1.20125.0
  • Adobe PDF Plug-In For Firefox and Netscape "9.5.3"
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • DjVu browser plugin
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • NPWLPG

Toepassing

  • Useragent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0

Meer informatie

Nathan 0 oplossingen 2 antwoorden

Have you tried going into Firefox-Options-Options and then click on the General tab. Under something labeled Startup there should be something called When Firefox starts. It has 3 options, choose the Show my homepage. In the address bar below type in the URL of the website you want opened when you start your browser then click ok.

Have you tried going into''' Firefox-Options-Options''' and then click on the '''General''' tab. Under something labeled '''Startup''' there should be something called '''When Firefox starts'''. It has 3 options, choose the '''Show my homepage'''. In the address bar below type in the URL of the website you want opened when you start your browser then click '''ok'''.

Bewerkt door Nathan op

Vraageigenaar

I have tried that but it did not get rid of the first tab. When I open up Firefox, two tabs open up. The first one is the Welcome to Firefox page and the second is my homepage. I know this is a luxury problem. I just do not want the Welcome to Firefox page to open up anymore but I have no idea how to stop it from opening along with my homepage.

I have tried that but it did not get rid of the first tab. When I open up Firefox, two tabs open up. The first one is the Welcome to Firefox page and the second is my homepage. I know this is a luxury problem. I just do not want the Welcome to Firefox page to open up anymore but I have no idea how to stop it from opening along with my homepage.
TheOldFox 86 oplossingen 620 antwoorden

Some suggestions in these articles:


Other - Check your Plugins and update as needed.

  1. Check your Plugins - https://www.mozilla.org/en-US/plugincheck/
  2. Shockwave Flash 11.6 r602
  3. Adobe PDF Plug-In For Firefox and Netscape "9.5.3"
Some suggestions in these articles: *Firefox can open multiple home pages. Look at ''Options > General > Home page''. Multiple home pages are separated by the "|" keyboard character **https://support.mozilla.com/kb/Firefox+has+just+updated+tab+shows+each+time+you+start+Firefox **https://support.mozilla.com/kb/How+to+set+the+home+page *Also see Preferences not saved - http://kb.mozillazine.org/Preferences_not_saved *Also see Reset Firefox: **Reset Firefox - https://support.mozilla.org/kb/reset-firefox-easily-fix-most-problems **Recovering data (after Reset) - https://support.mozilla.org/kb/Recovering+important+data+from+an+old+profile **Transfer data to a new Profile - http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox ------------------------- Other - Check your Plugins and update as needed. #Check your Plugins - https://www.mozilla.org/en-US/plugincheck/ #Shockwave Flash 11.6 r602 #*See - https://support.mozilla.org/en-US/kb/keep-flash-up-to-date-and-troubleshoot-problems #*See - https://support.mozilla.org/en-US/kb/install-flash-plugin-view-videos-animations-games #Adobe PDF Plug-In For Firefox and Netscape "9.5.3" #*See - https://support.mozilla.org/en-US/kb/use-adobe-reader-plugin-view-or-download-pdf-files

Bewerkt door TheOldFox op

KarMar6361 0 oplossingen 4 antwoorden

I recently got this same problem when firefox updated to the latest version (23.0.1) and found that by editing the file (user.js) in the firefox profiles folder. I found it had more than one startup homepage lines in the text. I deleted all other startup homepage lines and left the one with my correct startup homepage.

Hope this is of help.

I recently got this same problem when firefox updated to the latest version (23.0.1) and found that by editing the file (user.js) in the firefox profiles folder. I found it had more than one startup homepage lines in the text. I deleted all other startup homepage lines and left the one with my correct startup homepage. Hope this is of help.
cor-el
  • Top 10 Contributor
  • Moderator
17578 oplossingen 158993 antwoorden

The user.js file is only present if you or other software has created it, so normally it wouldn't be there.
You can check its content with a plain text editor if you didn't create this file yourself.

The user.js file is read each time you start Firefox and initializes preferences to the value specified in this file, so preferences set via this file can only be changed temporarily for the current session.

The user.js file is only present if you or other software has created it, so normally it wouldn't be there.<br /> You can check its content with a plain text editor if you didn't create this file yourself. The user.js file is read each time you start Firefox and initializes preferences to the value specified in this file, so preferences set via this file can only be changed temporarily for the current session.
braverydude 0 oplossingen 12 antwoorden

I just upgraded to Firefox 23 and now I am also having Firefox open the "Welcome to Firefox" update tab every time I start Firefox. If I close all tabs and exit Firefox and restart, the "welcome" tab comes back. I have no home page set in my options.

I tried uninstalling Firefox including erasing all user data and reinstalling, but the "Welcome to Firefox" tab is still here!! Very frustrating.

I just upgraded to Firefox 23 and now I am also having Firefox open the "Welcome to Firefox" update tab every time I start Firefox. If I close all tabs and exit Firefox and restart, the "welcome" tab comes back. I have no home page set in my options. I tried uninstalling Firefox including erasing all user data and reinstalling, but the "Welcome to Firefox" tab is still here!! Very frustrating.
cor-el
  • Top 10 Contributor
  • Moderator
17578 oplossingen 158993 antwoorden

You can check for problems with preferences.

Rename or delete the prefs.js file and possible numbered prefs-##.js files and a possible user.js file to reset all prefs to the default value.

You can check for problems with preferences. Rename or delete the prefs.js file and possible numbered prefs-##.js files and a possible user.js file to reset all prefs to the default value. *http://kb.mozillazine.org/Preferences_not_saved *http://kb.mozillazine.org/Resetting_preferences
braverydude 0 oplossingen 12 antwoorden

Hey cor-el thanks for the reply. Unfortunately this did not help. Firefox is successfully saving my preferences without a problem. And when I did go in and rename my prefs.js file, it re-created a new one for me but STILL the Welcome to Firefox tab opens up every time.

Interesting sidebar: If I close Firefox and save open tabs, the Welcome to Firefox update tab does not open. Only when I shut down Firefox and close all tabs does it come back. Arrrggghhh!

Hey cor-el thanks for the reply. Unfortunately this did not help. Firefox is successfully saving my preferences without a problem. And when I did go in and rename my prefs.js file, it re-created a new one for me but STILL the Welcome to Firefox tab opens up every time. Interesting sidebar: If I close Firefox and save open tabs, the Welcome to Firefox update tab does not open. Only when I shut down Firefox and close all tabs does it come back. Arrrggghhh!
Wesley Branton
  • Top 10 Contributor
644 oplossingen 5241 antwoorden

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • Open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Once you get the pop-up, just select "'Start in Safe Mode"

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

Please report back soon.

'''Try Firefox Safe Mode''' to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons. ''(If you're not using it, switch to the Default theme.)'' * Open the Help menu and click on the '''Restart with Add-ons Disabled...''' menu item while Firefox is running. ''Once you get the pop-up, just select "'Start in Safe Mode"'' '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, and you need to figure out which one. Please follow the [[Troubleshooting extensions and themes]] article for that. ''To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' Please report back soon.
cor-el
  • Top 10 Contributor
  • Moderator
17578 oplossingen 158993 antwoorden

Did you check if there is a user.js file?

Try to delete the compatibility.ini file as well.


Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be careful not to copy corrupted files.

Did you check if there is a user.js file? Try to delete the compatibility.ini file as well. ---- Create a new profile as a test to check if your current profile is causing the problems. See "Creating a profile": *https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Profile_issues If the new profile works then you can transfer some files from an existing profile to the new profile, but be careful not to copy corrupted files. *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox
braverydude 0 oplossingen 12 antwoorden

Hi ComputerWhiz,

Just tried it. Help, Restart with Add-ons Disabled, Start in Safe Mode.

The "Welcome to Firefox" tab opened up even while in Safe Mode.

Bizarre.

Thanks for the help. Any other thoughts?

Hi ComputerWhiz, Just tried it. Help, Restart with Add-ons Disabled, Start in Safe Mode. The "Welcome to Firefox" tab opened up even while in Safe Mode. Bizarre. Thanks for the help. Any other thoughts?
braverydude 0 oplossingen 12 antwoorden

Hi cor-el,

No dice. Created a new profile. "Welcome to Firefox" tab still opens. SOOO annoying.

I also tried a full reset of Firefox - no change.

Finally, as I mentioned above, I did a full uninstall, reinstall which did no good.

Interestingly, here's the URL in the address bar for the "Welcome to Firefox" tab - http://www.mozilla.org/en-US/firefox/23.0.1/whatsnew/?oldversion=16.0.2

It references "old version 16.0.2" - is there a reference somewhere in the Windows registry to the old Firefox version data and Firefox is getting hung up on that? I would think after uninstalling, doing a full reboot and then reinstalling from scratch, there would be no "old version" data...

Hi cor-el, No dice. Created a new profile. "Welcome to Firefox" tab still opens. SOOO annoying. I also tried a full reset of Firefox - no change. Finally, as I mentioned above, I did a full uninstall, reinstall which did no good. Interestingly, here's the URL in the address bar for the "Welcome to Firefox" tab - http://www.mozilla.org/en-US/firefox/23.0.1/whatsnew/?oldversion=16.0.2 It references "old version 16.0.2" - is there a reference somewhere in the Windows registry to the old Firefox version data and Firefox is getting hung up on that? I would think after uninstalling, doing a full reboot and then reinstalling from scratch, there would be no "old version" data...
Wesley Branton
  • Top 10 Contributor
644 oplossingen 5241 antwoorden

@braverydude

When you say, "The "Welcome to Firefox" tab opened up even while in Safe Mode", do you mean that was the only page that opened in Safe Mode?

If this is the only page that opened in Safe Mode and the problem does not occur in Safe Mode, then the issue is caused by an extension installed on Firefox.

<b>@braverydude</b> When you say, "The "Welcome to Firefox" tab opened up even while in Safe Mode", do you mean that was the only page that opened in Safe Mode? If this is the only page that opened in Safe Mode and the problem does not occur in Safe Mode, then the issue is caused by an extension installed on Firefox.
KarMar6361 0 oplossingen 4 antwoorden

Hi braverydude

Have you tried to remove the

user_pref("browser.startup.homepage", "http://www.mozilla.org/en-US/firefox/23.0.1/whatsnew/?oldversion=16.0.2

line from the user.js file, I had to do this even after full resetting of firefox.

I found the following 2 lines in my user.js file located at C:\Users\xxxxxxx\AppData\Roaming\Mozilla\Firefox\Profiles\xxxxxxxxxx (The x's are different on your computer) and with view hidden folders activated in folder options. I put homepage into find box on the user.js opened edit page. and removed the line in bold and removed the empty line, closed and saved then reopen firefox.

user_pref("browser.startup.homepage", "http://www.google.com.au/");

user_pref("browser.startup.homepage", "http://www.mozilla.org/en-US/firefox/23.0.1/whatsnew/?oldversion=xxxx");

'''Hi braverydude''' Have you tried to remove the user_pref("browser.startup.homepage", "http://www.mozilla.org/en-US/firefox/23.0.1/whatsnew/?oldversion=16.0.2 line from the user.js file, I had to do this even after full resetting of firefox. I found the following 2 lines in my user.js file located at C:\Users\xxxxxxx\AppData\Roaming\Mozilla\Firefox\Profiles\xxxxxxxxxx '''(The x's are different on your computer)''' and with view hidden folders activated in folder options. I put ''homepage'' into ''find box'' on the user.js opened edit page. and removed the line in bold and removed the empty line, closed and saved then reopen firefox. user_pref("browser.startup.homepage", "http://www.google.com.au/"); '''user_pref("browser.startup.homepage", "http://www.mozilla.org/en-US/firefox/23.0.1/whatsnew/?oldversion=xxxx");'''
braverydude 0 oplossingen 12 antwoorden

Hi ComputerWhiz,

Thanks for your help but when I restart in Safe mode, the "Welcome to Firefox" tab opens along with my home page or any other tabs I had opened before I switched to safe mode.

Hi ComputerWhiz, Thanks for your help but when I restart in Safe mode, the "Welcome to Firefox" tab opens along with my home page or any other tabs I had opened before I switched to safe mode.
braverydude 0 oplossingen 12 antwoorden

Hi KarMar6361,

Thanks for the advice. Unfortunately, when I browse to that folder, I don't have a user.js file in that folder. Any other thoughts?

Hi KarMar6361, Thanks for the advice. Unfortunately, when I browse to that folder, I don't have a user.js file in that folder. Any other thoughts?
cor-el
  • Top 10 Contributor
  • Moderator
17578 oplossingen 158993 antwoorden

Note that Windows hides some file extensions by default.
Among them are .html and .ini and .js and .txt, so you may only see a name without file extension. You can see the real file type if you open the Properties via the right-click context menu

Did you try to delete the pres.js file and possible numbered prefs-##.js files to reset all preferences?

You can also try to delete the compatibility.ini file in the Firefox profile folder.

Note that Windows hides some file extensions by default.<br /> Among them are .html and .ini and .js and .txt, so you may only see a name without file extension. You can see the real file type if you open the Properties via the right-click context menu Did you try to delete the pres.js file and possible numbered prefs-##.js files to reset all preferences? *http://kb.mozillazine.org/Preferences_not_saved You can also try to delete the compatibility.ini file in the Firefox profile folder.

Bewerkt door cor-el op

braverydude 0 oplossingen 12 antwoorden

Hi cor-el,

Thanks again you have been really helpful (even though the problem isn't solved yet!).

Anyway, here's a screenshot of my profiles folder. No user.js and yes, I did try deleting the prefs.js but that had no effect on the problem. The "Welcome to Firefox" tab still opens.

It opens in Safe mode. It opens if I delete my prefs.js file. It opens even after a full uninstall and reinstall of Firefox.

I am at a loss.

Thanks again.

Hi cor-el, Thanks again you have been really helpful (even though the problem isn't solved yet!). Anyway, here's a screenshot of my profiles folder. No user.js and yes, I did try deleting the prefs.js but that had no effect on the problem. The "Welcome to Firefox" tab still opens. It opens in Safe mode. It opens if I delete my prefs.js file. It opens even after a full uninstall and reinstall of Firefox. I am at a loss. Thanks again.
braverydude 0 oplossingen 12 antwoorden

Here's what happens when I restart in Safe Mode - see screenshot. "Welcome to Firefox" tab plus my home page (Yahoo). My Yahoo is the only page listed in my homepage options box.

Also here's an interesting tidbit: when I open up Firefox by clicking a hyperlink directly in an email, Firefox only opens the page related to the hyperlink - meaning no Welcome To page. But when I exit and start Firefox from the Start menu, my beloved "Welcome to Firefox" tab is back again!

Here's what happens when I restart in Safe Mode - see screenshot. "Welcome to Firefox" tab plus my home page (Yahoo). My Yahoo is the only page listed in my homepage options box. Also here's an interesting tidbit: when I open up Firefox by clicking a hyperlink directly in an email, Firefox only opens the page related to the hyperlink - meaning no Welcome To page. But when I exit and start Firefox from the Start menu, my beloved "Welcome to Firefox" tab is back again!
cor-el
  • Top 10 Contributor
  • Moderator
17578 oplossingen 158993 antwoorden

Note that is shows in the screenshot: oldversion=16.0.2

Did you try to delete or at least check the content of the compatibility.ini file as this file looks like a possible cause?

Note that is shows in the screenshot: oldversion=16.0.2 Did you try to delete or at least check the content of the compatibility.ini file as this file looks like a possible cause?