Zoeken in Support

Vermijd ondersteuningsscams. We zullen u nooit vragen een telefoonnummer te bellen, er een sms naar te sturen of persoonlijke gegevens te delen. Meld verdachte activiteit met de optie ‘Misbruik melden’.

Learn More

Deze conversatie is gearchiveerd. Stel een nieuwe vraag als u hulp nodig hebt.

Font is messed up on Firefox 17.0

  • 109 antwoorden
  • 169 hebben dit probleem
  • 32119 weergaven
  • Laatste antwoord van Merecat

more options

Just updated to FF17.0 and the fonts look awful, something like when the ClearType is enabled in Windows. I have ClearType disabled cause I hate the look of the fonts with it enabled, and now Firefox looks like it's all over it. Font is like bolded. What happened? Can I disable it somewhere in Firefox?

Gekozen oplossing

Hey guys! Thanks to everyone who helped us in troubleshooting this. We are fairly certain it's an azure problem. There is a patch in the works and setting gfx.content.azure.enabled = False seems to work in the meantime. I don't know if the patch will be part of a chemspill or wait until 18. Thanks for your help and patience.

Happy Thanksgiving!

Dit antwoord in context lezen 👍 17

Alle antwoorden (20)

more options

Nvidia Geforce GTX 670, Win 8 x64 Pro, driver version 310.61 beta

more options

To (possibly) resolve this without disabling hardware acceleration/Direct2D, try changing the setting "gfx.content.azure.enabled" to false in about:config and then restarting the browser.

more options

I've the same problem.

AMD ATI Mobility Radeon HD 4300 Driver 8.821-110126a-112965C-ATI

more options

Thanks. gfx.content.azure.enabled = False worked for me (in place of disabling hardware acceleration).

more options

@jfkthame, @ecarlson It isn't final remedy but only next temporary solution. This only disables 2D API named Azuro, where probably problem is hidden. It is only step on the way to identify and fix core of the problem.

Bewerkt door ad_verbum op

more options

Gekozen oplossing

Hey guys! Thanks to everyone who helped us in troubleshooting this. We are fairly certain it's an azure problem. There is a patch in the works and setting gfx.content.azure.enabled = False seems to work in the meantime. I don't know if the patch will be part of a chemspill or wait until 18. Thanks for your help and patience.

Happy Thanksgiving!

more options

It's serious? Wait Firefox 18? I'm not sure whether I should laugh or cry...

more options

Same problem here, I have cleartype disabled in Win7.

more options

"I don't know if the patch will be part of a chemspill or wait until 18."

- "It's serious? Wait Firefox 18? I'm not sure whether I should laugh or cry... "

I agree, but at least they're fixing it. :/

Bewerkt door Vitdom op

more options

You guys realize you don't have to live with the text till then right? It was posted how to get it back to normal in the meantime:

  1. Go to about:config
  2. Find and set gfx.content.azure.enabled to false
  3. Restart the browser

While I think many people underestimate how awful ClearType is for us who prefer pixel-perfect text, and it would be a smart move to push an update for publicity reasons, it sounds like some of you are worrying about having to deal with it for a long time. That just isn't the case.

Bewerkt door Aeroxima op

more options

I could never understand what's the point of ClearType. Font just looks awful with it. The blurriness and the reddish outline in some places, why would anyone want that? There must be something behind it, but I just don't see it.

more options

You can set the gfx.content.azure.enabled pref to false or if this didn't help disable Direct2D by setting the gfx.direct2d.disabled pref to true on the about:config page and leave hardware acceleration otherwise enabled.

more options

I have a font issue after upgrading to Firefox 17 on MacPro.

I don't have gfx.content.azure.enabled, gfx.direct2d.disabled in about:config.

See my screenshot.

A space appears where there isn't one. Example

Observed: "text1 text2"

Expected: "text1text2"

Bewerkt door pennyblossoms op

more options

For Windows users, the blurry fonts issue will be fixed in Firefox 17.0.1, which should be released very soon (hopefully, tomorrow). More info here:

more options

Once for all, the final solution to the ClearShit

Simple add the following two lines in Pref.fs

/* Disable the putain de Cleartype in the webpages */ user_pref("gfx.downloadable_fonts.enabled", false);

Simple test page: http://support.mozilla.org/en-US/questions/796596

Technitronik

Bewerkt door Technitronik op

more options

Updated to 17.0.1 didn't help....same shitty blurry fonts

more options

Hm, it works for me. gfx.content.azure.enabled set to true and I don't have blurry fonts.

more options

Firefox 17.0.1, cleartype off, gfx.content.azure.enabled set to true (default) and I always have blurry fonts.

And cleartype is definitely enabled on my firefox. Why firefox transgressing the user preferences? For IE9, it is understandable, but for firefox ... new policy?

more options

They released 17.0.1 to fix the blurry fonts without have to go to the config and change the azure.

So the patch didn't worked....

Bewerkt door forhike op

more options

Violon, forhike: could you post a screenshot of what you're seeing in FF 17.0.1 (with ClearType OFF), please? Does this affect ALL fonts, or only certain ones?

  1. 1
  2. 2
  3. 3
  4. 4
  5. 5
  6. 6