Zoeken in Support

Vermijd ondersteuningsscams. We zullen u nooit vragen een telefoonnummer te bellen, er een sms naar te sturen of persoonlijke gegevens te delen. Meld verdachte activiteit met de optie ‘Misbruik melden’.

Learn More

Deze conversatie is gearchiveerd. Stel een nieuwe vraag als u hulp nodig hebt.

Navigation, menu commands and Bookmarks toolbars all disappear

  • 12 antwoorden
  • 5 hebben dit probleem
  • 1260 weergaven
  • Laatste antwoord van monsieurms

more options

Hi---started up and suddenly ---No Navigation buttons or customized buttons --no bookmarks toolbar --no box in which to enter a URL and change to another page --no menu commands --pretty much nothing, in fact, except the content of my home page. There's not even the series of commands for "about" or "help" NOTHING

Now, I discovered by accident that if I click on a link from my portal (netvibes) that happens to open in a new window, then all my old stuff appears.

But every time I open the first instance of the browser as a default--it's unuseable as it even lacks a place to put a url to change sites!

I've tried right-clicking along the strip as I saw in a FAQ; all I get are Windows commands (restore, minimize, close, and a nview command added long ago by my video card), but no options to CUSTOMIZE and or VIEW and restore toolbars, etc-

I tried f11 to make sure that I was not accidentally running full screen (although clearly I was not) and that test demonstrated I was not.

I hit f10---nothing happened.

When I right click elsewhere on the page (other than on a link from some feed on my portal), it gives me a host of commands from various extensions, like "open tab in new window" or "add to evernote" or "fireshot" but nothing that seems directly related to Firefox except I can see navigation commands like back/forward in the right click menu.

Clicking on the Firefox icon in the upper left just brings up the "close" "minimize" "restore" commands mentioned earlier from Windows.

Any advice?

FF 16.01, WinXPsp3

Gekozen oplossing

Well, I think I solved it. IN preparing to do the harder troubleshoot (always debating whether to just accept the need to use the CTRL-N anomaly after getting the first, useless browser window...)...I started FF in safe mode. Everything came up fine.

That got me to thinking about what extensions changed recently. Some update behind the scenes. I don't know of any way to track that. (Is there some list of dates of latest updates for extensions?)

But one that updated recently that I did have some trouble with was Hotspot Shield. I disabled that--noting that it was ver 1.1 and the new version is 2.X. Everything is now fine.

My theory is that HSS upgraded its program, but didn't bother to upgrade the browser plugin, or disable a no-longer-needed feature from an earlier version of HSS.

In fact, HSS still works with the plugin disabled. So, the plugin has to be obsolete and for an older version of the program.

Once again...extensions acting badly.

Dit antwoord in context lezen 👍 1

Alle antwoorden (12)

more options

If you're able to see the 'Firefox' orange tab, go to it and go to 'Options'. Make sure everything is checked depends on what you need or just press 'alt' near your windows button. If it doesn't helps you, re-installing the client may fix this problem otherwise wait for another member to help you.

Bewerkt door Wizzy op

more options

Well, if by orange tab, you mean the FF icon upper left--yes, I see that, but clicking on it--or RIGHT clicking on it--brings up nothing but Windows commands like "close" "minimize" "restore" etc. I see no way to get to the OPTIONS menu--which in any event seems unnecessary because if another instance of FF opens, everything comes right back. JUST NOT AT STARTUP.

Very odd...

more options

Make sure that you do not run Firefox in full screen mode (press F11 or Fn + F11 to toggle; Mac: command+Shift+F). If you are in full screen mode then hover the mouse to the top to make the Navigation Toolbar and Tab bar appear. You can click the Maximize button at the top right to leave full screen mode or right click empty space on a toolbar and use "Exit Full Screen Mode" or press F11.


You can check for problems with the localstore.rdf file.

more options

Thanks.

I am not in full screen mode. As a test in the second copy I opened of my browser, I hit F11 and WENT to full screen mode--it is very different than what it is happening. For one thing there is still a box to enter URLs and go. There are still some key icons--home, back, forward, and the "leave full screen" icon. None of those appear on the truncated browser that pops up.

The truncated 1st instance browser I get on startup seems as if it is one of the trimmed down pop ups that you sometimes get on websites. Only now instead being some specialty pop up firefox has decided to load IT first....I can't imagine how that happened, bu presumably there has to be some command to tell FF to stop doing that.

more options

Another clue....I recently installed a program, it took me to a website, gave me a chance to DL some other stuff. At this point, I'm still working in the truncated browser. I went to close it (since I'd already opened up another copy of the browser, with all my stuff visible) and it said "there are 3 tabs open--do you want to close them all?" ----that standard FF warning when multiple tabs are open.

BUT I couldn't see any evidence of multiple tabs open. So something is simply hiding things that are there, making them invisible.

more options

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.


Further information can be found in the Refresh Firefox - reset add-ons and settings article.

Did this fix your problems? Please report back to us!

more options

Try to open a new window (Ctrl+N) to see if that window works better.
If that works then close the other window and close and restart Firefox.

You can also try to start Firefox with the -new-window switch appended to (a copy of) the Firefox desktop shortcut.

more options

Hi, Cor-el. The "new window" always comes up fine, with all my stuff there. Although not using a Ctrl-N command, that's essentially what I've been doing successfully. The new window ALWAYS comes up fine. Which makes no sense whatsoever.

Using the switch -new-window appended to the command line in the shortcut makes no difference, however. The first instance of FF called always defaults to the truncated version. I presume this syntax is correct?

"C:\Program Files\Mozilla Firefox\firefox.exe" -new-window The discussion of switches made me think---something has installed a switch somewhere. Perhaps the registry? Is there anyplace else it would be?

more options

It is possible that there is a problem with the files sessionstore.js and sessionstore.bak in the Firefox Profile Folder.

Delete the sessionstore.js file and possible sessionstore-##.js files with a number and sessionstore.bak in the Firefox Profile Folder.

Deleting sessionstore.js will cause App Tabs and Tab Groups and open and closed (undo) tabs to get lost, so you will have to create them again (make a note or bookmark them).


You can also try to clear the cache (possibly the entire cache folder on disk, see the about:cache page).

more options

Hi, using my backups I have overwritten the files mentioned in this thread and replaced them with files from 11 days ago when I had no problems.

It had no effect.

FF is set for me to clear cache on every exit.

more options

Quote: FF is set for me to clear cache on every exit.

Note that Firefox doesn't use the disk cache if you use clear history to clear the browsing cache when you close Firefox.
You can see that on the about:cache page and in Firefox/Tools > Options > Advanced > Network


Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

There may be extensions and plugins installed by default in a new profile, so check that in "Tools > Add-ons > Extensions & Plugins" in case there are still problems.

If the new profile works then you can transfer some files from the old profile to that new profile, but be careful not to copy corrupted files.

See:

You can also try to reset Firefox:

more options

Gekozen oplossing

Well, I think I solved it. IN preparing to do the harder troubleshoot (always debating whether to just accept the need to use the CTRL-N anomaly after getting the first, useless browser window...)...I started FF in safe mode. Everything came up fine.

That got me to thinking about what extensions changed recently. Some update behind the scenes. I don't know of any way to track that. (Is there some list of dates of latest updates for extensions?)

But one that updated recently that I did have some trouble with was Hotspot Shield. I disabled that--noting that it was ver 1.1 and the new version is 2.X. Everything is now fine.

My theory is that HSS upgraded its program, but didn't bother to upgrade the browser plugin, or disable a no-longer-needed feature from an earlier version of HSS.

In fact, HSS still works with the plugin disabled. So, the plugin has to be obsolete and for an older version of the program.

Once again...extensions acting badly.

Bewerkt door monsieurms op