Zoeken in Support

Vermijd ondersteuningsscams. We zullen u nooit vragen een telefoonnummer te bellen, er een sms naar te sturen of persoonlijke gegevens te delen. Meld verdachte activiteit met de optie ‘Misbruik melden’.

Learn More

Deze conversatie is gearchiveerd. Stel een nieuwe vraag als u hulp nodig hebt.

Problems with chat / messages / page refresh in Facebook

  • 23 antwoorden
  • 116 hebben dit probleem
  • 25856 weergaven
  • Laatste antwoord van jscher2000

more options

I suddenly began having problems with Facebook, and then with Huffington Post. On HP, the dropdown menu for notifications won't load. On Facebook, things are far worse. Chat won't load, and I can't load private messages. In addition, the page won't refresh. When things get really bad, I can't even post. This all began rather suddenly as I was running Firefox version 12.x, but the problems continue in 13.x (for Windows 7, 64 bit)..

Alle antwoorden (20)

more options

Could you try to clear your browser cache and cookies to see if it's related to the saved settings of the sites. Note that this will log you out of websites you've selected to automatically log in to.

Follow these two articles for the instructions:

Bewerkt door David Tenser op

more options

I'd already done all that, and tried several completely clean installs as well. I wiped out ALL Mozilla data in these installs, even what was in my application data folder, importing my bookmarks back from Chrome instead. Nothing works.

I'm talking deleting the folders and everything after doing the uninstall.

Bewerkt door CircaRigel op

more options

Have you tried the Java Platform ? Updating, reinstalling ? Checking the plugin ?

I had a problem similar to this when trying to use a few websites and it was due to a conflict with the Java Platform and that version of Firefox at the time.

more options

Nope. The Java platform doesn't seem to be the issue. Did all of the above.

more options

I'm having the exact same problem. Messages won't load, I can't post any new messages. Ironically (and frustratingly), no problems whatsoever with Internet Explorer...

The problem seems to be within Facebook itself, not Firefox.

I disabled all my add-ons, but no difference. Then I did a clean install of FF, got rid of all my old profiles and settings, but that didn't help either. However, interestingly enough: when I open a private browsing session, everything is going smoothly, seems to be perfectly okay. As of yet, that seems to be the only (although temporary) solution

Given this fact, has anybody have any ideas about the origin of the problem?

Bewerkt door Puck77 op

more options

Puck77 I have the same problem, which started only a few days ago. Having looked at forums I too tried turning on the private browsing and messages and chat works ok. So is this a Firefox problem? Thanks

more options

> So is this a Firefox problem?

No, on the contrary. I think it's a Facebook problem; that is: Facebook not conforming to the correct web standards. I'm a bit surprised though, that not more people seem to have these problems. Or maybe they're just not writing about them? Dunno. I really really hope they will be solved soon; I'm getting a bit sick of having to start up IE just to send Facebook-messages...

more options

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes).

more options

@cor-el: as I already wrote: I did all that. Disabled everything - add-ons, themes, you name it. Did a clean install. Nothing works, except starting a Private Browsing session (which has all the 'supposedly guilty' add-ons enabled!!)

more options

Cor-el, like Puck, I'd already tried all of those things. It didn't work. Moreover, this problem carried over from FF 12 to FF13, and even a totally clean install didn't work (fully uninstalled, deleted all program and application data directories, even eraser FireFox entries in my computer's registry).

This is a really stubborn problem. I'm not fond of Google Chrome, and have to open THAT up just for Facebook.

more options

Hi!

I'm having this issue also with FF13.x.x. As I recall it appeared when I updated FF to 12/13 version.

I noticed that javascript error console gives the following error when I try to open a message in Facebook: Error: uncaught exception: [Exception... "The operation is insecure." code: "18" nsresult: "0x80530012 (SecurityError)" location: "https://s-static.ak.fbcdn.net/rsrc.php/v2/yO/r/Q4NnQjo7Mja.js Line: 9"]

and the javascript execution stops there. I haven't investigated this bug more, but I hope it will get fixed.

Cheers, Jukka

more options

I also cleared all cache etc. and restarted in safe mode. I too cannot see messages in facebook. In particular, the following do not work: 1 - The drop down for messages in the top left does not list the messages, it only shows the "wait" animated icon with the text "see all messages" below it. It never loads. 2 - Clicking on "see all messages" opens the messages screen correctly, showing the list of messages. Clicking on any message, however, shows the "wait" animated icon. Nothing loads. 3 - The chat list on the bottom right shows the text "Loading..." but it too never loads. This behavior started in ff12 and continues in ff13. Everything works fine in IE9.

more options

Exactly the same problem here with messages on my laptop(I am not having the problem when surfing on my parents' PC!!!) I also have some problems when posting/sharing something such as a photo or a link: if I comment or write too much, I am not able to scroll the window down anymore and I cannot click the "share" button! I too fixed it by switching to anonymous navigation mode (that is, if I don't want to oper IE...). i was experiencing problems in downloading pdf files since months (I have to save them on my laptop most of the time...and this, once again, does not happen on my parents' PC) so I assumed there was something wrong with my hardware.

more options

I also have the same problem (messages on facebook won't load), and after reverting back to FF 10 ESR I got another error code which lead me on the track to what might be the root cause:first of all, wih FF 10 the error code is "-- [20:44:47.982] uncaught exception: [Exception... "Security error" code: "1000" nsresult: "0x805303e8 (NS_ERROR_DOM_SECURITY_ERR)" location: "https://s-static.ak.fbcdn.net/rsrc.php/v2/y6/r/5_JR7IHOlEa.js Line: 8"]" When googling around with this error code, you'll find tons of reports, mostly dealing with FF3.6, e.g. here or here or here. A workaround seems to be, like described in the first link on lauchpad to set the cookie policy for third-pary cookies to 'allow' - after this also Facebook messenger works perfect again, but I would suppose this being a bug in FF - if a cookie can not be read via JavaScript, why the hell should the JS engine throw an exception and stop working afterwards completely?!?

more options

As others have noticed, opening in a private session works fine - message list, buddy list, realtime status list (aka creeper list), and clicking on certain photos all work perfectly now.

Also, I noticed via the web console that the "operation is insecure. code: 18" error that jhappone found does not appear when running in a private session, but does when running in my normal session. So I did a little more digging by trying different cookie settings.

My normal set up for keeping cookies is "ask every time". So I tried "until they expire" and "until I close firefox". Both worked much much better than "ask every time" but there were still occasional instances here and there when viewing the message list did not work (and there appeared the error in the web console) whereas private browsing always worked. In addition, I have the setting "ask every time" at work, and I seem to have most actions working fine there.

So my theory is with timing. It appears that the faster it can process what to do with cookies the better chance of success. Maybe it is a threading race condition? Private browsing blindly accepts all cookies and keeps them in RAM. This is the fastest. "Until they expire" and "until I close firefox" also a blind accept, but uses the HD, so it's a bit slower. "Ask me everytime" needs to check against an accept/accept-session/block list first, so that is the slowest. Perhaps some other thread finished first and that is when we see the error (and the corresponding missing facebook data)?

more options

@cydnub - Dear.Lord.Thank.You.O.M.G. You have identified a simple way to fix this issue. I do think you are right about the speed being the cause.

As Mozilla has tried to improve js performance I think this is something that was left behind. How there aren't more users who care about security/privacy, and having a social life is stunning!

They need to enable some testing of this feature, or make it clear to users that there are real work impacts to their decision for how to handle cookies (prompting or not).

more options

Sorry no one mentioned this before, but if you have your cookie handling set to "ask me every time" then Facebook and some other sites seem to have a problem accessing the permission you previously gave them. The workaround is to create a new exception for facebook.com (without the www). Please see these threads for more discussion:

more options

jscher2000, thank you so much! It worked instantly! Now I can stop using IE on facebook ;)

more options

Thank you very much! It worked for me as well!!!

more options

Jscher2000 -- thank you so much! I had been struggling with this for weeks and had (I thought) tried everything. And I was having to use IE for FB. Your solution was instant success. Wondering how in the world you figured this out ....!

  1. 1
  2. 2