Zoeken in Support

Deze conversatie is gearchiveerd. Stel een nieuwe vraag als u hulp nodig hebt.

Firefox 12 incorrectly caching pages

  • 28 antwoorden
  • 259 hebben dit probleem
  • 5257 weergaven
  • Laatste antwoord van cor-el

more options

After upgrading from Firefox 11 to 12 I'm having serious problems with Firefox over-caching pages.

For example if you: Go to a URL where you can enter comments. If after comments are entered you are sent back to the same URL Firefox is showing the old page (without your new comments). You have to do a refresh to see the new page (with the new comment)

Even if the page has PHP headers: header('Cache-Control: no-cache, no-store, must-revalidate'); header('Pragma: no-cache'); header('Expires: 0');

Firefox ignores this too.

Gekozen oplossing

Firefox 13 is out and the fix for this issue is included in the release. Please update to the latest release version of Firefox if you are still having this issue.

Dit antwoord in context lezen 👍 6

Alle antwoorden (20)

more options

I noticed a very similar issue and it also began after upgrading to FF12. I have multiple users that I've been able to do testing with and I have been able to confirm that the caching is not an issue in FF11.

I did notice I press the browser refresh button it seems to pull a new version of the page, but if I click links on the site it doesn't pull the current version of the page. I've also tried adding a random string to the URL query string, but that didn't seem to make a difference.

Has anyone found any workarounds or additional information related to the caching?

more options

One thing you can test to verify that local caching is occurring is by modifying the about:config to disable caching.

Point your URL to about:config, then search for "network.http.use-cache". Double click the setting and it will set it to "false", then test the URL that is having the caching issue. To turn caching back on, double click the value again.

You likely won't want to leave your browser set to no caching what so ever because it will render pages more slowly, but it might help you identify your issue.

more options

Note that adding random strings to the URLs did fix the issue for me kind of.

In my osCommerce admin I added "&nocache={random number}" to all URLs, when I update orders now, it shows the updated page right away, but for some weird reason the session message ("Order has been updated") gets lost...

I downgraded back to Firefix 11, i'll wait for 13 hopefully they fixed it by then.

more options

Hey guys. Can you give an example of a website where you can consistently reproduce this behavior? That will help in troubleshooting the issue. Just to be thorough, can you try to recreate the issue in Troubleshoot Firefox issues using Safe Mode too just be sure it isn't plugin related?

more options

I tried in safe mode and it still occurs. Here is a site experiencing this: Wall Written Try adding something to the cart, look at the cart and update the quantity, it stays the same until it is refreshed.

more options

Hi dmiller12,

I was able to reproduce it on the site that you linked to. However, I was not able to reproduce it on amazon.com using the same steps. I'm wondering if it is an issue with the websites. Please try the same steps on amazon to see if you still have the issue with cart not updating. If you can provide links to any other sites that have this issue, that would be helpful as well.

Thanks!

more options

Have a look at the browser cookie information. On my websites having the issues, Firefox 12 is actually starting a new session on a header redirect (which would normally not happen until you close the browser). My error messages in the session were not appearing because the session was now not the same... Something to maybe look into

more options

Hi robilim,

Can you please add that information to this bug:

https://bugzilla.mozilla.org/show_bug.cgi?id=751753

That will help the developers to troubleshoot and fix the issue.

Thanks!

more options

Hi Matt,

I posted it on that bug for you.

Cheers

more options

Believe it or not, this appears to to be related to character encoding somehow. Look at my comment on the bug for the "solution".

more options

I'm not entirely convinced that jnrbsn's utf-8 tweak is the full solution - https://bugzilla.mozilla.org/show_bug.cgi?id=751753#c12 and https://bugzilla.mozilla.org/show_bug.cgi?id=751753#c13

It would be quite helpful if people could share url's to apps that they know are exhibiting this bug-ish behavior. Currently we're only aware of wallwritten.com.

Please add urls to https://bugzilla.mozilla.org/show_bug.cgi?id=751753


(removed trailing dot - c)

Bewerkt door cor-el op

more options

Unfortunately, I cannot share mine. It is an internal app that we use at my job.

more options

Thanks to everyone who has been replying with additional information. As mbrandt mentioned above, please add any sites that you can reproduce this on to the ticket.

more options

Hi guys! Here you have two of my sites, this strange behavior appears on both of them: Mititel.ro (I already use random strings to prevent caching) and Bien.hu (random strings not implemented).

On Bien you can try to register (easiest via FB) and then log out ("Kijelentkezes"). After reload it will look like you are still logged in, but in fact you aren't... On other browsers everything works fine, of course.

I hope it helps. Cheers, Zsolt.

more options

Here is an update from the ticket. I thought I would share it here:

This nightly contains the fix. http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2012-05-10-03-05-17-mozilla-central/

Can you please try that build and post back in the ticket if it resolves the issue.

more options

Dear Matt_G,

I can confirm, the new nightly solves the problems, everything works now as expected! When can we expect this to be released to the public?

Thank you, Zsolt.

more options

here are some websites have this issue when you "add to cart" nothing shows in the cart unless you refresh the page or go to a different page.

IE. www.geekatronics.com http://www.bladesandbelts.com http://www.groupsaleonline.com http://www.beautyallinone.com

more options

Gekozen oplossing

Firefox 13 is out and the fix for this issue is included in the release. Please update to the latest release version of Firefox if you are still having this issue.

more options

In Firefox-13 as well caching issue is there even if I added on jsp page

response.setHeader("Cache-Control", "no-cache,no-store,private,must-revalidate,max-stale=0,post-check=0,pre-check=0"); response.setHeader("Pragma", "no-cache"); response.setDateHeader("Expires", 0);

more options

I'm still seeing this in FF v.13.0.1 especially on Facebook and playing Mafia Wars via Facebook. I can reload the page from a bookmark and see updated info in Mafia Wars (http://facebook.mafiawars.zynga.com ...) but not always seeing the most recent comments I or someone else enters on a facebook.com page no matter how much I reload or load from a bookmark. This may have happened elsewhere, but not enough that I've noticed. But since update to v.12 this has been an ongoing issue to date.

Bewerkt door Taco_X op

  1. 1
  2. 2