Zoeken in Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Deze conversatie is gearchiveerd. Stel een nieuwe vraag als u hulp nodig hebt.

firefox losing internet connection

  • 13 antwoorden
  • 191 hebben dit probleem
  • 2886 weergaven
  • Laatste antwoord van sundiver2000

more options

Hi, ever since updating to version 6, I started to experience connection lost from time to time.

This never happen to me prior to version 6.

As an attempt to fix this, in outpost firewall, I allow all activity for firefox (this is not even needed before this).

I then run firefox in safe mode, with all plugins disabled. It appears to fix it but then the problem is back after few minutes.

I do a clean reinstall of firefox but nothing seems to change.

On my side, I am able to reproduce this by visiting deviantart.com

I am sure my internet connection is still on because I can browse while using IE.

I am going to switch to others, the only reason I am giving this so many chances because of few extentions that I use. But then, losing connection periodically driving me nuts

By the way, restarting the browser temporary fix this, also the reason I can finally post this.

Alle antwoorden (13)

more options

I have almost identical problem with FF 6.0.2 and it begun since version 6. I can certainly reproduce it with http://davidicke.pl also happens quite often while browsing google+ and facebook but davidicke.pl is almost certain. Other browsers like Chrome or Opera don't lose internet connection. This only happens in FF. Sometimes internet comes back after 40 or more seconds but it's quicker to close all the tabs and windows of FF and then open again. I don't have any addons or anything besides clean install of FF and my system is Windows XP Home Edition Service Pack 3. I also have that problem on 3 other computers I use so it's not a operating system problem.

more options

I had the same problem with 6.x. I updated to 7 with a totaly clean install and it's getting worse and worse..

Before v7 FF was losing the connexion only when I went to my Google+ page. Now it doesn't matter the site i'm on or what i'm doing, tt looses the connexion realllyy often.

With v6 connexion was caming back after 1 to 5 reboot of firefox. With v7 sometimes I just have to wait 30/60seconds and it comes back most of the times. But I still have to reboot entirely FF to get it back some other times. And trust me, it's REALLY borring :'(..


I cleaned EVERYTHING before installing V7. Add-ons, bookmars, passwords, plugins, etc.. And even with just this clean install connexion is lost oftenly. When i say oftenly it's like every five minutes I have to wait 30s to get something, and I already had to reboot totaly firefox 3 times to get connexion back.

If you need any details just ask.. :/

*This post has been written from Google Chrome because Firefox has lost internet connexion ^^*

Bewerkt door Durss op

more options

I keep having this problem with 7.0.1 it just started last night. Is anyone even working on this issue at the moment? Should I just change browsers? Please say no I don't think there is a comparable browser to ff, it just needs some more immediate response time in the love, if at all possible.

Any fixes yet? Anyone do anything that worked for more than a few minutes?

more options

i have the problem on 6 , 7 .x.x im have problem too firefox stop loading the pages ,don't know what the problem i happy if firefox helpful and fix this problem necessary Thanks.

more options

ever since i updated to version 7.0 I've been losing my internet connection, if this keeps up goodbye Firefox!

more options

In case it could help I have some more informations. We are at least three (didn't asked about it at any other collegues) in my agency to get the exact same problem.

And at our home everything's fine.

Maybe a network configuration could be the source of that?

It's worse and worse, I (we) have to reboot firefox at least 25 times a day (in 8 hours it's not so bad ^^), so I hope you'll find a solution quickly :'(...

more options

I'm experiencing this problem too. I also can reproduce it by browsing www.deviantart.com, as operafansnow said (I'm using FF 7.0.1 with no extension but NagiosChecker). I have increased in about:config these values : network.http.max-connections : from 256 to 512 -- network.http.max-connections-per-server : from 15 to 30 -- After rebooting FF, I can browse www.deviantart.com without losing connection.. I will try these new values these days. Nevertheless, they might be too high and probably need to be decreased a little..

Bewerkt door michaelbx op

more options

I've had this problem ever since updating to 7.0.1.

A fix I've found that's less intrusive than restarting the entire program is that if I flip to private browsing, then flip back to regular browsing, it seems to bring the connection back without losing most of my tabs or waiting for a complete restart.

more options

Also having the same issue. Using LastPass aswell, which indicates when the browser has lost it's connection to the internet. I have no problems when using chrome and I also ping a local server to check that I still have a connection. This has happened ever since 6.0. HATE CHROME. Please fix...

more options

Issue is back again with these settings.. (network.http.max-connections and network.http.max-connections-per-server)

more options

Another fix I've found, that's less disruptive than switching to private browsing, is switching to 'work offline', then switching back. It restores the connection without losing my tabs, and so far has been more consistent than switching to private browsing, which sometimes would freeze, causing me to restart anyway.

more options

I think this may have finally been fixed in Firefox 8. I've had the issue since Firefox 6 as well, but after upgrading from version 7 to 8 I haven't noticed it.

more options

I just "upgraded" one of my computers to FF8. It loses its internet connection several times a session. I am connected- email and other browsers work fine while FF8 is sitting there looking. Back to 3.6. Or maybe Chrome.