Zoeken in Support

Vermijd ondersteuningsscams. We zullen u nooit vragen een telefoonnummer te bellen, er een sms naar te sturen of persoonlijke gegevens te delen. Meld verdachte activiteit met de optie ‘Misbruik melden’.

Learn More

Deze conversatie is gearchiveerd. Stel een nieuwe vraag als u hulp nodig hebt.

Firefox 5 not loading @font-face. It worked for months a couple of days ago, why has it stopped working now? It works in v3&v4

  • 21 antwoorden
  • 26 hebben dit probleem
  • 1 weergave
  • Laatste antwoord van tonka_atx

more options

Firefox is not loading @font-face on my site in v5

It has worked for months so it can't be the CSS. It also works in V3 and V4. Also I tested it on another machine with V5 and it seems to load the fonts

I have tried to reinstall firefox and delete profile but that just gives me an error.

Whats going on?

Is this just me?

Bewerkt door littleheadspin op

Alle antwoorden (20)

more options

Is downloading fonts still enabled?

You can check the value of the pref gfx.downloadable_fonts.enabled (true) on the about:config page.

To open the about:config page, type about:config in the location (address) bar and press the "Enter" key, just like you type the url of a website to open a website.
If you see a warning then you can confirm that you want to access that page.

  • Use the Filter bar at to top of the about:config page to locate a preference more easily.
  • Preferences that have been modified show as bold(user set).
  • Preferences can be reset to the default or changed via the right-click context menu.
more options

Ye, is is set to True.

This is what I mean, It has happened out of no where.

The only thing that is different is that I have moved to a dedicated server 3 days ago... But even so, it works on all other Firefox's including V3, V4 AND V5 on another computer.

Im dying to get this sorted

more options

Ok, I just updated to the latest Firefox V5 on another computer, and I can confirm that the latest update to V5 is causing this.

more options

Firefox will only load font if they come from the same domain.

Same-origin rule: By default, Firefox will only accept relative links. If you want to use absolute links or include fonts from different domains, you need to send these fonts with Access Control Headers.

more options

My fonts do come from the same domain. And they are in relative

This is what is puzzling, it is the latest update. The fonts work on v3,v4 and v5 before last weeks update.. to 5.01

more options

I'm curious.
You only use @font-face to get the Verdana font and that font is probably installed locally if you use Windows.
I also have that font on Linux, so only visitors with a Mac may really need @font-face to download that font.

Do you see a GET to load that font from the server if you open the Web Console and reload the page with Ctrl+F5?

GET http://teencancer.co.uk/css/fonts/verdanab.eot [HTTP/1.1 200 OK 3645ms]
GET http://teencancer.co.uk/css/fonts/verdana.woff [HTTP/1.1 200 OK 3206ms]
GET http://teencancer.co.uk/css/fonts/verdanab.eot [HTTP/1.1 200 OK 3568ms]
GET http://teencancer.co.uk/css/fonts/verdana.woff [HTTP/1.1 200 OK 2959ms]
more options

ye, but there was only 2: This is what I got:

GET http://teencancer.co.uk/css/fonts/verdanab.eot [HTTP/1.1 304 Not Modified 390ms]

GET http://teencancer.co.uk/css/fonts/verdana.woff [HTTP/1.1 304 Not Modified 343ms]

Bewerkt door littleheadspin op

more options

When I reload it again and again I got the 4 you mentioned...which were

GET http://teencancer.co.uk/css/fonts/verdana.woff [HTTP/1.1 200 OK 1810ms] --

GET http://teencancer.co.uk/css/fonts/verdanab.eot [HTTP/1.1 200 OK 2168ms] --

GET http://teencancer.co.uk/css/fonts/verdana.woff [HTTP/1.1 200 OK 1981ms] --

GET http://teencancer.co.uk/css/fonts/verdanab.eot [HTTP/1.1 200 OK 2558ms]

Bewerkt door littleheadspin op

more options

So does anyone know why it's not working?

Please, I really need help with this

more options

Which font does Firefox use instead of the Verdana in the @font-face?

Do you have a Verdana font installed locally?

more options

I've had to set it to standard for the time being, until Mozilla fix this bug.

more options

Ok, I am sorry for bumping this question but I have found the solution so here it is, I am going to do a bit of explaining on the solution which solved my problem and worked for me

It's quite simple. The css tag which chose the font type and the font-face was not a capital. Now obviously, this calls the pre-installed Verdana font which is already installed on the visitors machine on Windows, but if you have a mac.. the most important thing is that if you still keep the @font-face with the selector a capital 'Verdana' it will get the font.

Here is some samples, notice that its a capital V on 'Verdana'

@font-face { font-family: Verdana; src: url('/SiteElements/fonts/verdana.eot'); src: local(Verdana), url('/css/fonts/verdana.ttf') format('opentype'); /* file for better browsers */ }

@font-face { font-family: Verdanab; src: url('/SiteElements/fonts/verdanab.eot'); src: local(Verdanab), url('/css/fonts/verdanab.ttf') format('opentype'); /* file for better browsers */ }

--text Css----

.text { font-family: Verdana, Verdanab; }


So i hoped that helped anyone on the World Wide Web out there.

Kind regards, Ryan

more options

No.. it stopped working again

I hate firefox. They have ruined everything in Version 5

more options

Font names shouldn't be case sensitive, so it shouldn't matter if you use 'verdana' or 'Verdana'

I'm still not sure of the code format('opentype') as you specify a TTF font.

src: local(Verdanab), url("/css/fonts/verdanab.ttf") format('opentype');

I see a GET for the woff font

GET /css/fonts/verdana.woff


Did you try another, less common, font that isn't stalled locally to see if that works?

more options

I am having the same problem. My gfx.downloadable_fonts.enabled is set to true in my about:config. My fonts are linked relatively and accurately. Nothing has changed in my coding since it was working in FF3 (I skipped 4 & went straight to FF5).

I have concluded that the problem is NOT on my end, but is a bug within FF5 itself. Please fix this ASAP!

Thank you!

more options

Can you post a link?

more options
more options
more options

Aaaah! Thank you. My host went down and deleted all my files for all my sites this week...and somehow those didn't get reuploaded. So I guess the problem has been fixed in FF6? Because when I first noticed the problem was RIGHT after upgrading to FF5 and at the time I'd double checked and the fonts were there.

more options

It is working for me in Firefox 6 AFAICT.

  1. 1
  2. 2