Zoeken in Support

Vermijd ondersteuningsscams. We zullen u nooit vragen een telefoonnummer te bellen, er een sms naar te sturen of persoonlijke gegevens te delen. Meld verdachte activiteit met de optie ‘Misbruik melden’.

Learn More

Deze conversatie is gearchiveerd. Stel een nieuwe vraag als u hulp nodig hebt.

FF 4 won't work with Mac OSX (PowerPC) - says not valid with architecture. How do I go back to FF 3.5-6? For some reason, I'm now back to FF2!

  • 5 antwoorden
  • 13 hebben dit probleem
  • 35 weergaven
  • Laatste antwoord van jendhi

more options

Mac OSX with Power PC -- not Intel. I assume that is the "architecture" problem. When I tried to nuke FF 4, I ended back with FF 2, so I don't have my bookmarks anymore, and don't seem able to use FB chat anymore. How can I download 3.5-6 again?

Alle antwoorden (5)

more options

The last Firefox version that works on OS X 10.3.x is 2.0.0.20.

Other browsers that you can look at:

more options

Your answer was not extremely helpful -- sorry! I assumed it was because I do not have an Intel processor. Fine -- I can live without FF 4.0. But neither do I want FF 2.0! How can I return to FF 3.5-6? I had it until I tried to upgrade.

more options

Your answer was not extremely helpful. I assume it's an issue with the Intel processor. Fine -- I can live w/o FF 4.0! However, neither do I want FF 2.0 -- and if I wanted another browser, I could use Safari or IE, which are still on my system. You are apparently assuming I have OSX 10.3. I do not -- I have 10.5.8, with a powerpc processor.

The question is -- again -- where/how do I download FF 3.5-6 again? I had it until I attempted to upgrade to FF4.

more options

You didn't tell us which Mac OS X version you are running, so it is hard to give specific advice.

Firefox 3.6.x can be found here:


more options

I have Mac OS X version 10.5.8 but it's a G4 PowerPC (not Intel). Will Firefox 4 ever work on it or am I stuck using 3.6.16 forever? I love Firefox 4 and have it installed on my android phone, my PC at home and at the office, and am bummed out that it doesn't work on my Apple iBook G4.

Thanks!