Zoeken in Support

Vermijd ondersteuningsscams. We zullen u nooit vragen een telefoonnummer te bellen, er een sms naar te sturen of persoonlijke gegevens te delen. Meld verdachte activiteit met de optie ‘Misbruik melden’.

Learn More

Websites do not load

  • 12 antwoorden
  • 1 heeft dit probleem
  • 34 weergaven
  • Laatste antwoord van thomas-buetow

more options

Hello,

I have a problem with opening 2 or 3 websites. I get an error message which is basically the same as if the page did not exist. It does exist though. I tried a different browser and there it works. I also created a new Firefox profile and I can access the sites without issues this way. So the problem must be with my original standard profile. Can you suggest me how to fix this? I already selected these specific websites and had Firefox forget about them in my browsing history, but sadly this does not solve the issue. They are still unavailable.

I don't mind losing pretty much everything attached to this profile in order to solve the issue and be able to open the sites again. Saved logins would be cool to keep, but I can sacrifice those too if there is no other option. The only exception is my browsing history. I do need that one and cant afford to lose it, which is why I do not simply switch over to a new profile. Of course if there is a way to export my entire history to another new profile, then I'd happily take this path too. Just no idea how. Thanks for reading! I hope all is clear, I am not an English native speaker.

I have Firefox 96.0.1 and Windows 11.

Alle antwoorden (12)

more options

If you are willing to use the other profile, you will need to do a few things, one of which involves about:config:

WARNING from the moderator team: Changing Firefox pref from the about:config page can sometimes break Firefox or cause strange behavior. You should only do this if you know what you're doing.

Please read Firefox advanced customization and configuration options to learn more.

  1. In the original profile, go to history and manage history. Click on Import and backup, then export to HTML
  2. Do the same for bookmarks if you would like to keep them
  3. For login details, go to about:logins, go to the top right and under the three dot menu, choose export logins
  4. On the new profile now, go to the history, then import and backup, then import from HTML
  5. As before, you can do the same for bookmarks
  6. Go to about:config and set signon.management.page.fileImport.enabled to true if it is not already
  7. Go to about:logins, and click the three dots, and import the exported CSV file.

Behulpzaam?

more options

You can copy certain files with Firefox closed to the current profile folder to transfer or recover personal data. Note that best is to avoid copying a full profile folder.

You can use the button on the "Help -> More Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page (Root directory).


  • bookmarks and history: places.sqlite
  • favicons: favicons.sqlite
  • bookmark backups: compressed .jsonlz4 JSON backups in the bookmarkbackups folder
  • cookies.sqlite for the Cookies
  • formhistory.sqlite for saved autocomplete Form Data
  • logins.json (encrypted logins;32+) and key4.db (decryption key;58+) for Passwords saved in the Password Manager
    key3.db support ended in 73+; to use key3.db in 58-72, make sure to remove key4.db
  • cert9.db (58+) for (intermediate) certificates stored in the Certificate Manager
  • persdict.dat for words added to the spell checker dictionary
  • permissions.sqlite for Permissions and possibly content-prefs.sqlite for other website specific data (Site Preferences)
  • sessionstore.jsonlz4 for open tabs and pinned tabs (see also the sessionstore-backups folder)

Behulpzaam?

more options

Thanks a lot for the answers you two. I will check up on that when I find the time to go through it and afterwards let you know if it worked.

Behulpzaam?

more options

thomas-buetow said

. . . . I get an error message which is basically the same as if the page did not exist.

Please explain the problem in detail. What happens? What is/are the exact error message(s) ?


Please provide a public link (no password) that we can check out. No Personal Information Please !

Behulpzaam?

more options

The error is the one in the picture. (Not a screenshot I made because mine would be in German)

Behulpzaam?

more options

Make sure you are not blocking content.

https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop also see https://blog.mozilla.org/security/2021/03/23/introducing-smartblock/

https://support.mozilla.org/en-US/kb/smartblock-enhanced-tracking-protection


Diagnose Firefox issues using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?


Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

Behulpzaam?

more options

Behulpzaam?

more options

Okay I went through all these steps thanks guys. The only security I have is Windows defender. I disabled and error was still there. In troubleshoot mode, the error was also still there. I disabled the shield on the left side of the web address field, but it did not solve the issue either.


So eventually, I had no choice than really go step by step through the files and folder and replace them from the old folder to the new folder to see at what point the error would start showing up.

The result was that the file that caused the issue was prefs.js Comparing the entries there, I found that this line:

user_pref("network.trr.mode", 2);

was responsible.

I removed it and the issue was solved. The sites are working again. I put it back in and replaced the 2 with a 1 and the issue was solved as well and everything is good. So as long as the value is not 2, it seems to be fine. I have honestly no clue what this stands for, but maybe somebody here can tell me if best choice is to remove the entire line or change the value into something else? Thanks again for the support, folks.

Behulpzaam?

more options

That is about DNS over HTTPS.

We have seen more issues recently reported when DoH is enabled.

Behulpzaam?

more options

yeah thanks, but unfortunately I don't understand any of this stuff, especially in a foreign language can you tell me if there is any kind of impact if I remove the line or just put a 1 there instead of the 2 and what the differences would be?

Behulpzaam?

more options

Setting network.trr.mode to 0 merely means that you disable DNS over HTTPS (DoH) feature. DNS is about translating a domain name to an IP address similar to a phone book where you can lookup a telephone number to dial. Enabling DoH means that DNS requests are send via a secure connection. That way other servers can't sniff where you are going to (privacy/security feature).

You can find this DoH setting at the bottom of the connection settings window, so you do not need to use about:config although this check box toggles network.trr.mode between 2 (TRR first) and 5 (explicit off).


Behulpzaam?

more options

Thanks a lot for the rookie-friendly explanation cor-el. Now I got it. Cool Superman reference too in the name!

Behulpzaam?

Een vraag stellen

U moet zich aanmelden bij uw account om op berichten te antwoorden. Stel een nieuwe vraag als u nog geen account hebt.