Zoeken in Support

Vermijd ondersteuningsscams. We zullen u nooit vragen een telefoonnummer te bellen, er een sms naar te sturen of persoonlijke gegevens te delen. Meld verdachte activiteit met de optie ‘Misbruik melden’.

Learn More

Deze conversatie is gearchiveerd. Stel een nieuwe vraag als u hulp nodig hebt.

Firefox line spacing, and window title vertical size.

  • 7 antwoorden
  • 1 heeft dit probleem
  • 190 weergaven
  • Laatste antwoord van fred37

more options

Please provide an option to revert to the smaller line spacing and the original smaller top window title vertical size. For those of us using smaller displays the new sizes in Firefox make it much less friendly, and inconsistent with other software on the same PC. Thanks!

Please provide an option to revert to the smaller line spacing and the original smaller top window title vertical size. For those of us using smaller displays the new sizes in Firefox make it much less friendly, and inconsistent with other software on the same PC. Thanks!

Gekozen oplossing

Have a look at these settings:

Check 'about:config' for the 'browser.compactmode.show' setting and set to True.

Menu app icon > More Tools > Customise Toolbar At the bottom is 'Density' button with drop down options.

On mine one of the drop down options says 'Compact (not supported)' But when I select it, the height of the Toolbars and Tabs is reduced.

Link to info: https://support.mozilla.org/en-US/kb/compact-mode-workaround-firefox

Dit antwoord in context lezen 👍 0

Alle antwoorden (7)

more options

I've posted a bug report. It may help if you could offer comments in support and explain how this effects you.


If you are finding there is too much space between all menu items in drop down lists. eg: View History Bookmarks and also the Menu app icon (3 horizontal lines) then you could do the following to reduce the gap as a workaround.

This is easier than you may think. Check a setting in Firefox about:config Access profile,create a folder, create a file and you do not need to write code because I have supplied the text, you just copy and paste. So work through instructions step by step. Note: I have added an image below to show process. If you cannot see details, access forum and click on image to enlarge.

  • Open 'about:config'

Info at link if unsure but basically type about:config in the address text bar. https://support.mozilla.org/en-US/kb/about-config-editor-firefox

  • in search type: legacy
  • look for: toolkit.legacyUserProfileCustomizations.stylesheets
  • make sure it is set to 'True'

Now access the profile itself:

  • Menu app icon > Help > More Troubleshooting Information
  • About 11th in list is 'Profile Folder' - click on the 'Open Folder' button

A new window opens showing the contents of your Firefox profile.

  • Create a new folder and call it chrome - it must be spelt correctly - all lowercase.
  • Open a text editor eg: Notepad
  • Copy all the text shown between the lines below and paste it into 'Notepad'.

I advise you double check the content shown in the email you receive is the same as the info posted in this forum question.


menupopup > menuitem, menupopup > menu {
  padding-block: 3px !important;
}
:root {
  --arrowpanel-menuitem-padding: 4px 8px !important;
}


  • Exit Firefox now - you need to close the browser; this is important.

The Notepad document:

  • File > Save As
  • Choose where to save it - it must be saved in the 'chrome' folder you just created.
  • Save the Notepad file with this name: userChrome.css

All lowercase except for the 'C' which is uppercase.

  • Make sure the 'Save as Type' is 'All files' - not a text document.
  • click on 'Save'

In the 'chrome' folder, it's type will be described as 'Cascading Style sheet.

Start Firefox

more options

Toad-Hall, thanks for that. No problem to follow your instructions as I'm competent at that level. Whilst this fixes the bookmarks drop-down list, the vertical size of the tabs, and of the space for icons on the toolbar are still greater than they used to be, which reduces space for the text I wish to read. If those sizes could be restored to the pre-91 behaviour it would be very much appreciated. Perhaps this is some new Microsoft standard - no problem with that - but it should be a user option which is easier to set and reset. I'll try to add comments supporting the bug report.

Thanks, David

more options

Gekozen oplossing

Have a look at these settings:

Check 'about:config' for the 'browser.compactmode.show' setting and set to True.

Menu app icon > More Tools > Customise Toolbar At the bottom is 'Density' button with drop down options.

On mine one of the drop down options says 'Compact (not supported)' But when I select it, the height of the Toolbars and Tabs is reduced.

Link to info: https://support.mozilla.org/en-US/kb/compact-mode-workaround-firefox

more options

Yes, that resolves the toolbar and tabs issue. Thanks!

more options

The above workaround does not work for Firefox 91. Don't waste your time!

I've seen a post here of 34 pages with various suggestions. None worked for the original poster. The about:config workaround worked for Firefox 90, now in 91 it doesn't. I tried the .ccs style sheet solution and ended up with my menus and bookmarks crammed together so it was illegible.

I've been an avid user of Firefox since 3.4 and have recommended it to everyone standing still long enough to listen to me. When I configure something, I expect it to stay configured.

This fetish with spread out menus and bookmarks must stop.

Time to move onto another browser. I'm typing this within Opera. On day one, so not sure how things are going yet. One thing is certain, the menus and bookmarks don't take up a significant part of the screen.

When you see sense, you have my e-Mail address. Until then, goodbye moz://a

more options

oghma said

The above workaround does not work for Firefox 91. Don't waste your time! I've seen a post here of 34 pages with various suggestions. None worked for the original poster. The about:config workaround worked for Firefox 90, now in 91 it doesn't. I tried the .ccs style sheet solution and ended up with my menus and bookmarks crammed together so it was illegible.

re :The about:config workaround worked for Firefox 90, now in 91 it doesn't. Correct, but this was known to be expected as that preference functionality was being removed in 91, so it was only a temp fix.

You do not mention whether you made a comment in the bug report I mentioned. It would be helpful to have others also explain the problems they experience toget the attention of the developers, so I'm not fighting this cause on my own.

The css code I wrote in first comment is working perfectly ok in Firefox 91.0 You have full control over the spacing by adjusting the px value. Some prefer 4px, I like 3px. You would need to provide an image to show what you consider as illegible so I am able to understand your specific problem and provide an image of the userchrome.css file contents so I can check the code you are using. Then I may be able to assist. So if you would like some help, please create you own question and provide some images as described so people can sort out the issue.

Please do not continue in this question as it already has a Chosen Solution and the person who originally asked the question does not need to get emails from you.

The second comment chosen as solution is all to do with tabs and space at the top which works for me and the person who asked the question.

more options

I went through various suggestions, most of which assumed that you were sort of familiar with how to build Windows apps and know the directory trees, etc. The most important take-aways (on Windows 10) were: - Use the More Troubleshooting Information to find the profile directory -- it may be well hidden -- and leave that open, or shortcut it to the desktop. - Create a chrome folder as they say under your profile. - Find the magic css incantations above that specify the padding - Open Notepad *as administrator* and paste in that code. - The two values 4 and 8 px in the suggested code are TOO WIDE. They still look like proton. I found 2 and 6 to work better. - Then save it to the chrome folder as userChrome.css. This may fail if you are not opening it as administrator as Windows protects some folders against casual writes. - Restart.

Yes, Mozilla has jumped the shark. If somebody has a good fork I'd be interested. Thunderbird is also a mess; I am locked into old 68, bugs never fixed, because they broke compatibility in 78.

I think I know what's going on, though. Mozilla's band of code monkeys is a mix of paid and volunteers. Even the paid ones are probably young. Their main priority is NOT making a good program; after all, Firefox is free. Their main priority is in making their resumes look good. For a code monkey, having all of the latest and greatest tools and languages on the resume is important. So Mozilla is sort of like a graduate school, where code monkeys get to play with all of the new tools by rewriting working code such that it may not work as well, and may break users' work flows, but they get to add another item to their resume.

Google is no better; their goal is to mine your habits for personal information. Microsoft keeps trying to do whatever made money for Facebook or Google or Apple a decade ago, also with no idea of what users want. Thus most software sucks, or migrates from good to sucks over time.