Zoeken in Support

Vermijd ondersteuningsscams. We zullen u nooit vragen een telefoonnummer te bellen, er een sms naar te sturen of persoonlijke gegevens te delen. Meld verdachte activiteit met de optie ‘Misbruik melden’.

Learn More

Deze conversatie is gearchiveerd. Stel een nieuwe vraag als u hulp nodig hebt.

Set 'Launch using dedicated Graphics card' as default on Ubuntu 20.04 with 2x GTX970

  • 4 antwoorden
  • 1 heeft dit probleem
  • 88 weergaven
  • Laatste antwoord van beardyandy

more options

Firefox launches with all white window, can't see tabs/ menus/ page etc I'd get a screenshot but interesting that displays ok

Seems connected with this error GFX1-]: More than 1 GPU from same vendor detected via PCI, cannot deduce device

Right-clicking on the firefox icon and choosing 'Launch using dedicated Graphics card' makes it work as normal - how can I make that the default please.


I've tried

Thanks

Firefox launches with all white window, can't see tabs/ menus/ page etc I'd get a screenshot but interesting that displays ok Seems connected with this error GFX1-]: More than 1 GPU from same vendor detected via PCI, cannot deduce device '''Right-clicking on the firefox icon and choosing 'Launch using dedicated Graphics card' makes it work as normal - how can I make that the default please.''' I've tried *deleting ~/.mozilla and apt purge/ reinstall *setting MOZ_ENABLE_WAYLAND=1 in various places as per https://www.reddit.com/r/Ubuntu/comments/gukt4b/running_firefox_in_wayland_mode_not_x11/ Thanks

Alle antwoorden (4)

more options
more options

Thanks but don't have that installed.

In his version you can see the navigation/ menu etc. I can't. It's not a 'nice' white either, it's the white of a display error, hard to explain that.

Though worked id I use the right click 'use dedicated' so ideally I could set that as the default somewhere..?

more options

This could be a problem with WebRender, so you can try to disable WebRender to see whether this has effect.

You can disable WebRender by setting this pref to true on the the about:config page.

  • gfx.webrender.force-disabled = true

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

more options

Thanks

For the next guy - I could get to the about:config page through launching in sage mode and disabling it as per about firefox -safe-mode

This does indeed allow it to open.

Is the answer here not to force it to use one specific graphics card though, rather than disable functionality? Keep coming back to that "[GFX1-]: More than 1 GPU from same vendor detected via PCI, cannot deduce device"