Zoeken in Support

Vermijd ondersteuningsscams. We zullen u nooit vragen een telefoonnummer te bellen, er een sms naar te sturen of persoonlijke gegevens te delen. Meld verdachte activiteit met de optie ‘Misbruik melden’.

Learn More

Deze conversatie is gearchiveerd. Stel een nieuwe vraag als u hulp nodig hebt.

Stop FF changing entered URLs

  • 2 antwoorden
  • 1 heeft dit probleem
  • 10 weergaven
  • Laatste antwoord van Craig100

more options

As a developer who often has to access web sites on their servers when connected via RDP, how do I prevent FF altering http://mysite.local to https://www.mysite.local. It's utter madness this can't be switched off easily. A "Developer" setting would be great where you could just switch this stuff off.

Please advise.

As a developer who often has to access web sites on their servers when connected via RDP, how do I prevent FF altering http://mysite.local to https://www.mysite.local. It's utter madness this can't be switched off easily. A "Developer" setting would be great where you could just switch this stuff off. Please advise.

Alle antwoorden (2)

more options

I don't think that .local is on the HSTS preload list, so there shouldn't be a reason to switch to https:// automatically.

You can check SiteSecurityServiceState.txt in the profile folder to see if there are references to the local domain and possibly remove these references.


Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

You can remove all data stored in Firefox for a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox for this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data for that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data for that website will be saved once again.

more options

Thanks for your reply.

.local is not in the SiteSecurityServiceState.txt Starting in Safe Mode and removing the history for the domain didn't help.

FF still changes http://uni-live.local to https://www.uni-live.local So that's two things it's doing, switching to https and adding a prefix of www. neither of which are wanted (ever, to be honest!).

Changing urls just encourages people to get sloppy IMHO.

All the "fixup" config parameters are set to "false" but the alternate prefix is still set to www. as it can't be left empty.

Bewerkt door Craig100 op