Zoeken in Support

Vermijd ondersteuningsscams. We zullen u nooit vragen een telefoonnummer te bellen, er een sms naar te sturen of persoonlijke gegevens te delen. Meld verdachte activiteit met de optie ‘Misbruik melden’.

Learn More

Deze conversatie is gearchiveerd. Stel een nieuwe vraag als u hulp nodig hebt.

Firefox Extensions and Themes

  • 2 antwoorden
  • 1 heeft dit probleem
  • 60 weergaven
  • Laatste antwoord van elicea0412

more options

Hello everyone.

I am having an issue with Firefox Desktop on my Linux machine(MX Linux). Before I was able to install themes and extensions from the marketplace just fine. However recently when I try to install a theme or extension through the marketplace, I get the green button that says "Only with Firefox -- Get Firefox Now" instead of the blue button that says "Add to Firefox".

I have tried purging all files and re-installing the application. I even went as far as deleting anything Firefox that was in my root files. I was able to change the theme and add a suggested extension through the Add-On settings but that was all.

To me it seems like the marketplace is not recognizing the browser as Firefox. Any help is much obliged.

Hello everyone. I am having an issue with Firefox Desktop on my Linux machine(MX Linux). Before I was able to install themes and extensions from the marketplace just fine. However recently when I try to install a theme or extension through the marketplace, I get the green button that says "Only with Firefox -- Get Firefox Now" instead of the blue button that says "Add to Firefox". I have tried purging all files and re-installing the application. I even went as far as deleting anything Firefox that was in my root files. I was able to change the theme and add a suggested extension through the Add-On settings but that was all. To me it seems like the marketplace is not recognizing the browser as Firefox. Any help is much obliged.

Gekozen oplossing

The Mozilla Add-ons site uses your browser's user agent string to detect your Firefox version. Any alterations to the string may cause mis-detection.

This forum recorded a completely blank user agent string for your post, which is weird. Do you use any settings or external middlemen (such as proxy servers) to modify your user agent string?

For the internal setting, see: How to reset the default user agent on Firefox

I have a test page here that shows the user agent string detected by the page: https://www.jeffersonscher.com/res/jstest.php

Dit antwoord in context lezen 👍 1

Alle antwoorden (2)

more options

Gekozen oplossing

The Mozilla Add-ons site uses your browser's user agent string to detect your Firefox version. Any alterations to the string may cause mis-detection.

This forum recorded a completely blank user agent string for your post, which is weird. Do you use any settings or external middlemen (such as proxy servers) to modify your user agent string?

For the internal setting, see: How to reset the default user agent on Firefox

I have a test page here that shows the user agent string detected by the page: https://www.jeffersonscher.com/res/jstest.php

more options

I thought it migh've had to do something with the user-agent. That was it exactly. I was able to reset it and now everything works great! thanks for the help!

Bewerkt door elicea0412 op