Zoeken in Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox update for Windows Server 2008 r2

  • 7 antwoorden
  • 1 heeft dit probleem
  • 28 weergaven
  • Laatste antwoord van jscher2000

more options

Can I install the latest Firefox on my Windows Server 2008 r2, or do I have to worry about compatibility issues? Is there a specific Firefox version for my OS? Thanks in advance for the help.

Bewerkt door rorypascua op

Alle antwoorden (7)

more options

Windows Server 2008 is built from the same codebase as Windows Vista and thus it shares much of the same architecture and functionality.

Firefox version 52.9.0esr was the last supported release for Windows XP and Windows Vista. No further security updates will be provided for those systems.

So no, for the current version of Firefox 79.0.

Behulpzaam?

more options

Certainly the original Windows Server 2008 can't run Firefox any more. However, I can't remember about R2.

You can check whether R2 will be detected as Vista (Windows NT 6.0) or Windows 7 (Windows NT 6.1) by opening a cmd.exe window and running the ver command. If you get NT 6.1, then it's worth a try.

As for compatibility issues, of course, there may be device driver/graphics issues to work around with such old hardware and drivers.

Behulpzaam?

more options

jscher-2000 -- The output of the ver command is "Microsoft Windows [version 6.1.7601]". No indication of whether its Vista or 7.

the-edmesiter -- I went to the download page and found this zip file: https://ftp.mozilla.org/pub/firefox/releases/52.9.0esr/firefox-52.9.0esr.win64.sdk.zip. Is this the right version?

Thank you all for the help.

Bewerkt door rorypascua op

Behulpzaam?

more options

jscher-2000 -- The output of the ver command is "Microsoft Windows [version 6.1.7601]". No indication of whether its Vista or 7.

the-edmesiter -- I went to the download page and found this zip file: https://ftp.mozilla.org/pub/firefox/releases/52.9.0esr/firefox-52.9.0esr.win64.sdk.zip. Is this the right version?

Thank you all for the help.

Behulpzaam?

more options

Hi rorypascua, there is a link moderation queue that delays posts that contain URLs. Your reply should appear here eventually.

Meanwhile, your system detects as Windows 7 so there's no need to install an old version.

Behulpzaam?

more options

jscher2000 -- I can install the latest/greatest Firefox version?

Behulpzaam?

more options

rorypascua said

jscher2000 -- I can install the latest/greatest Firefox version?

The installer should run on a system that identifies as Windows 6.1.x. Whether Firefox will run smoothly on older hardware is a different question.

Behulpzaam?

Een vraag stellen

U moet zich aanmelden bij uw account om op berichten te antwoorden. Stel een nieuwe vraag als u nog geen account hebt.