Zoeken in Support

Vermijd ondersteuningsscams. We zullen u nooit vragen een telefoonnummer te bellen, er een sms naar te sturen of persoonlijke gegevens te delen. Meld verdachte activiteit met de optie ‘Misbruik melden’.

Learn More

Deze conversatie is gearchiveerd. Stel een nieuwe vraag als u hulp nodig hebt.

cache being removed

more options

Each time I turn off Firefox, all cookies, cache and browsing history are being cleared. I turned off all the "clear data when Firefox is being turned off" options in the setting but it did not solved the problem. Re-installing FF is not helping either. How can I solve this?

Each time I turn off Firefox, all cookies, cache and browsing history are being cleared. I turned off all the "clear data when Firefox is being turned off" options in the setting but it did not solved the problem. Re-installing FF is not helping either. How can I solve this?

Gekozen oplossing

Some other things to check:

Some security software includes a "Privacy Cleanup" feature.

Some third-party toolbars and add-ons change Firefox's home page and search settings.

A user.js file is overriding Firefox settings.

Locked or Corrupt prefs.js file.

More details are in How to fix preferences that won't save.

Suggestion: Save Refresh as a last resort.

Dit antwoord in context lezen 👍 1

Alle antwoorden (7)

more options

Hi Wrubel, You wouldn't happen to be in permanent Private Browsing mode ?

more options

RobertJ said

Hi Wrubel, You wouldn't happen to be in permanent Private Browsing mode ?

Unfortunately, no. FF runs in regular mode. But actually, if I turn option to run in pernament Private Browsing on, it is being turned off after re-opening browser as well.

more options

Private Browsing only lasts until you turn it off or close the browser.

You may be in Private Browsing mode or told Firefox not to remember.

Type about:preferences#privacy<enter> in the address bar. The button next to History, select Use Custom Settings.

Turn off Always Use Private Browsing Mode Turn on Remember My Browsing And Download History At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on ONLY Cache and Form And Search History leaving the others off.

more options

FredMcD said

Private Browsing only lasts until you turn it off or close the browser. You may be in Private Browsing mode or told Firefox not to remember. Type about:preferences#privacy<enter> in the address bar. The button next to History, select Use Custom Settings. Turn off Always Use Private Browsing Mode Turn on Remember My Browsing And Download History At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on ONLY Cache and Form And Search History leaving the others off.

I follwed the instructions. After restarting firefox all data was cleared and settings were back to previous ones. It seems that it also changed start page to blank. The settings browser keep getting back to are:

"Awlays use private browsing mode" - off "Clear history when Firefox Xloses" - on, with all settings on

Additionaly, I ran antivirus and malware scan. It found nothing.

more options

Gekozen oplossing

Some other things to check:

Some security software includes a "Privacy Cleanup" feature.

Some third-party toolbars and add-ons change Firefox's home page and search settings.

A user.js file is overriding Firefox settings.

Locked or Corrupt prefs.js file.

More details are in How to fix preferences that won't save.

Suggestion: Save Refresh as a last resort.

more options

RobertJ said

Some other things to check: Some security software includes a "Privacy Cleanup" feature. Some third-party toolbars and add-ons change Firefox's home page and search settings. A user.js file is overriding Firefox settings. Locked or Corrupt prefs.js file. More details are in How to fix preferences that won't save. Suggestion: Save Refresh as a last resort.

RobertJ, you are a life-saver! :D Editing the user.js file resolved the issue. Thanks a lot!

more options

I'm glad we could track it down. Good work!


Browse Safe!