Zoeken in Support

Vermijd ondersteuningsscams. We zullen u nooit vragen een telefoonnummer te bellen, er een sms naar te sturen of persoonlijke gegevens te delen. Meld verdachte activiteit met de optie ‘Misbruik melden’.

Learn More

Deze conversatie is gearchiveerd. Stel een nieuwe vraag als u hulp nodig hebt.

Starting today, Netflix will not run on Firefox—red loading circles goes and goes, but won't load.

  • 1 antwoord
  • 2 hebben dit probleem
  • 96 weergaven
  • Laatste antwoord van FredMcD

more options

Starting today, Netflix will not run on Firefox. At first I got an error message from Netflix saying to update Firefox, but it's already up to date. Now, the red "loading" circle goes around and around, but the show won't start AND the error message no longer appears. Netflix works fine on Chrome, but I'd rather be using Firefox.

Starting today, Netflix will not run on Firefox. At first I got an error message from Netflix saying to update Firefox, but it's already up to date. Now, the red "loading" circle goes around and around, but the show won't start AND the error message no longer appears. Netflix works fine on Chrome, but I'd rather be using Firefox.

Alle antwoorden (1)

more options

Websites say that Firefox is outdated or incompatible even though it's the latest version https://support.mozilla.org/en-US/kb/websites-say-firefox-outdated-or-incompatible

This article is no longer maintained, so its content might be out of date.


Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}