X
Tik hier voor de mobiele versie van de website.

Ondersteuningsforum

Firefox is re-directing to another domain on the homepage.

Geplaatst

I was using a staging site and then went live and redirected the staging domain to the live domain. However, I then needed to re-instate the staging site. Now, whenever I go to the home page of the staging site, it redirects me to the live site. Any other page or url doesn't redirect. If I put a query parameter in the url, it doesn't redirect either. I've tried the suggestions here without success: https://stackoverflow.com/questions/13063496/firefox-invalidate-dns-cache

I was using a staging site and then went live and redirected the staging domain to the live domain. However, I then needed to re-instate the staging site. Now, whenever I go to the home page of the staging site, it redirects me to the live site. Any other page or url doesn't redirect. If I put a query parameter in the url, it doesn't redirect either. I've tried the suggestions here without success: https://stackoverflow.com/questions/13063496/firefox-invalidate-dns-cache

Gekozen oplossing

Did you also try:

  • Test in a private window
  • If needed, test in a new profile

New Profile Test

This takes about 3 minutes, plus the time to test your site(s).

Inside Firefox, type or paste about:profiles in the address bar and press Enter/Return to load it.

Click the "Create a New Profile" button, then click Next. Assign a name like Oct2019, ignore the option to relocate the profile folder, and click the Finish button.

After creating the profile, scroll down to it and click the Launch profile in new browser button.

Firefox should open a new window that looks like a brand new, uncustomized installation. (Your existing Firefox window(s) should not be affected.) Please ignore any tabs enticing you to connect to a Sync account or to activate extensions found on your system so we can get a clean test.

Do the problem site(s) work any better in the new profile?

When you are done with the experiment, you can close the extra window without affecting your regular Firefox profile. (Oct2019 will remain available for future testing.)

Dit antwoord in context lezen 1
Citeren

Aanvullende systeemdetails

Geïnstalleerde plug-ins

  • Shockwave Flash 32.0 r0

Toepassing

  • Useragent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:70.0) Gecko/20100101 Firefox/70.0

Meer informatie

jscher2000
  • Top 10 Contributor
8775 oplossingen 71736 antwoorden

Gekozen oplossing

Did you also try:

  • Test in a private window
  • If needed, test in a new profile

New Profile Test

This takes about 3 minutes, plus the time to test your site(s).

Inside Firefox, type or paste about:profiles in the address bar and press Enter/Return to load it.

Click the "Create a New Profile" button, then click Next. Assign a name like Oct2019, ignore the option to relocate the profile folder, and click the Finish button.

After creating the profile, scroll down to it and click the Launch profile in new browser button.

Firefox should open a new window that looks like a brand new, uncustomized installation. (Your existing Firefox window(s) should not be affected.) Please ignore any tabs enticing you to connect to a Sync account or to activate extensions found on your system so we can get a clean test.

Do the problem site(s) work any better in the new profile?

When you are done with the experiment, you can close the extra window without affecting your regular Firefox profile. (Oct2019 will remain available for future testing.)

Did you also try: * Clear the page cache: [[How to clear the Firefox cache]] * Test in a private window * If needed, test in a new profile '''New Profile Test''' This takes about 3 minutes, plus the time to test your site(s). Inside Firefox, type or paste '''about:profiles''' in the address bar and press Enter/Return to load it. Click the "Create a New Profile" button, then click Next. Assign a name like Oct2019, ignore the option to relocate the profile folder, and click the Finish button. After creating the profile, scroll down to it and click the '''Launch profile in new browser''' button. Firefox should open a new window that looks like a brand new, uncustomized installation. (Your existing Firefox window(s) should not be affected.) Please ignore any tabs enticing you to connect to a Sync account or to activate extensions found on your system so we can get a clean test. ''Do the problem site(s) work any better in the new profile?'' When you are done with the experiment, you can close the extra window without affecting your regular Firefox profile. (Oct2019 will remain available for future testing.)
Was dit nuttig voor u? 1
Citeren

Vraageigenaar

Clearing the cache did the trick. I'm not sure why I hadn't tried it. Probably because I'd tried force reloading the page a number of times.

Clearing the cache did the trick. I'm not sure why I hadn't tried it. Probably because I'd tried force reloading the page a number of times.
Was dit nuttig voor u?
Citeren
Een vraag stellen

U moet zich aanmelden bij uw account om op berichten te antwoorden. Stel een nieuwe vraag als u nog geen account hebt.