X
Tik hier voor de mobiele versie van de website.

Ondersteuningsforum

How do I get rid of the horrible popup that appears as soon as I start typing in the address bar?

Geplaatst

After a recent Firefox upgrade, as soon as I start typing in the address bar, a blue bar pops up beneath it, and asks me if I want to search or visit a site. I DON"T WANT IT! How do I turn it off? I already have (in Settings / Privacy and Security / Address Bar) everything unchecked. I don't want ANY suggestions, EVER! How do I get rid of this latest idiocy, and return to the behavior of previous versions?

After a recent Firefox upgrade, as soon as I start typing in the address bar, a blue bar pops up beneath it, and asks me if I want to search or visit a site. I DON"T WANT IT! How do I turn it off? I already have (in Settings / Privacy and Security / Address Bar) everything unchecked. I don't want ANY suggestions, EVER! How do I get rid of this latest idiocy, and return to the behavior of previous versions?

Gekozen oplossing

Hello n.p.,

You posted this question before (and marked a post as "Chosen Solution") in this thread :

https://support.mozilla.org/en-US/questions/1249496

Apparantly this isn't working for you anymore (?)

In that case; would you please try this :

Type in the address bar about:config and press Enter (promise to be careful, if asked)

Type in the search bar :

browser.urlbar

Look for the preference :

browser.urlbar.maxRichResults and set its value to 0 (zero)

Then close and restart Firefox.

If, however, this does not do what you want, then reset the value.

You could also try to toggle this preference :

keyword.enabled (set it to false) and see if that will work for you.

Dit antwoord in context lezen 1
Citeren

Aanvullende systeemdetails

Geïnstalleerde plug-ins

none

Toepassing

  • Useragent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/75.0.3770.94 Safari/537.36 Vivaldi/2.6.1566.40

Meer informatie

WMagicModel
  • Top 25 Contributor
  • Administrator
6 oplossingen 120 antwoorden

Hi n.p,

I think you may have some unwanted malware. What is the message saying exactly and what site is it recommending?

Here is a link to troubleshoot Firefox issues caused by malware: Troubleshoot Firefox issues caused by malware

Check to see if your Firefox is up to date You could try restarting Firefox in safe mode


To manually do this:

  1. On the top right, click the menu button
  2. Click Help towards the bottom
  3. Click About at the bottom
  4. The second line of text will determine if your Firefox is up to date.

Supporting article:

[[Update Firefox to the latest release|https://support.mozilla.org/en-US/kb/update-firefox-latest-release]]

If Firefox is up to date, you could try rebooting Firefox in safe mode. Safe mode starts Firefox with a limited amount of files:

  1. Click the menu button
  2. Click Help
  3. Select Restart with with Add-ons Disabled
  OR
   Hold down the shift key while starting Firefox 

Supporting article:

[[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems|https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems]]

Hope this helps!

Hi n.p, I think you may have some unwanted '''malware'''. What is the message saying exactly and what site is it recommending? Here is a ''link'' to troubleshoot Firefox issues caused by malware: [[Troubleshoot Firefox issues caused by malware]] Check to see if your Firefox is '''up to date''' You could try restarting Firefox in '''safe mode''' To manually do this: # On the top right, click the '''menu button''' # Click '''Help''' towards the bottom # Click '''About''' at the bottom # The second line of text will determine if your Firefox is up to date. Supporting article: [['''Update Firefox to the latest release'''|https://support.mozilla.org/en-US/kb/update-firefox-latest-release]] If Firefox is up to date, you could try rebooting Firefox in '''safe mode'''. Safe mode starts Firefox with a limited amount of files: # Click the '''menu button''' # Click '''Help''' # Select Restart with with '''Add-ons Disabled''' '''OR''' Hold down the '''shift key''' while starting Firefox Supporting article: [['''Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems'''|https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems]] Hope this helps!
Was dit nuttig voor u?
Citeren
McCoy
  • Top 10 Contributor
521 oplossingen 4902 antwoorden

Gekozen oplossing

Hello n.p.,

You posted this question before (and marked a post as "Chosen Solution") in this thread :

https://support.mozilla.org/en-US/questions/1249496

Apparantly this isn't working for you anymore (?)

In that case; would you please try this :

Type in the address bar about:config and press Enter (promise to be careful, if asked)

Type in the search bar :

browser.urlbar

Look for the preference :

browser.urlbar.maxRichResults and set its value to 0 (zero)

Then close and restart Firefox.

If, however, this does not do what you want, then reset the value.

You could also try to toggle this preference :

keyword.enabled (set it to false) and see if that will work for you.

Hello n.p., You posted this question before (and marked a post as "Chosen Solution") in this thread : https://support.mozilla.org/en-US/questions/1249496 Apparantly this isn't working for you anymore (?) In that case; would you please try this : Type in the address bar '''about:config''' and press Enter (promise to be careful, if asked) Type in the search bar : '''browser.urlbar''' Look for the preference : '''browser.urlbar.maxRichResults''' and set its value to '''0''' (zero) Then close and restart Firefox. If, however, this does not do what you want, then reset the value. You could also try to toggle this preference : '''keyword.enabled''' (set it to '''false''') and see if that will work for you.
Was dit nuttig voor u? 1
Citeren

Vraageigenaar

FancyBryce said

Hi n.p, I think you may have some unwanted malware. What is the message saying exactly and what site is it recommending?

The only malware is what come with Firefox itself. What pops up is just an echo of my typing asking to either search of visit.

''FancyBryce [[#answer-1245372|said]]'' <blockquote> Hi n.p, I think you may have some unwanted '''malware'''. What is the message saying exactly and what site is it recommending? </blockquote> The only malware is what come with Firefox itself. What pops up is just an echo of my typing asking to either search of visit.
Was dit nuttig voor u?
Citeren

Vraageigenaar

McCoy said

Hello n.p., You posted this question before (and marked a post as "Chosen Solution") in this thread : https://support.mozilla.org/en-US/questions/1249496 Apparantly this isn't working for you anymore (?)

You are correct with that assumption. Apparently, something changed in Firefox 68.

McCoy said

In that case; would you please try this : Type in the address bar about:config and press Enter (promise to be careful, if asked) Type in the search bar : browser.urlbar Look for the preference : browser.urlbar.maxRichResults and set its value to 0 (zero) Then close and restart Firefox. If, however, this does not do what you want, then reset the value. You could also try to toggle this preference : keyword.enabled (set it to false) and see if that will work for you.

I looked back at my previous question (I had forgotten about it), and someone had noted (just last month) that:

#PopupAutoCompleteRichResult {display:none !important;}

no longer works in Firefox 68. Instead the new setting is:

#urlbar-results {display:none !important;}

I changed that AND tried your suggestions, and the combination of all of those (not sure which one actually made the difference) has indeed restored the old behavior.

I thank you very much, and will mark this problem solved.

''McCoy [[#answer-1245388|said]]'' <blockquote> Hello n.p., You posted this question before (and marked a post as "Chosen Solution") in this thread : https://support.mozilla.org/en-US/questions/1249496 Apparantly this isn't working for you anymore (?) </blockquote> You are correct with that assumption. Apparently, something changed in Firefox 68. ''McCoy [[#answer-1245388|said]]'' <blockquote> In that case; would you please try this : Type in the address bar '''about:config''' and press Enter (promise to be careful, if asked) Type in the search bar : '''browser.urlbar''' Look for the preference : '''browser.urlbar.maxRichResults''' and set its value to '''0''' (zero) Then close and restart Firefox. If, however, this does not do what you want, then reset the value. You could also try to toggle this preference : '''keyword.enabled''' (set it to '''false''') and see if that will work for you. </blockquote> I looked back at my previous question (I had forgotten about it), and someone had noted (just last month) that: #PopupAutoCompleteRichResult {display:none !important;} no longer works in Firefox 68. Instead the new setting is: #urlbar-results {display:none !important;} I changed that '''AND''' tried your suggestions, and the combination of all of those (not sure which one actually made the difference) has indeed restored the old behavior. I thank you very much, and will mark this problem solved.

Bewerkt door cor-el op

Was dit nuttig voor u?
Citeren

Vraageigenaar

Oops, the number one is supposed to be a pound sign in that reply. Is there some help page for the exact form of markup used here?

Oops, the number one is supposed to be a pound sign in that reply. Is there some help page for the exact form of markup used here?
Was dit nuttig voor u?
Citeren
jscher2000
  • Top 10 Contributor
8638 oplossingen 70685 antwoorden

n.p. said

Oops, the number one is supposed to be a pound sign in that reply. Is there some help page for the exact form of markup used here?

Hi n.p., putting a # in the first position creates a numbered list item. Putting a * in the first position creates a bulleted list item. Putting a space in the first position creates a preformatted code block.

''n.p. [[#answer-1245817|said]]'' <blockquote> Oops, the number one is supposed to be a pound sign in that reply. Is there some help page for the exact form of markup used here? </blockquote> Hi n.p., putting a # in the first position creates a numbered list item. Putting a * in the first position creates a bulleted list item. Putting a space in the first position creates a preformatted code block.
Was dit nuttig voor u?
Citeren
Een vraag stellen

U moet zich aanmelden bij uw account om op berichten te antwoorden. Stel een nieuwe vraag als u nog geen account hebt.