X
Tik hier voor de mobiele versie van de website.

Ondersteuningsforum

After Update to Version 68.0 Firefox (Win 10), Firefox doesn't display locally stored webfonts and uses Arial (same files online work fine)

Geplaatst

Today, I was designing a new webpage. It uses fonts like Open Sans etc (directly embedded via css, not via Google Fonts). After the update to 68.0 (from 67.0.4) the fonts aren't shown any more and Arial is used for everything. It only happens when opened the html-files locally. If you upload the same files to a webserver, everything works fine. With 67.0.4 (and all previous versions) the website works fine both ways. OS is Windows 10, 64 bit, Professional.

Today, I was designing a new webpage. It uses fonts like Open Sans etc (directly embedded via css, not via Google Fonts). After the update to 68.0 (from 67.0.4) the fonts aren't shown any more and Arial is used for everything. It only happens when opened the html-files locally. If you upload the same files to a webserver, everything works fine. With 67.0.4 (and all previous versions) the website works fine both ways. OS is Windows 10, 64 bit, Professional.

Gekozen oplossing

hi dnisn, this is likely happening due to this security fix: https://www.mozilla.org/en-US/security/advisories/mfsa2019-21/#CVE-2019-11730

try to change privacy.file_unique_origin to false in about:config, restart firefox and see if this can make a difference (please note that this makes you vulnerable to the described security problem though).

Dit antwoord in context lezen 1
Citeren

Aanvullende systeemdetails

Geïnstalleerde plug-ins

  • Shockwave Flash 31.0 r0

Toepassing

  • Useragent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

Meer informatie

philipp
  • Top 25 Contributor
  • Moderator
5315 oplossingen 23470 antwoorden

Gekozen oplossing

hi dnisn, this is likely happening due to this security fix: https://www.mozilla.org/en-US/security/advisories/mfsa2019-21/#CVE-2019-11730

try to change privacy.file_unique_origin to false in about:config, restart firefox and see if this can make a difference (please note that this makes you vulnerable to the described security problem though).

hi dnisn, this is likely happening due to this security fix: https://www.mozilla.org/en-US/security/advisories/mfsa2019-21/#CVE-2019-11730 try to change ''privacy.file_unique_origin'' to false in about:config, restart firefox and see if this can make a difference (please note that this makes you vulnerable to the described security problem though).
Was dit nuttig voor u? 1
Citeren

Vraageigenaar

Hi Philipp, thanks a lot! It works again with the change in about:config. I will keep the security issues in mind. Thanks again!

Hi Philipp, thanks a lot! It works again with the change in about:config. I will keep the security issues in mind. Thanks again!
Was dit nuttig voor u?
Citeren
rhardy702 0 oplossingen 1 antwoorden

I ran in to this or a similar problem when OpenSuse Leap upgraded from Firefox 60 to 68 a week or so ago and I then tried to locally access a very old Baen CD, such as found in http://baencd.thefifthimperium.com/01-HonorverseCD/Baen01-HonorverseCD.zip . The problem wasn't with fonts but with control mechanisms for manipulating the individual books, which disappeared. The chosen solution appears to be a fix.

I ran in to this or a similar problem when OpenSuse Leap upgraded from Firefox 60 to 68 a week or so ago and I then tried to locally access a very old Baen CD, such as found in http://baencd.thefifthimperium.com/01-HonorverseCD/Baen01-HonorverseCD.zip . The problem wasn't with fonts but with control mechanisms for manipulating the individual books, which disappeared. The chosen solution appears to be a fix.

Bewerkt door rhardy702 op

Was dit nuttig voor u?
Citeren
Een vraag stellen

U moet zich aanmelden bij uw account om op berichten te antwoorden. Stel een nieuwe vraag als u nog geen account hebt.