X
Tik hier voor de mobiele versie van de website.

Ondersteuningsforum

JavaScript is enabled but still getting message to enable Javascript

Geplaatst

Hi :-(

What a PITA this has become.

With FF 67.0.4 this message is coming up on the Airbnb site:

"We’re sorry, some parts of the Airbnb website don’t work properly without JavaScript enabled."

I've checked about:config and javascript is enabled (true).

Cleared the cache, cleared cookies . . . same message comes up.

On TripAdvisor https://www.tripadvisor.com/ all site images are not loading.

HALP!!

Any advice is much appreciated!  :-))

Hi :-( What a PITA this has become. With FF 67.0.4 this message is coming up on the Airbnb site: "We’re sorry, some parts of the Airbnb website don’t work properly without JavaScript enabled." I've checked about:config and javascript is enabled (true). Cleared the cache, cleared cookies . . . same message comes up. On TripAdvisor https://www.tripadvisor.com/ all site images are not loading. HALP!! Any advice is much appreciated! :-))

Gekozen oplossing

Hi JohnDohe, NoScript has a toolbar button which shows the status of what scripts in the page it is blocking. It blocks everything by default, so if you use NoScript, you need to spend a lot of time working that list and making exceptions. If that sounds like a huge hassle, it probably isn't a good extension for you to use.

On either computer, were you able to use the site in Firefox's Safe Mode? Safe Mode disables all the extensions, so it's a quick way to test whether an extension is causing the issue.

Dit antwoord in context lezen 0
Citeren

Aanvullende systeemdetails

Toepassing

  • Useragent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

Meer informatie

jscher2000
  • Top 10 Contributor
8583 oplossingen 70195 antwoorden

Hi JohnDohe, a lot of time, when a function doesn't work, the site assumes it is a problem with JavaScript being disabled. If JavaScript is disabled, half of the web will tell you right away, so that's usually not the issue. Instead, it's usually something more selective, like Firefox's Content Blocking feature, or an add-on, which knocks out a script or two.

If a site is generally known to work in Firefox, these are standard suggestions to try when it stops working normally:

Double-check content blockers: Firefox's Content Blocking feature and extensions that counter ads and tracking may break websites that embed third party content (meaning, from a secondary server).

(A) Do you see a shield icon toward the left end of the address bar, near the lock icon? More info on managing the Tracking Protection feature in this article: Content blocking.

(B) Extensions such as Adblock Plus, Blur, Disconnect, Ghostery, NoScript, Privacy Badger, uBlock Origin or uMatrix should provide toolbar buttons to manage blocked content in a page. There may or may not be a number on the icon indicating the number of blocked items; you may need to click the button to see what's going on and test whether you need to make an exception for this site.

Cache and Cookies: You've covered this one, you can skip to the next section. When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click (on Mac Ctrl+click) a blank area of the page and choose View Page Info > Security > "Clear Cookies and Site Data"
  • (menu bar) Tools > Page Info > Security > "Clear Cookies and Site Data"
  • click the padlock or "i" icon in the address bar, then the ">" button, then More Information, and finally the "Clear Cookies and Site Data" button

In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites.

Then try reloading the page. Does that help?

Testing in Firefox's Safe Mode: In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

Hi JohnDohe, a lot of time, when a function doesn't work, the site assumes it is a problem with JavaScript being disabled. If JavaScript is disabled, half of the web will tell you right away, so that's usually not the issue. Instead, it's usually something more selective, like Firefox's Content Blocking feature, or an add-on, which knocks out a script or two. If a site is generally known to work in Firefox, these are standard suggestions to try when it stops working normally: '''Double-check content blockers:''' Firefox's Content Blocking feature and extensions that counter ads and tracking may break websites that embed third party content (meaning, from a secondary server). (A) Do you see a shield icon toward the left end of the address bar, near the lock icon? More info on managing the Tracking Protection feature in this article: [[Content Blocking]]. (B) Extensions such as Adblock Plus, Blur, Disconnect, Ghostery, NoScript, Privacy Badger, uBlock Origin or uMatrix should provide toolbar buttons to manage blocked content in a page. There may or may not be a number on the icon indicating the number of blocked items; you may need to click the button to see what's going on and test whether you need to make an exception for this site. '''Cache and Cookies:''' '''''You've covered this one, you can skip to the next section.''''' When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site. (1) Clear Firefox's Cache See: [[How to clear the Firefox cache]] If you have a large hard drive, this might take a few minutes. (2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either: * right-click (on Mac Ctrl+click) a blank area of the page and choose View Page Info > Security > "Clear Cookies and Site Data" * (menu bar) Tools > Page Info > Security > "Clear Cookies and Site Data" * click the padlock or "i" icon in the address bar, then the ">" button, then More Information, and finally the "Clear Cookies and Site Data" button In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites. Then try reloading the page. Does that help? '''Testing in Firefox's Safe Mode:''' In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem. ''If Firefox is not running:'' Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.) ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" Help > Restart with Add-ons Disabled * (menu bar) Help menu > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Any improvement?
Was dit nuttig voor u?
Citeren

Vraageigenaar

@ jscher2000

I tried all of that.

Nothing worked.

What worked was: disabling the NoScript extension of FF.

That is . . . in Windows 7.

In my Mac with Mojave and the latest FF: disabling NoScript has no effect.

Same problem occurring.

But thanks!

@ jscher2000 I tried all of that. Nothing worked. What worked was: disabling the '''NoScript '''extension of FF. That is . . . in Windows 7. In my Mac with Mojave and the latest FF: disabling NoScript has no effect. Same problem occurring. But thanks!

Bewerkt door JohnDohe op

Was dit nuttig voor u?
Citeren
jscher2000
  • Top 10 Contributor
8583 oplossingen 70195 antwoorden

Gekozen oplossing

Hi JohnDohe, NoScript has a toolbar button which shows the status of what scripts in the page it is blocking. It blocks everything by default, so if you use NoScript, you need to spend a lot of time working that list and making exceptions. If that sounds like a huge hassle, it probably isn't a good extension for you to use.

On either computer, were you able to use the site in Firefox's Safe Mode? Safe Mode disables all the extensions, so it's a quick way to test whether an extension is causing the issue.

Hi JohnDohe, NoScript has a toolbar button which shows the status of what scripts in the page it is blocking. It blocks everything by default, so if you use NoScript, you need to spend a lot of time working that list and making exceptions. If that sounds like a huge hassle, it probably isn't a good extension for you to use. On either computer, were you able to use the site in Firefox's Safe Mode? Safe Mode disables all the extensions, so it's a quick way to test whether an extension is causing the issue.
Was dit nuttig voor u?
Citeren

Vraageigenaar

JohnDohe said

@ jscher2000 I tried all of that. Nothing worked. What worked was: disabling the NoScript extension of FF. That is . . . in Windows 7. In my Mac with Mojave and the latest FF: disabling NoScript has no effect. Same problem occurring. But thanks!

UPDATE:

In fact, NoScript isn't even loaded into my Mac extensions!

''JohnDohe [[#answer-1234580|said]]'' <blockquote> @ jscher2000 I tried all of that. Nothing worked. What worked was: disabling the '''NoScript '''extension of FF. That is . . . in Windows 7. In my Mac with Mojave and the latest FF: disabling NoScript has no effect. Same problem occurring. But thanks! </blockquote> UPDATE: In fact, NoScript isn't even loaded into my Mac extensions!
Was dit nuttig voor u?
Citeren
jscher2000
  • Top 10 Contributor
8583 oplossingen 70195 antwoorden

Okay, I'm not sure where we stand on this problem. What was the result of the Safe Mode test? Did that make any difference?

Okay, I'm not sure where we stand on this problem. What was the result of the Safe Mode test? Did that make any difference?
Was dit nuttig voor u?
Citeren

Vraageigenaar

It seems that in the interim between posting this issue and now, FF updated from 67.0.4 to 68.0 and the problem seems to have melted away.

We are trying to reproduce the issue but so far, all is well.

If this occurs again I will post the site(s).

Thanks!

It seems that in the interim between posting this issue and now, FF updated from 67.0.4 to 68.0 and the problem seems to have melted away. We are trying to reproduce the issue but so far, all is well. If this occurs again I will post the site(s). Thanks!

Bewerkt door JohnDohe op

Was dit nuttig voor u?
Citeren
Een vraag stellen

U moet zich aanmelden bij uw account om op berichten te antwoorden. Stel een nieuwe vraag als u nog geen account hebt.