X
Tik hier voor de mobiele versie van de website.

Ondersteuningsforum

Deze conversatie is gearchiveerd. Stel een nieuwe vraag als u hulp nodig hebt.

Firefox takes forever to load. How fix this? (And no, I don't want to do a reset of all my preferences!)

Geplaatst

I open the browser (homepage is google search - so a pretty empty space - but it makes no diff which homepage i use). And it takes a verrryyyyyyyy long time to load.

I have emptied cache etc etc etc, No viruses etc etc, Not caused by an add on....

And no, I dont want to do the 'reset' thing. (Why should I have to spend time every few weeks resetting all my Firefox preferences? This is a long standing BUG with firefox. Other browsers dont do this!)

How fix it? It seems to me that someone at Mozilla needs to address this bug. It's been around for a few years now.

I open the browser (homepage is google search - so a pretty empty space - but it makes no diff which homepage i use). And it takes a verrryyyyyyyy long time to load. I have emptied cache etc etc etc, No viruses etc etc, Not caused by an add on.... And no, I dont want to do the 'reset' thing. (Why should I have to spend time every few weeks resetting all my Firefox preferences? This is a long standing BUG with firefox. Other browsers dont do this!) How fix it? It seems to me that someone at Mozilla needs to address this bug. It's been around for a few years now.

Aanvullende systeemdetails

Geïnstalleerde plug-ins

  • Shockwave Flash 32.0 r0

Toepassing

  • Useragent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0

Meer informatie

FredMcD
  • Top 10 Contributor
4311 oplossingen 60542 antwoorden

https://support.mozilla.org/en-US/kb/update-firefox-latest-version?cache=no Did you update Firefox to the latest version 64.0.2 January 9, 2019


Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

https://support.mozilla.org/en-US/kb/update-firefox-latest-version?cache=no Did you update Firefox to the latest version '''64.0.2''' January 9, 2019 [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?
Pj 42 oplossingen 869 antwoorden

davidtay said

I open the browser ... it takes a very long time to load... Not caused by an add on...

64.0.2 is the latest. Why are you on 61?

You say it's not an Add-on (Extension) that is at fault. How did you determine this? What Extensions do yo have?

Meanwhile:
Click on the Windows icon 'Start' (bottom-left) and in the right column, bottom, click on Run. Enter in:

DxDiag /64bit

(Skip the /64bit part if it's Windows 32-Bit.)

...Wait until the green bar loads and disappears, then click "Save All Information".
Post back here in the Forum, just these information parts, under these three Headers:

    System Information
Display Devices
Disk & DVD/CD-ROM Drives

Make sure your computer is not too 'LOW' on disk-remaining space. This will be a major performance problem if your remaining disk space is TOO LOW!
Example: At the moment, I have 37% space free. If you're way under 25%, then you're probably running into performance / Memory issues.
Windows-7 and Programs like to have plenty of free-disk 'breathing' room. I recently cleared over 75 Gigs worth to get me to about 37% of free disk space.

Perhaps you may wish to setup a ReadyBoost Flash Drive.
If you have a lot of Windows and Tabs and your FireFox Browser is set to Restore Session when you start-up FF, the following will help with conserving some Memory:

Go to Options. Edit or Insert in the URL Box About:Config and go there. Set the following Values:

browser.newtabpage.enabled; false

browser.newtabpage.enhanced; false

browser.sessionstore.restore_pinned_tabs_on_demand; true


This will preload only the last Tab you were parked on per browser window. The other Tabs from your Previous Session will load only when you click on them.

If you open a lot of browser windows, you can set the maximum 'remembered' browser windows higher than the default for your Restored Session. My max is set for 25:

browser.sessionstore.max_windows_undo; 25

Finally, I did the following FireFox adjustments for my old 2010 computer with the Performance settings in Options as shown in the image attachment:


~Pj

''davidtay [[#question-1247888|said]]'' <blockquote> I open the browser ... it takes a very long time to load... Not caused by an add on... </blockquote> 64.0.2 is the latest. Why are you on 61? You say it's not an Add-on (Extension) that is at fault. How did you determine this? What Extensions do yo have? Meanwhile: <Br> Click on the Windows icon ''''Start'''' (bottom-left) and in the right column, bottom, click on '''Run'''. Enter in: <Center>'''DxDiag /64bit'''</Center><Br> <Center> (Skip the '''/64bit''' part if it's Windows 32-Bit.)</Center><Br> ...Wait until the green bar loads and disappears, then click "'''Save All Information'''". <Br> Post back here in the Forum, just these information parts, under these three Headers:<Br> '''System Information'''<Br> '''Display Devices'''<Br> '''Disk & DVD/CD-ROM Drives'''<Br> Make sure your computer is not too 'LOW' on disk-remaining space. This will be a major performance problem if your remaining disk space is '''TOO LOW!'''<Br> Example: At the moment, I have 37% space free. If you're way under 25%, then you're probably running into performance / Memory issues.<Br> Windows-7 and Programs like to have plenty of free-disk 'breathing' room. I recently cleared over 75 Gigs worth to get me to about 37% of free disk space.<Br><Br> Perhaps you may wish to setup a '''ReadyBoost''' Flash Drive.<Br> If you have a lot of Windows and Tabs and your FireFox Browser is set to '''Restore Session''' when you start-up FF, the following will help with conserving some Memory:<Br><Br> Go to '''Options'''. Edit or Insert in the URL Box '''About:Config''' and go there. Set the following Values:<Br> <Center> '''browser.newtabpage.enabled; false'''<Br><Br> '''browser.newtabpage.enhanced; false'''<Br><Br> '''browser.sessionstore.restore_pinned_tabs_on_demand; true''' </Center><Br> This will preload only the last Tab you were parked on per browser window. The other Tabs from your Previous Session will load only when you click on them.<Br><Br> If you open a lot of browser windows, you can set the maximum 'remembered' browser windows higher than the default for your Restored Session. My max is set for 25:<Br><Br> <Center>'''browser.sessionstore.max_windows_undo; 25'''</Center><Br> Finally, I did the following FireFox adjustments for my old 2010 computer with the '''Performance''' settings in '''Options''' as shown in the image attachment: <Br><Br><Br> ~Pj

Bewerkt door Pj op