Zoeken in Support

Vermijd ondersteuningsscams. We zullen u nooit vragen een telefoonnummer te bellen, er een sms naar te sturen of persoonlijke gegevens te delen. Meld verdachte activiteit met de optie ‘Misbruik melden’.

Learn More

Deze conversatie is gearchiveerd. Stel een nieuwe vraag als u hulp nodig hebt.

Can't edit search engine

  • 4 antwoorden
  • 1 heeft dit probleem
  • 98 weergaven
  • Laatste antwoord van volechy

more options

I have problems managing search engines. The default options are regularly restored (deleted engines come back), despite their removal. Cleaning the profile did not help. Why are the settings restored and how to fix it?

Alle antwoorden (4)

more options

Hi volechy, some users have reported that if they use Remove for some or all of the built-in search engines, they are restored by a later update.

Workarounds

(A) It is simplest to uncheck (click in the left column of the list to check and uncheck) the built-in search engines you do not want to see in the set of search icons.

(B) If you don't want the row of search icons to appear at the bottom of the address bar drop-down at all, there is a setting to hide it:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste oneoff and pause while the list is filtered

(3) Double-click the browser.urlbar.oneOffSearches preference to switch the value from true to false

Search Preference Storage

Unchecked search engine plugins

You'll notice the browser.search.hiddenOneOffs preference in about:config lists the search engines you "unchecked" and this information is stored in the prefs.js file (in your Firefox profile folder).

Removed search engine plugins

If you "Remove" a built-in search engine, that is recorded in the compressed file search.json.mozlz4 (in your Firefox profile folder). If you want to read this file, I have a decompressor here:

https://www.jeffersonscher.com/ffu/searchjson.html

The page shouldn't list any removed search engines that were added on; those should be purged from the file when you remove them.

more options

Thank you for your prompt response. The proposed option does not suit me. Is the problem solved by downgrade to the previous version and blocking auto-update? Do you plan to fix this problem in future versions?

more options

Hi volechy, just to be clear, support forum volunteers aren't the ones coding Firefox, and this is not a new issue in Firefox 64, it seems to strike randomly.

In the following thread for Firefox 56, the problem was cured by removing several search files from the profile folder and letting Firefox regenerate the newest one: How Can I Stop Firefox From Updating My Search Engines?

Maybe that will work for you.

more options

switching off search engines updates was help. Thank you for help.