Zoeken in Support

Vermijd ondersteuningsscams. We zullen u nooit vragen een telefoonnummer te bellen, er een sms naar te sturen of persoonlijke gegevens te delen. Meld verdachte activiteit met de optie ‘Misbruik melden’.

Learn More

Deze conversatie is gearchiveerd. Stel een nieuwe vraag als u hulp nodig hebt.

Is anyone else experiencing extreme slowness loading pages since upgrading to Firefox 63.0?

  • 6 antwoorden
  • 2 hebben dit probleem
  • 52 weergaven
  • Laatste antwoord van Pushmataha

more options

Upgraded to Firefox 63.0 and all of a sudden started to see extreme sluggishness on every website I visited, especially Facebook, YouTube and some auction sites. I played around with the security settings, because this is what I saw changes in from my previous browser version to this new one, and that did not correct the sluggishness. I removed 63.0 and went back to my last browser 62.0.3 and bam, sluggishness gone. What changes were made that could have made this occur?

Alle antwoorden (6)

more options

hi, could you please check in the firefox menu ≡ > options > general panel that you have set firefox to connect directly to the internet (="no proxy") and see if the problem is still present afterwards?

more options

Thank you for your feedback, Philipp, but I'm a little unsure how changing the proxy setting will make a difference as I've used the same setting for years, over multiple versions, without any issue untill version 63.0 came out. I may give it a try on the weekend, when I have more time, just to see. I'm a little surprised I'm the only person experiencing this issue.

more options

Experience the same. Did not revert to previous version but tried concurrrent webbrowsers.

Some pages load after seconds.....notice when viewing the bottom on resolving the webpage info. Time between refresh and updates on this 'status' up to 10 seconds. Looks like a dns resolving issue before the actual refresh of the webpage begins.

more options

tried the 'no proxy' setting.

Testing, seems faster.

more options

set it to 3 third option :Use System settings. My work laptop had same and that one is working fast.

Ok for me now.

more options

Worked great for me. Thanks.