X
Tik hier voor de mobiele versie van de website.

Ondersteuningsforum

Deze conversatie is gearchiveerd. Stel een nieuwe vraag als u hulp nodig hebt.

Automatic Proxy Login

Geplaatst

Every time I open firefox, I get prompted to enter my proxy credentials. This is extremely annoying, because I open and close the browser >20x a day.

This was never a problem before because I used the wonderful AutoAuth addon which automatically took care of that kind of thing, but now with the new version of Firefox the addon had to be re-written and now it doesn't work in the same way - notably that each set of credentials have to be tied to a website, and that doesn't work for a proxy.

I have signon.autologin.proxy;true, but this doesn't seem to work, or do anything at all. I also searched around the internet and found some really old fixes, but none of them helped or are applicable anymore.

If for some reason this can't be fixed, ideally at least change the startup auto-connect prompts (presumably looking for updates) to wait for an internet connection, wait for 1 minute once I actually access the internet and have auto-auth do its thing, or stop them from triggering more than once a day.

Any help would be greatly appreciated, this is driving me mad!

Every time I open firefox, I get prompted to enter my proxy credentials. This is extremely annoying, because I open and close the browser >20x a day. This was never a problem before because I used the wonderful AutoAuth addon which automatically took care of that kind of thing, but now with the new version of Firefox the addon had to be re-written and now it doesn't work in the same way - notably that each set of credentials have to be tied to a website, and that doesn't work for a proxy. I have signon.autologin.proxy;true, but this doesn't seem to work, or do anything at all. I also searched around the internet and found some really old fixes, but none of them helped or are applicable anymore. If for some reason this can't be fixed, ideally at least change the startup auto-connect prompts (presumably looking for updates) to wait for an internet connection, wait for 1 minute once I actually access the internet and have auto-auth do its thing, or stop them from triggering more than once a day. Any help would be greatly appreciated, this is driving me mad!

Aanvullende systeemdetails

Geïnstalleerde plug-ins

  • Shockwave Flash 30.0 r0

Toepassing

  • Useragent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:60.0) Gecko/20100101 Firefox/60.0

Meer informatie

FFus3r 50 oplossingen 757 antwoorden
see this page: * https://support.mozilla.org/en-US/kb/connection-settings-firefox

Vraageigenaar

FFus3r said

see this page:

Thanks, but I'm aware of how to set up a proxy. My proxy is set up correctly, however the "Do not prompt for authentification" button (listed on the page you linked to) does nothing, and my extension that used to hide the issue (AutoAuth) no longer works due to changes in how FF handles extensions.

''FFus3r [[#answer-1159203|said]]'' <blockquote> see this page: * https://support.mozilla.org/en-US/kb/connection-settings-firefox </blockquote> Thanks, but I'm aware of how to set up a proxy. My proxy is set up correctly, however the "Do not prompt for authentification" button (listed on the page you linked to) does nothing, and my extension that used to hide the issue (AutoAuth) no longer works due to changes in how FF handles extensions.
FFus3r 50 oplossingen 757 antwoorden
* https://addons.mozilla.org/en-US/firefox/addon/autoauth/

Vraageigenaar

Are you a bot or something? lol

I clearly said in both posts that Autoauth (what you linked to) no longer bypasses the proxy login box thanks to Firefox's new WebExtensions API

Are you a bot or something? lol I clearly said in both posts that Autoauth (what you linked to) no longer bypasses the proxy login box thanks to Firefox's new WebExtensions API