X
Tik hier voor de mobiele versie van de website.

Ondersteuningsforum

Deze conversatie is gearchiveerd. Stel een nieuwe vraag als u hulp nodig hebt.

Cursor and text doesn't display in some input box

Geplaatst

In some input text area, cursor and text doesn't display, although the input box accept those input. The text input can be seen if highlight is applied. Otherwise, the input box will show nothing

In some input text area, cursor and text doesn't display, although the input box accept those input. The text input can be seen if highlight is applied. Otherwise, the input box will show nothing
Gekoppelde schermafbeeldingen

Bewerkt door Box_Hezi op

Gekozen oplossing

Are you possibly using a dark theme in your Linux distribution?

Dit antwoord in context lezen 1

Vraageigenaar

There are two screenshot in different site's input box

There are two screenshot in different site's input box
jscher2000
  • Top 10 Contributor
8783 oplossingen 71822 antwoorden

If text becomes visible when selected, it sounds like a problem of white text on a white background. However, I don't know what causes that.

As a first step toward discovering the cause, could you try setting Firefox to strictly follow page colors and see whether that makes any difference. Let us know what happens:

On the Preferences page:

  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type color and Firefox should filter the page down so you can easily find the "Colors" button. Go ahead and click that.

Try changing this setting:

"Override the colors specified by the page with your selections above"

Below that, it usually says

"Only with High Contrast themes"

Click that and change the setting to

"Never"

then click OK to finish the change.

Does that help at all?

Here's a screenshot of that part of the Colors dialog:

If text becomes visible when selected, it sounds like a problem of white text on a white background. However, I don't know what causes that. As a first step toward discovering the cause, could you try setting Firefox to strictly follow page colors and see whether that makes any difference. Let us know what happens: On the Preferences page: * Linux: "3-bar" menu button (or Edit menu) > Preferences * Windows: "3-bar" menu button (or Tools menu) > Options * Mac: "3-bar" menu button (or Firefox menu) > Preferences * Any system: type or paste '''about:preferences''' into the address bar and press Enter/Return to load it In the search box at the top of the page, type ''color'' and Firefox should filter the page down so you can easily find the "Colors" button. Go ahead and click that. Try changing this setting: "Override the colors specified by the page with your selections above" Below that, it usually says "Only with High Contrast themes" Click that and change the setting to "'''Never'''" then click OK to finish the change. Does that help at all? Here's a screenshot of that part of the Colors dialog: <img src="https://prod-cdn.sumo.mozilla.net/uploads/images/2018-01-21-12-48-55-d2a6b4.png" width="500">
cor-el
  • Top 10 Contributor
  • Moderator
17564 oplossingen 158873 antwoorden

Gekozen oplossing

Are you possibly using a dark theme in your Linux distribution?

Are you possibly using a dark theme in your Linux distribution?

Vraageigenaar

Thank u guys, the problem is I am using some dark theme on my linux distribution, and I solved it if I change back to default or light theme

Thank u guys, the problem is I am using some dark theme on my linux distribution, and I solved it if I change back to default or light theme