Zoeken in Support

Vermijd ondersteuningsscams. We zullen u nooit vragen een telefoonnummer te bellen, er een sms naar te sturen of persoonlijke gegevens te delen. Meld verdachte activiteit met de optie ‘Misbruik melden’.

Learn More

Deze conversatie is gearchiveerd. Stel een nieuwe vraag als u hulp nodig hebt.

trying to configure FF using policies.json file, but not all configurations are being recognized

  • 5 antwoorden
  • 1 heeft dit probleem
  • 224 weergaven
  • Laatste antwoord van RJF1nra

more options

We will be using Group Policy for our windows devices but need to use the json file for our Mac users. Unfortunately, FF is not accepting all the JSON configs. JSON file below (domain names have been xd out

{
  "policies": {
    "DisableFirefoxAccounts": true,
    "DisablePocket": true,
    "DisableAppUpdate": true,
    "DontCheckDefaultBrowser": true,
    "OfferToSaveLogins": true,
   		
	"Homepage": {
	 "URL": "https://xxx.xxx.org",
	 "Locked": true,			
    
		"Authentication": {
		 "SPNEGO": ["xxx.xxx", "xxx.com", "xxx.com"],
		 "Delegated": ["xxx.xxx", "xxx.com", "xxx.com"],
         "NTLM": ["finra.org", "xxx.xxx", "xxx.com", "xxx.com""],
		 "AllowNonFQDN": {
			"SPNEGO": true,
			"NTLM": true,  
		
				"Proxy": {
				 "Mode": "autoDetect",
				 "Locked": true,
	 
					"Certificates": {
					 "ImportEnterpriseRoots": true
	  }
	 }
	}	
   }
  }
 }
}
We will be using Group Policy for our windows devices but need to use the json file for our Mac users. Unfortunately, FF is not accepting all the JSON configs. JSON file below (domain names have been xd out <pre><nowiki>{ "policies": { "DisableFirefoxAccounts": true, "DisablePocket": true, "DisableAppUpdate": true, "DontCheckDefaultBrowser": true, "OfferToSaveLogins": true, "Homepage": { "URL": "https://xxx.xxx.org", "Locked": true, "Authentication": { "SPNEGO": ["xxx.xxx", "xxx.com", "xxx.com"], "Delegated": ["xxx.xxx", "xxx.com", "xxx.com"], "NTLM": ["finra.org", "xxx.xxx", "xxx.com", "xxx.com""], "AllowNonFQDN": { "SPNEGO": true, "NTLM": true, "Proxy": { "Mode": "autoDetect", "Locked": true, "Certificates": { "ImportEnterpriseRoots": true } } } } } } }</nowiki></pre>

Bewerkt door cor-el op

Gekozen oplossing

You misplaced a lot of closing curly brackets They are all at the bottom instead of after the section they are part of.

I think that this is what you want :

{
  "policies": {
    "DisableFirefoxAccounts": true,
    "DisablePocket": true,
    "DisableAppUpdate": true,
    "DontCheckDefaultBrowser": true,
    "OfferToSaveLogins": true,
    "Homepage": {
     "URL": "https://xxx.xxx.org",
     "Locked": true
    },
    "Authentication": {
      "SPNEGO": ["xxx.xxx", "xxx.com", "xxx.com"],
      "Delegated": ["xxx.xxx", "xxx.com", "xxx.com"],
      "NTLM": ["finra.org", "xxx.xxx", "xxx.com", "xxx.com"]
    },
    "AllowNonFQDN": {
      "SPNEGO": true,
      "NTLM": true
    },
    "Proxy": {
      "Mode": "autoDetect",
      "Locked": true
    },
    "Certificates": {
      "ImportEnterpriseRoots": true
    }
  }
}
Dit antwoord in context lezen 👍 1

Alle antwoorden (5)

more options

You seem to be missing a lot of closing brackets in your file. For example, you have "Homepage": { "URL": "xxxx", "Locked": true, but it should be "Homepage": { "URL": "xxxx", "Locked": true }, which is a really easy mistake to make, but it will make things stop working.

Your file should look something like this: "policies": { "DisableFirefoxAccounts": true, "DisablePocket": true, "DisableAppUpdate": true, "DontCheckDefaultBrowser": true, "OfferToSaveLogins": true, "Homepage": { "URL": "https://xxx.xxx.org", "Locked": true }, "Authentication": { "SPNEGO": ["xxx.xxx", "xxx.com", "xxx.com"], "Delegated": ["xxx.xxx", "xxx.com", "xxx.com"], "NTLM": ["finra.org", "xxx.xxx", "xxx.com", "xxx.com""] }, "AllowNonFQDN": { "SPNEGO": true, "NTLM": true }, "Proxy": { "Mode": "autoDetect", "Locked": true }, "Certificates": { "ImportEnterpriseRoots": true } }

If you are still having issues, let us know what specific policies aren't working and we can see if there are any other issues.

more options

I think I just didn't copy and past them, let me try this again. As the below file sits, the policies stop after setting the home page

{

 "policies": {
   "DisableFirefoxAccounts": true,
   "DisablePocket": true,
   "DisableAppUpdate": true,
   "DontCheckDefaultBrowser": true,
   "OfferToSaveLogins": true,
  		

"Homepage": { "URL": "https://xxx.xxx.org", "Locked": true,

"Authentication": { "SPNEGO": ["xxx.org", "xxx.com", "xxx.com"], "Delegated": ["xxx.org", "xxx.com", "xxx.com"],

        "NTLM": ["xxx.org", "xxx.com", "xxx.com"],

"AllowNonFQDN": { "SPNEGO": true, "NTLM": true,

"Proxy": { "Mode": "autoDetect", "Locked": true,

"Certificates": { "ImportEnterpriseRoots": true } } }

  }
 }
}

}

more options

It's possible that the forum is just hiding some of the brackets that you are using. Try surrounding your code with the <code> tag. This will stop the forum from trying to interpret your code and it will just show the plain text.

For example:

<code> {PASTE YOUR CODE} </code>

This will give us on the forum the ability to see exactly what your code is, since what you have pasted into your most recent reply is still missing vital brackets.

more options

Gekozen oplossing

You misplaced a lot of closing curly brackets They are all at the bottom instead of after the section they are part of.

I think that this is what you want :

{
  "policies": {
    "DisableFirefoxAccounts": true,
    "DisablePocket": true,
    "DisableAppUpdate": true,
    "DontCheckDefaultBrowser": true,
    "OfferToSaveLogins": true,
    "Homepage": {
     "URL": "https://xxx.xxx.org",
     "Locked": true
    },
    "Authentication": {
      "SPNEGO": ["xxx.xxx", "xxx.com", "xxx.com"],
      "Delegated": ["xxx.xxx", "xxx.com", "xxx.com"],
      "NTLM": ["finra.org", "xxx.xxx", "xxx.com", "xxx.com"]
    },
    "AllowNonFQDN": {
      "SPNEGO": true,
      "NTLM": true
    },
    "Proxy": {
      "Mode": "autoDetect",
      "Locked": true
    },
    "Certificates": {
      "ImportEnterpriseRoots": true
    }
  }
}
more options

That took care of it, thank you very much.