Zoeken in Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Deze conversatie is gearchiveerd. Stel een nieuwe vraag als u hulp nodig hebt.

Facebook.com seems to be always laggy and makes whole browser slow. (firefox latest version) recently.

  • 8 antwoorden
  • 1 heeft dit probleem
  • 49 weergaven
  • Laatste antwoord van FredMcD

more options

but m.facebook runs smoothly and sound. and all other sites works normally. I have already removed all the cache and history and still no solutions.

Note: i have only two add ons enabled (idm and add block)

Alle antwoorden (8)

more options

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

more options

FredMcD said

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

I did it. it seems to be facebook.com is little smooth and responsive than before. so what should i do to make it smooth in normal mode?

more options

It could be the work of one of your add-ons, or it could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

more options

sorry for the late reply. the facebook is still too laggy and slow and responsive. most of the times the page wont open at all. i am using m.facebook, pleas fix this asap otherwise i will switch to other browser i think. this is too frustatng

more options

and this problem is not on my laptop alone. yesterday i went to my friend's house, however facebook.com opens but after some times ( 2 minute), the whole browser becomes too much unresponsive. only way to solve that is to quit facebook and the browser runs smoothly.

more options

Did you do what I posted last?


One issue that seems more common lately is Firefox's Tracking Protection feature. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature: Tracking Protection {web link}

Bewerkt door FredMcD op

more options

yes, i followed all the steps you mentioned. It is still too laggy and unresponsive even in private browser. In safe mode, the peformance improves somewhat a little bit but still it is bit laggy. however facebook.com is only one site thats suffering from the problem. soo frustating. still using m.facebook

more options

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.


Start your Computer in safe mode with network support. Then start Firefox. Try Secure websites. Is the problem still there?

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia