X
Tik hier voor de mobiele versie van de website.

Ondersteuningsforum

Deze conversatie is gearchiveerd. Stel een nieuwe vraag als u hulp nodig hebt.

Cannot click/select some password fields in firefox on Ubuntu

Geplaatst

Hello

I am currently using Ubuntu 18.04 and Firefox Quantum 59.0.2 64-bit. On some websites, I am unable to select the password field either using tab or a mouse click to be able to enter a password. This leaves me unable to login. However, this doesnt seem to happen on all password fields.

For example on https://reddit.com I can enter username and password on the field on the right. However, if I click on Login hyperlink on 'Want to join? Log in or sign up in seconds.', I get a popup which I am unable to click the password field on.

I have also seen this problem on https://abnzb.com

I have tried to run in safe-mode but the problem persists.

My addons are Gnome shell integration, Enhanced Steam, HTTPS Everywhere, uBlock origin.

Also, to add to this. When I right click on the password text fields, I do not get a menu popup. I am not sure if this is related or not.

Hello I am currently using Ubuntu 18.04 and Firefox Quantum 59.0.2 64-bit. On some websites, I am unable to select the password field either using tab or a mouse click to be able to enter a password. This leaves me unable to login. However, this doesnt seem to happen on all password fields. For example on https://reddit.com I can enter username and password on the field on the right. However, if I click on Login hyperlink on 'Want to join? Log in or sign up in seconds.', I get a popup which I am unable to click the password field on. I have also seen this problem on https://abnzb.com I have tried to run in safe-mode but the problem persists. My addons are Gnome shell integration, Enhanced Steam, HTTPS Everywhere, uBlock origin. Also, to add to this. When I right click on the password text fields, I do not get a menu popup. I am not sure if this is related or not.

Bewerkt door mattxo op

Gekozen oplossing

Just to add an update. I have since installed the snap version of firefox on ubuntu and the issue is gone.

Thanks for your help.

Dit antwoord in context lezen 0

Aanvullende systeemdetails

Toepassing

  • Firefox 59.0.2
  • Useragent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:59.0) Gecko/20100101 Firefox/59.0
  • Ondersteunings-URL: https://support.mozilla.org/1/firefox/59.0.2/Linux/en-US/

Extensies

  • Enhanced Steam 9.8.1 (jid1-YdiFiTEkQgInxA@jetpack) (Inactief)
  • GNOME Shell integration 10.1 (chrome-gnome-shell@gnome.org) (Inactief)
  • HTTPS Everywhere 2018.4.11 (https-everywhere@eff.org) (Inactief)
  • uBlock Origin 1.15.24 (uBlock0@raymondhill.net) (Inactief)

Javascript

  • incrementalGCEnabled: True

Grafisch

  • adapterDescription: X.Org -- AMD HAWAII (DRM 2.50.0 / 4.15.0-13-generic, LLVM 6.0.0)
  • adapterDeviceID: AMD HAWAII (DRM 2.50.0 / 4.15.0-13-generic, LLVM 6.0.0)
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: X.Org
  • crashGuards: []
  • driverDate:
  • driverVersion: 3.0 Mesa 18.0.0-rc5
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'blocked', u'description': u'Compositing', u'name': u'HW_COMPOSITING', u'log': [{u'status': u'blocked', u'message': u'Acceleration blocked by platform', u'type': u'default'}, {u'status': u'blocked', u'message': u'Acceleration blocked by safe-mode', u'type': u'runtime'}]}, {u'status': u'unavailable', u'description': u'OpenGL Compositing', u'name': u'OPENGL_COMPOSITING', u'log': [{u'status': u'unavailable', u'message': u'Hardware compositing is disabled', u'type': u'default'}]}, {u'status': u'unavailable', u'description': u'WebRender', u'name': u'WEBRENDER', u'log': [{u'status': u'opt-in', u'message': u'WebRender is an opt-in feature', u'type': u'default'}, {u'status': u'unavailable', u'message': u"Build doesn't include WebRender", u'type': u'runtime'}]}, {u'status': u'blocked', u'description': u'Off Main Thread Painting', u'name': u'OMTP', u'log': [{u'status': u'disabled', u'message': u'Disabled by default', u'type': u'default'}, {u'status': u'blocked', u'message': u'OMTP blocked by safe-mode', u'type': u'runtime'}]}]}
  • info: {u'ApzWheelInput': 1, u'ApzDragInput': 1, u'ApzKeyboardInput': 1, u'CairoUseXRender': 0, u'ApzAutoscrollInput': 1, u'AzureFallbackCanvasBackend': u'none', u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'skia', u'AzureContentBackend': u'skia'}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 2
  • offMainThreadPaintEnabled: False
  • webgl1DriverExtensions: -
  • webgl1Extensions: -
  • webgl1Renderer: WebGL is currently disabled.
  • webgl1Version: -
  • webgl1WSIInfo: -
  • webgl2DriverExtensions: -
  • webgl2Extensions: -
  • webgl2Renderer: WebGL is currently disabled.
  • webgl2Version: -
  • webgl2WSIInfo: -
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic
  • windowUsingAdvancedLayers: False

Aangepaste voorkeuren

Div

  • User JS: nee
  • Toegankelijkheid: nee
FredMcD
  • Top 10 Contributor
4254 oplossingen 59583 antwoorden

Let's try this;

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

Let's try this; Many site issues can be caused by corrupt cookies or cache. * Clear the Cache and * Remove Cookies '''Warning ! ! ''' This will log you out of sites you're logged in to. You may also lose any settings for that website. * '''Cookies; ''' [https://support.mozilla.org/en-US/kb/delete-cookies-remove-info-websites-stored Delete cookies to remove the information websites have stored on your computer] {web link} * '''Cache; ''' [https://support.mozilla.org/en-US/kb/how-clear-firefox-cache How to clear the Firefox cache] {web link} If there is still a problem, '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Did this help? While you are in safe mode; Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches. ''[https://support.mozilla.org/en-US/kb/forum-response-disable-hardware-acceleration How to disable Hardware Acceleration]'' {web link}

Vraageigenaar

FredMcD said

Let's try this; Many site issues can be caused by corrupt cookies or cache.
  • Clear the Cache and
  • Remove Cookies
Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website. If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help? While you are in safe mode; Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches. How to disable Hardware Acceleration {web link}

Ok, so I tried all of this and it didn't work but thanks for the reply.

''FredMcD [[#answer-1101862|said]]'' <blockquote> Let's try this; Many site issues can be caused by corrupt cookies or cache. * Clear the Cache and * Remove Cookies '''Warning ! ! ''' This will log you out of sites you're logged in to. You may also lose any settings for that website. * '''Cookies; ''' [https://support.mozilla.org/en-US/kb/delete-cookies-remove-info-websites-stored Delete cookies to remove the information websites have stored on your computer] {web link} * '''Cache; ''' [https://support.mozilla.org/en-US/kb/how-clear-firefox-cache How to clear the Firefox cache] {web link} If there is still a problem, '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Did this help? While you are in safe mode; Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches. ''[https://support.mozilla.org/en-US/kb/forum-response-disable-hardware-acceleration How to disable Hardware Acceleration]'' {web link} </blockquote> Ok, so I tried all of this and it didn't work but thanks for the reply.
FredMcD
  • Top 10 Contributor
4254 oplossingen 59583 antwoorden

There are some web pages that do not allow browsers to record or fill in the log-in information. You can try a Form Filling add-on.

Go to the Mozilla Add-ons Web Page {web Link} (There’s a lot of good stuff here) and search for what you want.

There are some web pages that do not allow browsers to record or fill in the log-in information. You can try a '''Form Filling''' add-on. Go to the [https://addons.mozilla.org/en-US/firefox/ Mozilla Add-ons Web Page] {web Link} (There’s a lot of good stuff here) and search for what you want.

Vraageigenaar

FredMcD said

There are some web pages that do not allow browsers to record or fill in the log-in information. You can try a Form Filling add-on. Go to the Mozilla Add-ons Web Page {web Link} (There’s a lot of good stuff here) and search for what you want.

I'm not trying to perform an auto fill of my information. I am simply trying to click the box or tab into it so that I can type into it.

''FredMcD [[#answer-1102287|said]]'' <blockquote> There are some web pages that do not allow browsers to record or fill in the log-in information. You can try a '''Form Filling''' add-on. Go to the [https://addons.mozilla.org/en-US/firefox/ Mozilla Add-ons Web Page] {web Link} (There’s a lot of good stuff here) and search for what you want. </blockquote> I'm not trying to perform an auto fill of my information. I am simply trying to click the box or tab into it so that I can type into it.
FredMcD
  • Top 10 Contributor
4254 oplossingen 59583 antwoorden

Ahh. Are the fields blocked?

Did you get your Firefox from Mozilla.org ?

Ahh. Are the fields blocked? Did you get your Firefox from Mozilla.org ?

Vraageigenaar

FredMcD said

Ahh. Are the fields blocked? Did you get your Firefox from Mozilla.org ?

The fields are completely unclickable. It doesn't have a red circle icon when hovering on it like when a field is disabled.

The firefox version I am using is bundled into Ubuntu 18.04.

''FredMcD [[#answer-1102344|said]]'' <blockquote> Ahh. Are the fields blocked? Did you get your Firefox from Mozilla.org ? </blockquote> The fields are completely unclickable. It doesn't have a red circle icon when hovering on it like when a field is disabled. The firefox version I am using is bundled into Ubuntu 18.04.
FredMcD
  • Top 10 Contributor
4254 oplossingen 59583 antwoorden

Pleasse try using the program from; Download Firefox For All languages And Systems {web link}

Pleasse try using the program from; '''[http://www.mozilla.org/en-US/firefox/all/ Download Firefox For All languages And Systems]''' {web link}

Vraageigenaar

FredMcD said

Pleasse try using the program from; Download Firefox For All languages And Systems {web link}

I have just tried this but the issue still exists. I have noticed that If i am quick and pressing the login button on reddit and then try and quickly click the box and start typing some junk it will allow a few characters before denying any further entry.

I think this may be a javascript issue?

When I open the login page the console displays the following:

XML Parsing Error: not well-formed Location: https://www.reddit.com/api/vote.json Line Number 1, Column 1:

The response from vote.json is simply: { }

Could this be something to do with it

''FredMcD [[#answer-1102710|said]]'' <blockquote> Pleasse try using the program from; '''[http://www.mozilla.org/en-US/firefox/all/ Download Firefox For All languages And Systems]''' {web link} </blockquote> I have just tried this but the issue still exists. I have noticed that If i am quick and pressing the login button on reddit and then try and quickly click the box and start typing some junk it will allow a few characters before denying any further entry. I think this may be a javascript issue? When I open the login page the console displays the following: XML Parsing Error: not well-formed Location: https://www.reddit.com/api/vote.json Line Number 1, Column 1: The response from vote.json is simply: { } Could this be something to do with it
FredMcD
  • Top 10 Contributor
4254 oplossingen 59583 antwoorden

It does sound like a script issue.

https://support.mozilla.org/kb/Clear+Recent+History#w_how-do-i-remove-a-single-website-from-my-history

Remove History For One Site

Open the History Manager <Control><Shift> H. In the search bar, enter the name of the site. Right-click on one of the listings and select Forget About This Site. This should remove all information, including any passwords / settings.

It does sound like a script issue. https://support.mozilla.org/kb/Clear+Recent+History#w_how-do-i-remove-a-single-website-from-my-history Remove History For One Site Open the History Manager '''<Control><Shift> H.''' In the search bar, enter the name of the site. Right-click on one of the listings and select '''Forget About This Site.''' This should remove all information, including any passwords / settings.

Vraageigenaar

FredMcD said

It does sound like a script issue. https://support.mozilla.org/kb/Clear+Recent+History#w_how-do-i-remove-a-single-website-from-my-history Remove History For One Site Open the History Manager <Control><Shift> H. In the search bar, enter the name of the site. Right-click on one of the listings and select Forget About This Site. This should remove all information, including any passwords / settings.

This didn't fix the issue. Any other suggestions?

''FredMcD [[#answer-1102734|said]]'' <blockquote> It does sound like a script issue. https://support.mozilla.org/kb/Clear+Recent+History#w_how-do-i-remove-a-single-website-from-my-history Remove History For One Site Open the History Manager '''<Control><Shift> H.''' In the search bar, enter the name of the site. Right-click on one of the listings and select '''Forget About This Site.''' This should remove all information, including any passwords / settings. </blockquote> This didn't fix the issue. Any other suggestions?
FredMcD
  • Top 10 Contributor
4254 oplossingen 59583 antwoorden

I called for more help.

I called for more help.
guigs 1072 oplossingen 11697 antwoorden

Hi, I see you disabled hardware acceleration in Firefox, but when you submitted your question, webgl was already disabled.

Are your graphics drivers up to date? Upgrade your graphics drivers to use hardware acceleration and WebGL

Also the gnome extension requires an extra package in linux, 'chrome-gnome-shell', but you had it disabled, so I am not sure if that would affect the menus in Firefox. (I am thinking it is your graphics drivers since the right click menu does not come up either)

Do you have a password manager or antivirus installs that controls form fills?

Hi, I see you disabled hardware acceleration in Firefox, but when you submitted your question, webgl was already disabled. Are your graphics drivers up to date? [[Upgrade your graphics drivers to use hardware acceleration and WebGL]] Also the gnome extension requires an extra package in linux, 'chrome-gnome-shell', but you had it disabled, so I am not sure if that would affect the menus in Firefox. (I am thinking it is your graphics drivers since the right click menu does not come up either) Do you have a password manager or antivirus installs that controls form fills?
cor-el
  • Top 10 Contributor
  • Moderator
17522 oplossingen 158436 antwoorden

What element gets selected in the Inspector when you right-click in the password field and use Inspect Element?

You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected.

What element gets selected in the Inspector when you right-click in the password field and use Inspect Element? You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected. *https://developer.mozilla.org/en/Tools/Page_Inspector

Vraageigenaar

cor-el said

What element gets selected in the Inspector when you right-click in the password field and use Inspect Element? You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected.

When I right click the box, no menu comes up so there is no Inspect Element option. However, it is correctly identifying elements before and after the element. So I would assume that if I could inspect element on it that it would work.

''cor-el [[#answer-1103496|said]]'' <blockquote> What element gets selected in the Inspector when you right-click in the password field and use Inspect Element? You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected. *https://developer.mozilla.org/en/Tools/Page_Inspector </blockquote> When I right click the box, no menu comes up so there is no Inspect Element option. However, it is correctly identifying elements before and after the element. So I would assume that if I could inspect element on it that it would work.

Vraageigenaar

guigs said

Hi, I see you disabled hardware acceleration in Firefox, but when you submitted your question, webgl was already disabled. Are your graphics drivers up to date? Upgrade your graphics drivers to use hardware acceleration and WebGL Also the gnome extension requires an extra package in linux, 'chrome-gnome-shell', but you had it disabled, so I am not sure if that would affect the menus in Firefox. (I am thinking it is your graphics drivers since the right click menu does not come up either) Do you have a password manager or antivirus installs that controls form fills?

Graphics drivers are all up to date and hardware acceleration on/off made no difference.

name of display: :0 display: :0 screen: 0 direct rendering: Yes Extended renderer info (GLX_MESA_query_renderer):

   Vendor: X.Org (0x1002)
   Device: AMD HAWAII (DRM 2.50.0, 4.15.0-15-generic, LLVM 6.0.0) (0x67b1)
   Version: 18.1.0
   Accelerated: yes
   Video memory: 8192MB
   Unified memory: no
   Preferred profile: core (0x1)
   Max core profile version: 4.5
   Max compat profile version: 3.1
   Max GLES1 profile version: 1.1
   Max GLES[23] profile version: 3.1

Memory info (GL_ATI_meminfo):

   VBO free memory - total: 8191 MB, largest block: 8191 MB
   VBO free aux. memory - total: 2043 MB, largest block: 2043 MB
   Texture free memory - total: 8191 MB, largest block: 8191 MB
   Texture free aux. memory - total: 2043 MB, largest block: 2043 MB
   Renderbuffer free memory - total: 8191 MB, largest block: 8191 MB
   Renderbuffer free aux. memory - total: 2043 MB, largest block: 2043 MB

Memory info (GL_NVX_gpu_memory_info):

   Dedicated video memory: 8192 MB
   Total available memory: 10235 MB
   Currently available dedicated video memory: 8191 MB

OpenGL vendor string: X.Org OpenGL renderer string: AMD HAWAII (DRM 2.50.0, 4.15.0-15-generic, LLVM 6.0.0) OpenGL core profile version string: 4.5 (Core Profile) Mesa 18.1.0-devel OpenGL core profile shading language version string: 4.50 OpenGL core profile context flags: (none) OpenGL core profile profile mask: core profile

OpenGL version string: 3.1 Mesa 18.1.0-devel OpenGL shading language version string: 1.40 OpenGL context flags: (none)

OpenGL ES profile version string: OpenGL ES 3.1 Mesa 18.1.0-devel OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.10

''guigs [[#answer-1102927|said]]'' <blockquote> Hi, I see you disabled hardware acceleration in Firefox, but when you submitted your question, webgl was already disabled. Are your graphics drivers up to date? [[Upgrade your graphics drivers to use hardware acceleration and WebGL]] Also the gnome extension requires an extra package in linux, 'chrome-gnome-shell', but you had it disabled, so I am not sure if that would affect the menus in Firefox. (I am thinking it is your graphics drivers since the right click menu does not come up either) Do you have a password manager or antivirus installs that controls form fills? </blockquote> Graphics drivers are all up to date and hardware acceleration on/off made no difference. ''name of display: :0 display: :0 screen: 0 direct rendering: Yes Extended renderer info (GLX_MESA_query_renderer): Vendor: X.Org (0x1002) Device: AMD HAWAII (DRM 2.50.0, 4.15.0-15-generic, LLVM 6.0.0) (0x67b1) Version: 18.1.0 Accelerated: yes Video memory: 8192MB Unified memory: no Preferred profile: core (0x1) Max core profile version: 4.5 Max compat profile version: 3.1 Max GLES1 profile version: 1.1 Max GLES[23] profile version: 3.1 Memory info (GL_ATI_meminfo): VBO free memory - total: 8191 MB, largest block: 8191 MB VBO free aux. memory - total: 2043 MB, largest block: 2043 MB Texture free memory - total: 8191 MB, largest block: 8191 MB Texture free aux. memory - total: 2043 MB, largest block: 2043 MB Renderbuffer free memory - total: 8191 MB, largest block: 8191 MB Renderbuffer free aux. memory - total: 2043 MB, largest block: 2043 MB Memory info (GL_NVX_gpu_memory_info): Dedicated video memory: 8192 MB Total available memory: 10235 MB Currently available dedicated video memory: 8191 MB OpenGL vendor string: X.Org OpenGL renderer string: AMD HAWAII (DRM 2.50.0, 4.15.0-15-generic, LLVM 6.0.0) OpenGL core profile version string: 4.5 (Core Profile) Mesa 18.1.0-devel OpenGL core profile shading language version string: 4.50 OpenGL core profile context flags: (none) OpenGL core profile profile mask: core profile OpenGL version string: 3.1 Mesa 18.1.0-devel OpenGL shading language version string: 1.40 OpenGL context flags: (none) OpenGL ES profile version string: OpenGL ES 3.1 Mesa 18.1.0-devel OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.10 ''

Vraageigenaar

guigs said

Hi, I see you disabled hardware acceleration in Firefox, but when you submitted your question, webgl was already disabled. Are your graphics drivers up to date? Upgrade your graphics drivers to use hardware acceleration and WebGL Also the gnome extension requires an extra package in linux, 'chrome-gnome-shell', but you had it disabled, so I am not sure if that would affect the menus in Firefox. (I am thinking it is your graphics drivers since the right click menu does not come up either) Do you have a password manager or antivirus installs that controls form fills?

I have keepassx but that isnt open when using firefox and I dont use it to auto fill.

I have noticed that when rightclick/leftclick spamming the box it will freeze a little and takes a few seconds to respond to further clicks. (for example, I spam right/left click the password box and then right click the username box and it will take a few seconds to select the username box so it seems to be crashing or something behind the scenes?)

''guigs [[#answer-1102927|said]]'' <blockquote> Hi, I see you disabled hardware acceleration in Firefox, but when you submitted your question, webgl was already disabled. Are your graphics drivers up to date? [[Upgrade your graphics drivers to use hardware acceleration and WebGL]] Also the gnome extension requires an extra package in linux, 'chrome-gnome-shell', but you had it disabled, so I am not sure if that would affect the menus in Firefox. (I am thinking it is your graphics drivers since the right click menu does not come up either) Do you have a password manager or antivirus installs that controls form fills? </blockquote> I have keepassx but that isnt open when using firefox and I dont use it to auto fill. I have noticed that when rightclick/leftclick spamming the box it will freeze a little and takes a few seconds to respond to further clicks. (for example, I spam right/left click the password box and then right click the username box and it will take a few seconds to select the username box so it seems to be crashing or something behind the scenes?)

Gekozen oplossing

Just to add an update. I have since installed the snap version of firefox on ubuntu and the issue is gone.

Thanks for your help.

Just to add an update. I have since installed the snap version of firefox on ubuntu and the issue is gone. Thanks for your help.
Ernesto94 0 oplossingen 4 antwoorden

Hi, I'm experiencing the same problem. Could you explain how you solved it? Thank you very much.

Hi, I'm experiencing the same problem. Could you explain how you solved it? Thank you very much.

Vraageigenaar

Ernesto94 said

Hi, I'm experiencing the same problem. Could you explain how you solved it? Thank you very much.

open terminal with ctrl + alt + T and type

sudo snap install firefox

This will install a second version of firefox which works.

''Ernesto94 [[#answer-1105519|said]]'' <blockquote> Hi, I'm experiencing the same problem. Could you explain how you solved it? Thank you very much. </blockquote> open terminal with ctrl + alt + T and type sudo snap install firefox This will install a second version of firefox which works.
Ernesto94 0 oplossingen 4 antwoorden

Hi. Thanks! Should I remove the first version first?

Hi. Thanks! Should I remove the first version first?