Zoeken in Support

Vermijd ondersteuningsscams. We zullen u nooit vragen een telefoonnummer te bellen, er een sms naar te sturen of persoonlijke gegevens te delen. Meld verdachte activiteit met de optie ‘Misbruik melden’.

Learn More

Deze conversatie is gearchiveerd. Stel een nieuwe vraag als u hulp nodig hebt.

Firefox Sucking Up LOTS of RAM

  • 9 antwoorden
  • 5 hebben dit probleem
  • 3 weergaven
  • Laatste antwoord van QuiGonJohn

more options

This is to continue my discussion in the now archived thread below:

https://support.mozilla.org/en-US/questions/1158358

I often find Firefox sucking up all/most of my RAM. My computer slows to a crawl overall. I have to close Firefox, then the computer starts working right again. Most recently, a few minutes ago, I found 4 instances of Firefox running in my Task Manager, even though I only had 1 web page tab open. The 4 processes totaled over 2.5GB of RAM.

Can't the techs do something about this? Or at least add a new way to CAP how much RAM Firefox will use. For example, I would go with 1GB. My PC is a Lenovo Tower, Windows 7 Home Premium, with 4GB of RAM.

Alle antwoorden (9)

more options

Hello,

The Refresh feature (called "Reset" in older Firefox versions) can fix many issues by restoring Firefox to its factory default state while saving your bookmarks, history, passwords, cookies, and other essential information.

Note: When you use this feature, you will lose any extensions, toolbar customizations, and some preferences. See the Refresh Firefox - reset add-ons and settings article for more information.

To Refresh Firefox:

  1. Open the Troubleshooting Information page using one of these methods:
    • Click the menu button New Fx Menu, click help Help-29 and select Troubleshooting Information. A new tab containing your troubleshooting information should open.
    • If you're unable to access the Help menu, type about:support in your address bar to bring up the Troubleshooting Information page.
  2. At the top right corner of the page, you should see a button that says "Refresh Firefox" ("Reset Firefox" in older Firefox versions). Click on it.
  3. Firefox will close. After the refresh process is completed, Firefox will show a window with the information that is imported.
  4. Click Finish and Firefox will reopen.

Did this fix the problem? Please report back to us!

Thank you.

more options

Will the reset wipe out minor things like new tabs blank, stop bugging me every time Flash is even 1 update behind, etc.

more options

Reset will save your profile and that's it.

Flash has nothing to do with Firefox in it's updating. You should never be behind updating as each update is critical and or to fix a catastrophic hacking event that is ongoing. There was 1 update last month and a emergency update. Never be behind. Flash Player Version: 27.0.0.183 Current Version https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) Note: Other software is offered in the download. <Windows Only>

Something else that has not been updated as drivers are from : 8-4-2015 This could be a reason or a partial reason of your issue.

https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration TRY NO HARDWARE ACCELERATION.

See if Multi-Processor Support is turned on. Multi-processor support feature may be disabled depending on your setup (it was for me) - you can check this by launching Firefox, then enter in "about:support" in the address bar; near the bottom, you should see a heading that says: "Multiprocess Windows", then look at the value next to it. If it says "0/1", then that means it's disabled. 0/2 or higher it is turned on/and or will say it is turned on and you will have to reverse the instructions for turning it on. http://www.ghacks.net/2016/07/22/multi-process-firefox/

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. Copy/paste the names below into the search bar in about:config. set dom.ipc.processCount to 1 if it is currently set to a higher value (4) disable multi-process windows in Firefox

You can disable multi-process windows in Firefox by setting these prefs to false on the about:config page. (SET BELOW TO FALSE)

browser.tabs.remote.autostart = false browser.tabs.remote.autostart.2 = false

Note : Firefox 56.0.2 is current release https://www.mozilla.org/firefox/all/ Full Version Installer Note : Firefox 57 Quantum release date Nov 14th https://www.mozilla.org/en-US/firefox/quantum/ Note : Legacy Extensions will be disabled and or removed.

Thank You for turning on send info to Mozilla before posting a question. This helps us help you.

Please let us know if this solved your issue or if need further assistance.

Bewerkt door Shadow110 op

more options

Instead of doing a reset you can also use the Profile Manager to create a new profile for testing. That way you do not need to redo all customization you made.

You can create a new profile to test if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

more options

PKSHADOW - I have 56.0.2. It sounds like you are saying I should try Hardware Acceleration Off and Turn Off Multi-Processor Support. Then see how that does. When I go to OPTION - GENERAL - PERFORMANCE I only have one check box for USE RECOMMENDED PERFORMANCE SETTINGS. No option below that for USE HARDWARE ACCELERATION.

Processor is Intel Pentium CPU G3220 3.0Ghz

more options

QuiGonJohn said

PKSHADOW - I have 56.0.2. It sounds like you are saying I should try Hardware Acceleration Off and Turn Off Multi-Processor Support. Then see how that does. When I go to OPTION - GENERAL - PERFORMANCE I only have one check box for USE RECOMMENDED PERFORMANCE SETTINGS. No option below that for USE HARDWARE ACCELERATION.

You couldn't possibly know this, unless you clicked on 'Learn More' or unchecked 'Use recommended performance settings'.

Give it a try and you'll see what happens .......

more options

Learn More did not show it. But I did uncheck "Use Rec..." and then it showed up. Did not realize I had to uncheck that first, thought it would just appear with all the applicable lines showing.

more options

QuiGonJohn said

Learn More did not show it. But I did uncheck "Use Rec..." and then it showed up.

When you ckick on more, you'll see this article :

https://support.mozilla.org/en-US/kb/performance-settings?as=u&utm_source=inproduct

And then when you scroll down, you'll see it. But again : how is one to know, eh  ?

Point is, though : Does toggling hardware acceleration off and on make any difference for you  ?

more options

Since turning off Hardware Acceleration, it has not bogged down my computer as often, still once or twice in past week. I notice now FF runs with only 1 open occurrence in Task Manager.