Zoeken in Support

Vermijd ondersteuningsscams. We zullen u nooit vragen een telefoonnummer te bellen, er een sms naar te sturen of persoonlijke gegevens te delen. Meld verdachte activiteit met de optie ‘Misbruik melden’.

Learn More

Deze conversatie is gearchiveerd. Stel een nieuwe vraag als u hulp nodig hebt.

Firefox Nightly 57 is misreporting useragent.

more options

I'm currently browsing with Firefox Nightly 57.0a1 (2017-08-09) (64-bit), on Windows 8.1 (64-bit), but Firefox is reporting my useragent to be Firefox 50.0, on Windows 7, even on the automatically detected troubleshooting information for this question.

At first I made sure that none of my extensions were changing my useragent, all useragent-changing behaviour was disabled, and I checked my useragent in Safe Mode, yet it still misreported the useragent. I read through previous support threads, and the wiki, both of which instructed me to check "general.useragent.override" in about:config, however it was not present, and there were no other values that could seemingly cause this misbehaviour.

Is there any solution to this issue, or has my profile become corrupted in some manner? Thanks in advance for any help.

I was having some trouble uploading these screenshots to the the question directly, so here are some external links. Misreported useragent: https://vgy.me/waciIX.png

Gekozen oplossing

After following the "To fix the problem in the original profile" instructions detailed in cor-el's second link, I found the problematic file to be prefs.js.

Creating a new profile would have solved the problem, but it's not an ideal solution. So I looked through every about:config value that I had modified and reset any that could possibly affect the useragent. I reset both

  • browser.migration.version
  • extensions.acr.previousApplicationVersion

but it made no difference.

Then I reset

  • privacy.resistFingerprinting

from true to false. And it worked! My useragent was correct.

Although I'm not sure if this is the intended behaviour for "privacy.resistFingerprinting", surely the most common useragent of Firefox users would be the latest version of the Stable branch on Windows 10? Especially when the current behaviour prevents you from using AMO properly.

TL;DR: Set "privacy.resistFingerprinting" in about:config to false. Or delete prefs.js

Dit antwoord in context lezen 👍 5

Alle antwoorden (9)

more options

Hi

Can you just quickly check to see what is reported when you use this site?

If you copy what is report next to "rawUa" (the first item on the list) and paste into a reply to this thread it would be handy.

more options

Could you check this article: How to reset the default user agent on Firefox.

more options

This is what rawUa reported:

  • rawUa: Mozilla/5.0 (Windows NT 6.1; rv:50.0) Gecko/20100101 Firefox/50.0

As for the "How to reset the default user agent on Firefox." article, I had already read it before posting the question and it did not work, but thank you for the help anyway.

more options

Since you already tested in Firefox's Safe Mode and checked the useragent preferences:

Do you browse through any intermediaries such as a proxy server, security software filter, or private VPN that might be modifying the user agent string sent to websites?

You can check Firefox's connection setting here:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences

In the left column, click Advanced. Then on the right side, with the "Network" mini-tab active, click the "Settings" button. The default of "Use system proxy settings" piggybacks on your Windows/IE "LAN" setting. "Auto-detect" can lead to a flaky connection. You may want to try "No proxy".

For external software or services, you probably have a better idea of what you're running than we do...

more options

My Firefox network settings were already on "No proxy", I occasionally browse via a private VPN with the OpenVPN client, however it does not modify my useragent.

more options

You can create a new profile to test if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

more options

Gekozen oplossing

After following the "To fix the problem in the original profile" instructions detailed in cor-el's second link, I found the problematic file to be prefs.js.

Creating a new profile would have solved the problem, but it's not an ideal solution. So I looked through every about:config value that I had modified and reset any that could possibly affect the useragent. I reset both

  • browser.migration.version
  • extensions.acr.previousApplicationVersion

but it made no difference.

Then I reset

  • privacy.resistFingerprinting

from true to false. And it worked! My useragent was correct.

Although I'm not sure if this is the intended behaviour for "privacy.resistFingerprinting", surely the most common useragent of Firefox users would be the latest version of the Stable branch on Windows 10? Especially when the current behaviour prevents you from using AMO properly.

TL;DR: Set "privacy.resistFingerprinting" in about:config to false. Or delete prefs.js

more options
more options

Thank you for reporting back on this.

"Barely Harry" said

Then I reset
  • privacy.resistFingerprinting
from true to false. And it worked! My useragent was correct.

First, you can reset that preference using about:config in the usual way and Firefox should then update prefs.js:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste fing and pause while the list is filtered

(3) If the privacy.resistFingerprinting preference is bolded and "modified" to true, double-click it to restore the default value of false

Second, this should be added to the article about resetting your user agent or websites thinking you have an out of date Firefox.

Third, it would be useful to create an article on what this preference does. It may be that it's not really intended to be turned on yet and the documentation will come after it's better tested?

Bewerkt door jscher2000 - Support Volunteer op