X
Tik hier voor de mobiele versie van de website.

Ondersteuningsforum

Deze conversatie is gearchiveerd. Stel een nieuwe vraag als u hulp nodig hebt.

Firefox 49 won't start after installation

Geplaatst

OS : Windows 7 x64 I was using Firefox 48.0.2 (x64) - french version. I manually downloaded and installed Firefox 49.0 (x64). After installation, Firefox does not start : - the firefox.exe process is running, using something between 5000 and 65000 Mb of memory - nothing else happens : the process does nothing, using 0% CPU

I've seen this issue : - on several PC's of my organization - after automatic update or manual update - after having deleted my Firefox profile - after having disabled Kasperky Antivirus

I've noticed that the last version of Firefox Developer Edition has the same behaviour : install OK, won't start.

Going back to previous version is OK : Firefox starts again.

OS : Windows 7 x64 I was using Firefox 48.0.2 (x64) - french version. I manually downloaded and installed Firefox 49.0 (x64). After installation, Firefox does not start : - the firefox.exe process is running, using something between 5000 and 65000 Mb of memory - nothing else happens : the process does nothing, using 0% CPU I've seen this issue : - on several PC's of my organization - after automatic update or manual update - after having deleted my Firefox profile - after having disabled Kasperky Antivirus I've noticed that the last version of Firefox Developer Edition has the same behaviour : install OK, won't start. Going back to previous version is OK : Firefox starts again.

Aanvullende systeemdetails

Geïnstalleerde plug-ins

  • Shockwave Flash 23.0 r0

Toepassing

  • Firefox 48.0.2
  • Useragent: Mozilla/5.0 (Windows NT 6.0; Win64; x64; rv:48.0) Gecko/20100101 Firefox/48.0
  • Ondersteunings-URL: https://support.mozilla.org/1/firefox/48.0.2/WINNT/fr/

Extensies

  • BehindTheOverlay 0.1.1.1-signed.1-signed (jid1-Y3WfE7td45aWDw@jetpack)
  • Firefox Hello Beta 1.4.4 (loop@mozilla.org)
  • Firefox Hotfix 20160826.01 (firefox-hotfix@mozilla.org)
  • I don't care about cookies 2.6.0 (jid1-KKzOGWgsW3Ao4Q@jetpack)
  • LeechBlock 1.0.5 ({a95d8332-e4b4-6e7f-98ac-20b733364387})
  • MeasureIt 0.4.15 ({75CEEE46-9B64-46f8-94BF-54012DE155F0})
  • Multi-process staged rollout 1.2 (e10srollout@mozilla.org)
  • Pocket 1.0.4 (firefox@getpocket.com)
  • Priv8 0.1.1 (id@baku.priv8)
  • Stop AutoPlay Next for YouTube™ 0.1.2.1 (jid1-nbzaq9ol2hyY64gGe@jetpack)
  • uBlock Origin 1.9.6 (uBlock0@raymondhill.net)

Javascript

  • incrementalGCEnabled: True

Grafisch

  • adapterDescription: Intel(R) HD Graphics 4600
  • adapterDescription2:
  • adapterDeviceID: 0x0412
  • adapterDeviceID2:
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 06121028
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.17568
  • driverDate: 3-16-2015
  • driverDate2:
  • driverVersion: 10.18.14.4170
  • driverVersion2:
  • info: {u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: Yes; Using D3D9 API
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 4600 Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Aangepaste voorkeuren

Div

  • User JS: nee
  • Toegankelijkheid: nee
S3ndG 1 oplossingen 16 antwoorden

Maybe you have old SSE processors... Firefox 49 needs SSE2 processors (pentium 4+). Otherwise try to remove the "Firefox Hotfix " extension :)

Maybe you have old SSE processors... Firefox 49 needs SSE2 processors (pentium 4+). Otherwise try to remove the "Firefox Hotfix " extension :)

Vraageigenaar

Thanks S3ndG,

My CPU is an Intel Core i5-4590@3.30Ghz so I don't think it's related.

I've uninstalled Firefox Hotfix and retried installing FF49 : same issue.

Thanks S3ndG, My CPU is an Intel Core i5-4590@3.30Ghz so I don't think it's related. I've uninstalled Firefox Hotfix and retried installing FF49 : same issue.

Nuttig antwoord

There is an error in "Question details" : the OS is not Vista but Windows 7.

There is an error in "Question details" : the OS is not Vista but Windows 7.
philipp
  • Top 25 Contributor
  • Moderator
5304 oplossingen 23419 antwoorden

well, maybe that is part of the problem. please right-click your firefox desktop icon, click on properties and then go to compatibility tab - in there disable all compatibility options and try to update again...

well, maybe that is part of the problem. please right-click your firefox desktop icon, click on properties and then go to compatibility tab - in there disable all compatibility options and try to update again...

Vraageigenaar

OK, I made an mistake : I checked this option in the shortcut to try if this could solve the problem...

I forgot to uncheck it before writing this post and retrieving data from the browser to populate the "Question details".

Unfortunately, the same issue happens with this option unchecked in the shortcut.

Sorry for this ...

OK, I made an mistake : I checked this option in the shortcut to try if this could solve the problem... I forgot to uncheck it before writing this post and retrieving data from the browser to populate the "Question details". Unfortunately, the same issue happens with this option unchecked in the shortcut. Sorry for this ...

Bewerkt door assistance-multi op

philipp
  • Top 25 Contributor
  • Moderator
5304 oplossingen 23419 antwoorden

is it the same with 32bit versions of the browser?

is it the same with 32bit versions of the browser?

Vraageigenaar

I'll check that tomorrow and keep you in touch.

I'll check that tomorrow and keep you in touch.

Vraageigenaar

Hi, the problem is the same with the 32bit version.

Hi, the problem is the same with the 32bit version.
philipp
  • Top 25 Contributor
  • Moderator
5304 oplossingen 23419 antwoorden

thanks, this is just a guess but does it make a difference when you install https://www.microsoft.com/download/details.aspx?id=48145 ?

thanks, this is just a guess but does it make a difference when you install https://www.microsoft.com/download/details.aspx?id=48145 ?

Vraageigenaar

Hi Philipp,

The "Visual C++ Redistributable for Visual Studio 2015" (x86 et x64) were already installed.

I have chosen the "Repair" option during installation, but it did not change anything.

Hi Philipp, The "Visual C++ Redistributable for Visual Studio 2015" (x86 et x64) were already installed. I have chosen the "Repair" option during installation, but it did not change anything.

Vraageigenaar

I have no idea if it can be usefull, but I have done the following steps :

- started Firefox (nothings happens) - run "procdump.exe firefox.exe" (procdump from https://technet.microsoft.com/en-us/sysinternals/dd996900.aspx) - used DebugDiag (from Microsoft too) to produce a report based on the dmp file

You can find the DebugDiag file here : CrashHangAnalysis

(available until 09/29/2016)

I have no idea if it can be usefull, but I have done the following steps : - started Firefox (nothings happens) - run "procdump.exe firefox.exe" (procdump from https://technet.microsoft.com/en-us/sysinternals/dd996900.aspx) - used DebugDiag (from Microsoft too) to produce a report based on the dmp file You can find the DebugDiag file here : [https://www.wetransfer.com/downloads/87120c4e68d5da8c8c633b9600040dd820160922151424/779f1e1aec8a44bed3679b2ee8255cff20160922151424/15a6a6 CrashHangAnalysis] (available until 09/29/2016)
FredMcD
  • Top 10 Contributor
4245 oplossingen 59390 antwoorden

You may have corrupt xulstore.json or Localstore.rdf file.

Close Firefox. Open your file browser to this hidden location:

  • Mac: *~/Library/Application Support/Firefox/
  • Linux: *~/.mozilla/firefox/
  • Windows: %AppData%\Mozilla\Firefox\
  • *C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\

Locate the above files. Then rename or delete them. Restart Firefox.

You may have corrupt '''xulstore.json''' or '''Localstore.rdf''' file. '''Close Firefox'''. Open your file browser to this hidden location: * Mac: *~/Library/Application Support/Firefox/ * Linux: *~/.mozilla/firefox/ * Windows: %AppData%\Mozilla\Firefox\ * *C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\ Locate the above files. Then rename or delete them. Restart Firefox.

Vraageigenaar

Hi FredMcD,

I have tried to rename those files.

FF49 still does not start.

Hi FredMcD, I have tried to rename those files. FF49 still does not start.
FredMcD
  • Top 10 Contributor
4245 oplossingen 59390 antwoorden

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh).

Is the problem still there?

Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac=Options)'' ''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?
1scotch 0 oplossingen 18 antwoorden

i think i'll wait 'til this is resolved before downloading.

i think i'll wait 'til this is resolved before downloading.
kevinherrmann 0 oplossingen 9 antwoorden

This problem also affects the 64-bit English UK version of Firefox 49 running on Windows 7 SP1 64-bit. On my computer, Firefox runs or hangs apparently at random with about 50% each, whether started by clicking the short cut or through a link. Two processes are left running showing no window and have to be terminated with Task Manager.

One other symptom I noticed was that the Html Validator add-on fails with a message about a library missing. However, the underlying Firefox propblem still occurs when this is disabled, so it is not the cause of the problem, it appears to be a victim of the Firefox problem.

As another poster has found, simply re-installing 48.0.2 back over the top of 49 fixes the hang on start up and, in my case, also restores Html Validator to working.

This problem also affects the 64-bit English UK version of Firefox 49 running on Windows 7 SP1 64-bit. On my computer, Firefox runs or hangs apparently at random with about 50% each, whether started by clicking the short cut or through a link. Two processes are left running showing no window and have to be terminated with Task Manager. One other symptom I noticed was that the Html Validator add-on fails with a message about a library missing. However, the underlying Firefox propblem still occurs when this is disabled, so it is not the cause of the problem, it appears to be a victim of the Firefox problem. As another poster has found, simply re-installing 48.0.2 back over the top of 49 fixes the hang on start up and, in my case, also restores Html Validator to working.

Bewerkt door kevinherrmann op

FredMcD
  • Top 10 Contributor
4245 oplossingen 59390 antwoorden

Start your Computer in safe mode with networking. Then start Firefox. Try Safe websites. Is the problem still there?

Starting The Computer In Safe Mode;
Free Online Encyclopedia

Start your '''Computer''' in safe mode with networking. Then start Firefox. Try '''Safe''' websites. Is the problem still there? '''[http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting The Computer In Safe Mode;<br>Free Online Encyclopedia]'''
kevinherrmann 0 oplossingen 9 antwoorden

As the other poster reported, all the usual troubleshooting does not fix it, only replacing the buggy software with the previous version. I also checked the C++ library and it is OK, but maybe Firefox 49 isn't accessing it correctly and is also making it inaccessible to add-ons somehow?

As I pointed out, Firefox 49 wouldn't even start clicking the program shortcut around half the time, so the safety of website isn't relevant, you never get the program open let alone to a website.

As the other poster reported, all the usual troubleshooting does not fix it, only replacing the buggy software with the previous version. I also checked the C++ library and it is OK, but maybe Firefox 49 isn't accessing it correctly and is also making it inaccessible to add-ons somehow? As I pointed out, Firefox 49 wouldn't even start clicking the program shortcut around half the time, so the safety of website isn't relevant, you never get the program open let alone to a website.

Vraageigenaar

Hi, I did not have enough time to try the safe mode of Windows, but I noticed that Mozilla has launched a 49.0.1 version of Firefox.

The problem still occurs with this new version.

I'll try the safe mode as soon as possible.

Hi, I did not have enough time to try the safe mode of Windows, but I noticed that Mozilla has launched a 49.0.1 version of Firefox. The problem still occurs with this new version. I'll try the safe mode as soon as possible.
philipp
  • Top 25 Contributor
  • Moderator
5304 oplossingen 23419 antwoorden

i have seen one or two similar reports by other users after the update. at the moment i think that looking for similarities of the affected systems is the most promising way to find a workaround/solution for this issue... could you do one of the methods at http://www.ghacks.net/2014/02/06/create-list-installed-windows-software/ to produce a list of all installed programs on the system and paste that into a reply here in the forum...?

i have seen one or two similar reports by other users after the update. at the moment i think that looking for similarities of the affected systems is the most promising way to find a workaround/solution for this issue... could you do one of the methods at http://www.ghacks.net/2014/02/06/create-list-installed-windows-software/ to produce a list of all installed programs on the system and paste that into a reply here in the forum...?