Zoeken in Support

Vermijd ondersteuningsscams. We zullen u nooit vragen een telefoonnummer te bellen, er een sms naar te sturen of persoonlijke gegevens te delen. Meld verdachte activiteit met de optie ‘Misbruik melden’.

Learn More

Deze conversatie is gearchiveerd. Stel een nieuwe vraag als u hulp nodig hebt.

Firefox runs in the background but does not open a window

  • 5 antwoorden
  • 3 hebben dit probleem
  • 16683 weergaven
  • Laatste antwoord van FredMcD

more options

In general, Firefox was running very poorly, freezing up at times while loading sites. I once ran RogueKiller and it detected a rootkit affecting Firefox. Following this I decided to reset Firefox. I was also prompted to update Firefox to the latest version, which I also did. After this, Firefox does not open a window upon starting the program. It will show that it is opening on the task bar (I have Windows 7) and then after about 15 seconds the icon appears as if it is not open. Upon checking in Windows Task Manager, it shows that FF is running, albeit in the background. I have tried various anti-virus/malware scanners (Spybot, AVG, Sophos Virus Removal Tool, Malwarebytes, SuperAntiSpyware) and other scanners (TDSS Killer, CCleaner, AdWCleaner) but nothing malicious is detected (even in safe mode). I suspect some kind of deeper infection which is evading all these attempts. FYI Internet Explorer is also affected by the same problem. Thank you so much for any kind of help.

Gekozen oplossing

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh).

Is the problem still there?

Dit antwoord in context lezen 👍 0

Alle antwoorden (5)

more options

You may have corrupt xulstore.json or Localstore.rdf file.

Close Firefox. Open your file browser to this hidden location:

  • Mac: *~/Library/Application Support/Firefox/
  • Linux: *~/.mozilla/firefox/
  • Windows: %AppData%\Mozilla\Firefox\
  • *C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\

Locate the above files. Then rename or delete them. Restart Firefox.

more options

Thank you Fred for your response. I had already deleted the xulstore.json file and that didn't work. The Localstore.rdf file was nowhere to be found. What could be the problem then?

Bewerkt door kompozitori op

more options

Gekozen oplossing

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh).

Is the problem still there?

more options

I tried this two times at first and it didn't work. On the third time a box came up asking which profile I wanted to use so I selected one and FF opened up. I closed the program and tried a fourth time to verify the successful attempt and it was able to start in safe mode. The program was also able to successfully open in regular mode as well following this. I'm hoping this was all that was needed. Thank you for your help!

more options

Glad to help. Safe Surfing.

If the problem should return, Please go to the top of any support.mozilla.org web page and use the Ask A Question link; https://support.mozilla.org/en-US/questions/new This will let us look at your system details. No Personal Information Is Collected.