Zoeken in Support

Vermijd ondersteuningsscams. We zullen u nooit vragen een telefoonnummer te bellen, er een sms naar te sturen of persoonlijke gegevens te delen. Meld verdachte activiteit met de optie ‘Misbruik melden’.

Learn More

Deze conversatie is gearchiveerd. Stel een nieuwe vraag als u hulp nodig hebt.

"Allow {website} to run 'Adobe Flash'?" constantly appears and disappears.

  • 3 antwoorden
  • 1 heeft dit probleem
  • 434 weergaven
  • Laatste antwoord van jscher2000

more options

When Shockwave Flash addon is set to "Ask to Activate", a bar appears at the top of the webpage when the page requests Flash. This bar contains the words "Allow {website} to run 'Adobe Flash'?" and has "Continue Blocking" and "Allow" buttons.

This is great. Flash is prevented from running.

However, with some websites, particularly those with lots of advertisements (eg. some news sites, etc.) this bar constantly opens and closes. It seems perhaps that some websites keep repeatedly requesting Flash, or request it, then release the request and request it again. Either way, it's got Firefox constantly adding and removing this bar.

Having the bar appear/disappear every second or so is very distracting. This issue makes the "Ask to Activate" feature relatively useless. Perhaps the mechanism used to ask the user regarding the activation of Flash (or other addons) needs to be updated or revisited to prevent this behavior?

Gekozen oplossing

Normally the bar wouldn't disappear by itself. Perhaps what is happening is that those ads use a script to determine whether the media played, and if it didn't start quickly enough, it tries a different one??

I must confess that my customizations may have shielded me from this problem:

(1) I use the NoScript extension to block unimportant scripts in pages, so that may be removing lots of annoying advertising.

NoScript isn't for everyone because it requires so much training; there are much more direct ways to block advertising. However, I need it for security reasons when investigating questionable websites.

(2) For a while I've been completely hiding the bar using a custom style rule. I use the plugin notification icon on the address bar when I want to activate Flash (or should I say, when something I expect to play isn't playing).

This is the rule, in case you are interested. I apply it to Firefox using the Stylish extension:

@namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul); /* Hide Plugin Notification Infobar */ notification[value="plugin-hidden"]{ display:none !important; }

You can get various other recommendations for workarounds, but I just don't know if there is a real fix.

Dit antwoord in context lezen 👍 1

Alle antwoorden (3)

more options

Gekozen oplossing

Normally the bar wouldn't disappear by itself. Perhaps what is happening is that those ads use a script to determine whether the media played, and if it didn't start quickly enough, it tries a different one??

I must confess that my customizations may have shielded me from this problem:

(1) I use the NoScript extension to block unimportant scripts in pages, so that may be removing lots of annoying advertising.

NoScript isn't for everyone because it requires so much training; there are much more direct ways to block advertising. However, I need it for security reasons when investigating questionable websites.

(2) For a while I've been completely hiding the bar using a custom style rule. I use the plugin notification icon on the address bar when I want to activate Flash (or should I say, when something I expect to play isn't playing).

This is the rule, in case you are interested. I apply it to Firefox using the Stylish extension:

@namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul); /* Hide Plugin Notification Infobar */ notification[value="plugin-hidden"]{ display:none !important; }

You can get various other recommendations for workarounds, but I just don't know if there is a real fix.

more options

Thanks for the information regarding CSS customization jscher2000. It's too bad that one has to disable the feature to work around the problem.

It used to just come on and stay on, and for most websites it still does, but I've been noticing this constant appearing/disappearing behavior now. There's definitely an active element to these pages that is confusing/abusing Firefox.

Since I didn't want to deal with an extension I applied your solution by adding a crome/userChrome.css file to the Firefox profile directory containing the following:

notification[value="plugin-hidden"] {

 display: none !important;

}

For those who don't know, the Firefox profile directory is located at: C:\Users\[username]\AppData\Roaming\Mozilla\Firefox\Profiles\[profile] where [profile] is a random string of letters and numbers.

Perhaps now that this notification is constantly appearing and disappearing on many websites Mozilla will have to address the problem formally!

more options

I'm not a UI designer, and I'm not sure of the best way to make this informative/correct but also less annoying.

You can submit suggested feature changes on this page:

https://input.mozilla.org/feedback/firefox

Or you can file a formal bug report here, but they will ask for steps to reproduce this, so you'll probably need to give the addresses of a couple sites where it happens reliably:

https://bugzilla.mozilla.org/enter_bug.cgi