X
Tik hier voor de mobiele versie van de website.

Ondersteuningsforum

Deze conversatie is gearchiveerd. Stel een nieuwe vraag als u hulp nodig hebt.

How to make Firefox display Chinese characters completely?

Geplaatst

This issue is going on for a few months already. At some point my Firefox lost the ability to display some Chinese characters. This is a big issue for me, because I use Chinese almost daily. They're not rarely used characters either. One examples is (you'll be able to see it, I am not): "问" (Now I see only two quotation marks but I know that there is a character in between them.)

Here are the details of what's going on:

When I enter Chinese characters on most websites (not all of them!), only some of them will be displayed, while others are invisible. Thus when I enter a whole phrase, it's difficult to check whether I made any mistakes. I know the characters are there, because I can move my cursor through the characters and it'll stay at the same place, internally counting that invisible character, when I move over one of those invisibles. Also when I write Chinese text messages, the other person never seems to be missing any characters from my messages. Also when I copy paste them into an editor, they're clearly there and visible.

So what I've tried so far is only the following:

I went to: about:preferences#content and then set a font, which I know can display the characters (WenQuanYi Micro Hei). Also I enabled the checkbox with the label "Allow pages to choose their own fonts, instead of my selections above".

So either almost aaaaall of the websites I am using suddenly removed their own font choices (highly unlikely) and FF can't use the font set by me properly, or there is another issue at work here.

I also tried with another profile, by starting FF using the command line: firefox -P A completely new profile, no addons installed or anything, but still some Chinese characters are missing.

Information about my machine: OS: Xubuntu 14.04 Firefox Version: 44.0.2 (shouldn't really matter as this is going on for a long time now) (Any other information required?)

Example for a website on which FF is displaying Chinese characters correctly: http://www.mdbg.net

This issue is going on for a few months already. At some point my Firefox lost the ability to display some Chinese characters. This is a big issue for me, because I use Chinese almost daily. They're not rarely used characters either. One examples is (you'll be able to see it, I am not): "问" (Now I see only two quotation marks but I know that there is a character in between them.) Here are the details of what's going on: When I enter Chinese characters on most websites (not all of them!), only some of them will be displayed, while others are invisible. Thus when I enter a whole phrase, it's difficult to check whether I made any mistakes. I know the characters are there, because I can move my cursor through the characters and it'll stay at the same place, internally counting that invisible character, when I move over one of those invisibles. Also when I write Chinese text messages, the other person never seems to be missing any characters from my messages. Also when I copy paste them into an editor, they're clearly there and visible. So what I've tried so far is only the following: I went to: about:preferences#content and then set a font, which I know can display the characters (WenQuanYi Micro Hei). Also I enabled the checkbox with the label "Allow pages to choose their own fonts, instead of my selections above". So either almost aaaaall of the websites I am using suddenly removed their own font choices (highly unlikely) and FF can't use the font set by me properly, or there is another issue at work here. I also tried with another profile, by starting FF using the command line: firefox -P A completely new profile, no addons installed or anything, but still some Chinese characters are missing. Information about my machine: OS: Xubuntu 14.04 Firefox Version: 44.0.2 (shouldn't really matter as this is going on for a long time now) (Any other information required?) Example for a website on which FF is displaying Chinese characters correctly: http://www.mdbg.net

Bewerkt door ZelphirKaltstahl op

Aanvullende systeemdetails

Geïnstalleerde plug-ins

  • Next Generation Java Plug-in 11.72.2 for Mozilla browsers
  • Shockwave Flash 13.1 r2
  • Shockwave Flash 11.2 r202

Toepassing

  • Firefox 44.0.2
  • Useragent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:44.0) Gecko/20100101 Firefox/44.0
  • Ondersteunings-URL: https://support.mozilla.org/1/firefox/44.0.2/Linux/en-US/

Extensies

  • Auto Unload Tab 0.8.9.8 ({d3c46ca0-999d-11da-a72b-0800200c9a66})
  • Flash and Video Download 1.79 ({bee6eb20-01e0-ebd1-da83-080329fb9a3a})
  • Flash Video Downloader - YouTube HD Download [4K] 9.1.0 (artur.dubovoy@gmail.com)
  • Loading Bar 0.3.2.1-signed (loadingbar@xertoz.se)
  • Save-To-Read 0.4.2.1-signed (save2read@konstantin.plotnikov)
  • Tab Counter 1.9.9.2 (tabcounter@morac)
  • uBlock 0.9.5.0.1-let-fixed ({2b10c1c8-a11f-4bad-fe9c-1c11e82cac42})
  • uMatrix 0.9.3.2 (uMatrix@raymondhill.net)
  • UnloadTab 0.24.7.1-signed (unloadtab@firefox.ext)
  • ZenMate Security, Privacy & Unblock VPN 5.4.7 (firefox@zenmate.com)
  • DownThemAll! 2.0.18.1-signed.1-let-fixed ({DDC359D1-844A-42a7-9AA1-88A850A938A8}) (Inactief)
  • NoScript 2.9.0.4 ({73a6fe31-595d-460b-a920-fcc0f8843232}) (Inactief)
  • Scriptish 0.1.11.1-signed (scriptish@erikvold.com) (Inactief)
  • Scroll Progress 2.2.0.1-signed (scrollprogress@com.sppad) (Inactief)
  • Site Favicon in Urlbar 47.0.3 (sitefavinurlbar@sonco.com) (Inactief)
  • Stylish 2.0.6 ({46551EC9-40F0-4e47-8E18-8E5CF550CFB8}) (Inactief)
  • uBlock Origin 1.6.2 (uBlock0@raymondhill.net) (Inactief)
  • Ubuntu Modifications 3.2 (ubufox@ubuntu.com) (Inactief)
  • WOT 20151208 ({a0d7ccb3-214d-498b-b4aa-0e8fda9a7bf7}) (Inactief)
  • YouTube Flash Video Player 44.2 ({f3bd3dd2-2888-44c5-91a2-2caeb33fb898}) (Inactief)

Javascript

  • incrementalGCEnabled: True

Grafisch

  • adapterDescription: GLXtest process failed (exited with status 1): GLX extension missing
  • adapterDeviceID:
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID:
  • driverDate:
  • driverVersion:
  • info: {u'CairoUseXRender': 1, u'AzureCanvasBackend': u'cairo', u'AzureFallbackCanvasBackend': u'none', u'AzureSkiaAccelerated': 0, u'AzureContentBackend': u'cairo'}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'tryNewerDriver', u'<Anything with EXT_texture_from_pixmap support>']
  • numTotalWindows: 1
  • supportsHardwareH264: No;
  • webglRendererMessage: [u'blockedGfxCard']
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

Aangepaste voorkeuren

Div

  • User JS: nee
  • Toegankelijkheid: nee

Vraageigenaar

Today I started up my other machine, using another OS (Fedora 22, FCITX, LibPinyin). I don't see the same issue.

So I think the question is: What's wrong with the first system?

Today I started up my other machine, using another OS (Fedora 22, FCITX, LibPinyin). I don't see the same issue. So I think the question is: What's wrong with the first system?

Nuttig antwoord

ZelphirKaltstahl said

Today I started up my other machine, using another OS (Fedora 22, FCITX, LibPinyin). I don't see the same issue. So I think the question is: What's wrong with the first system?

Correction: It's just the opposite situation again, on mdbg.net it doesn't show any characters, but therefore on other websites it does. So I guess on the machine, on which I thought it to be functioning correctly, it's simply that that one config value is set to false again. Checking this now...

Hm that's strange.

Although it is like this:

  • gfx.font_rendering.fontconfig.fontlist.enabled = true

It shows the same behavior as the other system shows, when I set it to false there.

''ZelphirKaltstahl [[#answer-852480|said]]'' <blockquote> Today I started up my other machine, using another OS (Fedora 22, FCITX, LibPinyin). I don't see the same issue. So I think the question is: What's wrong with the first system? </blockquote> Correction: It's just the opposite situation again, on mdbg.net it doesn't show any characters, but therefore on other websites it does. So I guess on the machine, on which I thought it to be functioning correctly, it's simply that that one config value is set to false again. Checking this now... Hm that's strange. Although it is like this: * gfx.font_rendering.fontconfig.fontlist.enabled = true It shows the same behavior as the other system shows, when I set it to false there.