Zoeken in Support

Vermijd ondersteuningsscams. We zullen u nooit vragen een telefoonnummer te bellen, er een sms naar te sturen of persoonlijke gegevens te delen. Meld verdachte activiteit met de optie ‘Misbruik melden’.

Learn More

Deze conversatie is gearchiveerd. Stel een nieuwe vraag als u hulp nodig hebt.

Firefox keeps changing my default search engine to Bing. I've changed it back 20 times already. Enough is enough.

  • 2 antwoorden
  • 34 hebben dit probleem
  • 31709 weergaven
  • Laatste antwoord van the_block

more options

Ever since the deal went down when Firefox changed its default provider from Google, I have had to reset my default search engine back from Bing at least every other day, if not more frequent. It is maddening. It doesn't just happen on one machine either, it's happening on all of mine.

I do have Firefox sync enabled with preference sync, so is it possible Firefox sync is getting out of sync? IE every time I change it on a machine, it misses a browser, and then the browser that doesn't get changed goes out and changes all the rest back in the next sync? That's the only thing I can think of, other than Mozilla selling their souls and values and forcing Firefox users to use a search engine they hate.

If the latter is the case, I have had enough and am switching to Chrome. I can't handle having to change my default search engine back every other day. Please someone tell me there is an explanation and a fix. Thanks.

Gekozen oplossing

Alright, I feel like an idiot. It was from an extension I installed called InvisibleHand that I installed right around the time the Google deal with Mozilla expired, which is why I assumed the problem was a result of that.

I just checked the settings of the extension and sure enough it has an option that gets ticked by default called "InvisibleHand Search (Use InvisibleHand (powered by Bing) as my default search provider)". So I jumped the gun and blamed Firefox, my apologies.

The extension automatically shows you if an item is cheaper elsewhere while online shopping which is useful, however having that setting ticked by default is pretty skeevy.

Anyway, thanks for the response and sorry I blamed Firefox :P

Dit antwoord in context lezen 👍 9

Alle antwoorden (2)

more options

Mozilla doesn't have a deal with Bing, and even if we did we wouldn't be forcing you to use any search engine, we are all about choice. It's possible that either Firefox sync is causing this (do you have a computer with bing set as the default perhaps?) or that you have an extension causing this.

Try resetting Firefox, Refresh Firefox - reset add-ons and settings, then change your search engine to Google (It will be yahoo, our new partner). Let me know if this fixes the issue.

Alternatively, How to fix preferences that won't save might help.

more options

Gekozen oplossing

Alright, I feel like an idiot. It was from an extension I installed called InvisibleHand that I installed right around the time the Google deal with Mozilla expired, which is why I assumed the problem was a result of that.

I just checked the settings of the extension and sure enough it has an option that gets ticked by default called "InvisibleHand Search (Use InvisibleHand (powered by Bing) as my default search provider)". So I jumped the gun and blamed Firefox, my apologies.

The extension automatically shows you if an item is cheaper elsewhere while online shopping which is useful, however having that setting ticked by default is pretty skeevy.

Anyway, thanks for the response and sorry I blamed Firefox :P