Zoeken in Support

Deze conversatie is gearchiveerd. Stel een nieuwe vraag als u hulp nodig hebt.

I can't open new tabs from links in a site, while it is possible from chrome.

  • 15 antwoorden
  • 1 heeft dit probleem
  • 20 weergaven
  • Laatste antwoord van finitarry

more options

In this site http://www.thepressproject.gr/ I can't open the links in new tabs, while for the same site using chrome I can. When I right click on the link, i don't have the usual options (open in new tab, open in new window, bookmark etc.). It is as if it doesn't "see" the links at all and the options are for the main page. What is wrong? (I am sorry for my english, I hope I make sense!)

Alle antwoorden (15)

more options

Do you use No Script plugin or such? If yes, Allow or white list "http://www.thepressproject.gr/" site in your plugin.

more options

No, I don't have such a plugin. The plugins I have are some of adobe, java deployment toolkit, java platform, microsoft office, silverlight, shockwave flash. And from add-ons ad block plus, lightbeam, blur (former DoNotTrackMe), eversync and adobe acrobat.

more options

So your problem is that if you right click that link and that link specifically from ANY webpage (not just this one), you won't get the usual options in the context menus?

more options

Try middle clicking the link (clicking down the scroll wheel on your mouse while the cursor is on it). Does that open a new tab?

more options

Middle clicking doesn't work, either. It is for this specific page (and 9gag), everything else works fine. I am curious why this happens and I'd like to find a solution, because , although i could just use chrome for these two pages that i visit very often, i use firefox all the time and its a bit annoying.

more options

That is a really strange issue. I've never heard of it before nor can I figure out how to fix it. What I'd recommend doing is disabling all your add-ons to see if that fixes the problem. If it does, one of your add-ons is causing the issue. If it doesn't, try starting Firefox is Safe Mode to see if the issue disappears. If the problem doesn't happen in Safe Mode, it's a problem with something that runs in Firefox when you start it normally (could be settings, plug-ins, add-ons, etc). If you can't figure out what is causing the problem in Safe Mode or you know the problem but can't solve it, the easiest thing to do is to reset Firefox or completely reinstall Firefox, described below:

Certain Firefox problems can be solved by performing a Clean reinstall. This means you remove Firefox program files and then reinstall Firefox. Please follow these steps:

Note: You might want to print these steps or view them in another browser.

  1. Download the latest Desktop version of Firefox from mozilla.org (or choose the download for your operating system and language from this page) and save the setup file to your computer.
  2. After the download finishes, close all Firefox windows (or open the Firefox menu New Fx Menu and click the close button Close 29 ).
  3. Delete the Firefox installation folder, which is located in one of these locations, by default:
    • Windows:
      • C:\Program Files\Mozilla Firefox
      • C:\Program Files (x86)\Mozilla Firefox
    • Mac: Delete Firefox from the Applications folder.
    • Linux: If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it - see Install Firefox on Linux. If you downloaded and installed the binary package from the Firefox download page, simply remove the folder firefox in your home directory.
  4. Now, go ahead and reinstall Firefox:
    1. Double-click the downloaded installation file and go through the steps of the installation wizard.
    2. Once the wizard is finished, choose to directly open Firefox after clicking the Finish button.

More information about reinstalling Firefox can be found here.

WARNING: Do not use a third party uninstaller as part of this process. Doing so could permanently delete your Firefox profile data, including but not limited to, extensions, cache, cookies, bookmarks, personal settings and saved passwords. These cannot be easily recovered unless they have been backed up to an external device! See Back up and restore information in Firefox profiles.

Bewerkt door You op

more options

Does the cursor change to a hand icon indicating that it is a link if you hover content?

A lot of elements on that page are DIV elements that have an event attached to it. You should see 'ev' buttons appended to those DIV containers if you right-click such a link and open the Inspector via Inspect Element.


You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Hold down the Shift key and left-click the Reload button
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (Mac)

Clear the cache and remove cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
more options

I started firefox in safe mode, the problem is still there, so I guess it isn't the plugins. I tried reloading it by "bypassing the cache".

The cursor is everywhere a hand icon and I attach a screenshoot of the menu if i right click somewhere. It says (because its in greek): Save page as... Select all Show source code Show page information Check object (I don't know if it's the correct translation) and two options for adobe pdf

I will try clean reinstall after I back up bookmarks and passwords and everything else

I really thank you both for your time (and the instructions) !

Bewerkt door EveBi op

more options

I believe that your settings may have been incorrectly altered, so try both a reset of Firefox then back up your profile and cleanly reinstall Firefox.

Bewerkt door You op

more options

All link processing is done via JavaScript, so you won't see the usual link related entries in the right-click context menu.

Did you try to use the Inspector to see if these mouse events are attached to those links?

I've attached a screenshot that shows the Inspector window that open if you right-click and select Inspect Element.

You should see the gray 'ev' buttons appended to a lot of DIV elements. If they are missing then this means that JavaScript is blocked.

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) as a test.

more options

I used the page inspector and the "ev" buttons appear!

more options

You already tried resetting Firefox then performing a clean reinstall, right?

more options

No, I'll do it later today, because I didn't have much time for this. When I reset firefox and perfom a clean reinstall, I 'll post it!

more options

I followed your instructions for clean reinstall, nothing... It's ok, it doesn't matter. Thank you very much!

more options

The items on that page are not normal links. They are divs containing "onclick=". You can use primary click to get the same tab, but middle-click does nothing because it does not work with "onclick". The secondary click gives a context menu that applies to the page, or to the image if the cursor is on the image, but does not give link options.

I am unable to post some sample code from the page. That does not seem to be possible on this forum.