On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Zoeken in Support

Vermijd ondersteuningsscams. We zullen u nooit vragen een telefoonnummer te bellen, er een sms naar te sturen of persoonlijke gegevens te delen. Meld verdachte activiteit met de optie ‘Misbruik melden’.

Learn More

Deze conversatie is gearchiveerd. Stel een nieuwe vraag als u hulp nodig hebt.

My website has an SSL and is showing as secure in Safari, but Firefox gives a grey triangle warning?

  • 5 antwoorden
  • 9 hebben dit probleem
  • 178 weergaven
  • Laatste antwoord van cor-el

more options

Hi,

My website has an SSL from Dreamhost and is forcing SSL in Wordpress. The web address is set to HTTPS. Everything works perfectly in Safari and the lock icon is showing up. In Firefox however, the "Gray Warning Triangle" shows up in the address bar. When I click the triangle and "Page Info", it shows I have a certificate. How do I make the lock icon show? I have a Wordpress site and will be selling product on it, so it needs to show as secure.

Thanks.

Hi, My website has an SSL from Dreamhost and is forcing SSL in Wordpress. The web address is set to HTTPS. Everything works perfectly in Safari and the lock icon is showing up. In Firefox however, the "Gray Warning Triangle" shows up in the address bar. When I click the triangle and "Page Info", it shows I have a certificate. How do I make the lock icon show? I have a Wordpress site and will be selling product on it, so it needs to show as secure. Thanks.

Gekozen oplossing

thanks, got it. you have a few image elements at the page which aren't loaded through https and which will break the secure connection indicator. in firefox you can press ctrl+shift+k to open the web console - in there make sure that you're logging security notices. then it will show you which elements are affected while you re/load a page...

Dit antwoord in context lezen 👍 3

Alle antwoorden (5)

more options

hello, can you provide a url for the site?

edit: Gray warning triangle

Bewerkt door philipp op

more options

Set you a private message. We're not ready for the world to see the site yet, so I didn't want to post it. Thanks.

more options

Gekozen oplossing

thanks, got it. you have a few image elements at the page which aren't loaded through https and which will break the secure connection indicator. in firefox you can press ctrl+shift+k to open the web console - in there make sure that you're logging security notices. then it will show you which elements are affected while you re/load a page...

more options

Thank you so much! I changed all my images from "http://www..." to just "/wp-content/uploads/2014/03/example.jpg" and it fixed it. You're a life saver!

more options

Note that you can also leave out the protocol name (https or http) and only leave the two slashes (//www.xxx) to make browser apply the currently used protocol.