De foutmelding “Het bladwijzer- en geschiedenissysteem zal niet werken” verhelpen

Dit artikel is van toepassing op Firefox 3.5 en hoger. Als u problemen met uw bladwijzers in Firefox 3.0.x ondervindt, zie dan Bladwijzers en werkbalkknoppen werken niet na upgraden voor een oplossing.

Ziet u deze foutmelding wanneer u Firefox start?

Het bladwijzer- en geschiedenissysteem zal niet werken, omdat één van de bestanden van Firefox in gebruik is door een andere toepassing. Sommige beveiligingssoftware kan dit probleem veroorzaken.

Dit treedt op wanneer het bestand dat uw bladwijzers en navigatiegeschiedenis bewaart (places.sqlite genaamd) niet door Firefox kan worden geopend. Dit artikel beschrijft twee mogelijke oplossingen.

Als u de bovenstaande foutmelding niet ziet, dient u in plaats hiervan een van de volgende artikelen te proberen:

Oplossing 1: uw computer herstarten

De meest voorkomende oorzaken van deze foutmelding zijn een ander programma dat het bestand gebruikt, of een probleem met het bestand dat werd veroorzaakt toen de computer onverwacht werd afgesloten (zoals bij stroomuitval). Het goede nieuws is dat herstarten van uw computer en opstarten van Firefox beide problemen oplost.

Oplossing 2: een nieuwe places-database aanmaken

Als herstarten van uw computer de zaken niet herstelt, kunt u dit oplossen door Firefox een nieuwe places-database voor u te laten aanmaken. Geen zorgen, dit is niet zo moeilijk als het lijkt.

Deel 1 – Uw profielmap openen

Klik boven in het Firefox-venster op de knop Firefox, ga naar het menu HelpKlik in de menubalk op het menu HelpKlik boven in het Firefox-venster op het menu Help en selecteer Probleemoplossingsinformatie. Het tabblad Probleemoplossingsinformatie wordt geopend.Klik op de menuknop New Fx Menu , klik op Help Help-29 en selecteer Probleemoplossingsinformatie. Het tabblad Probleemoplossingsinformatie wordt geopend.

  • Klik onder de sectie Toepassingsbasics op Map tonenTonen in FinderMap openen. Er wordt een venster met daarin uw profielbestandenmap geopend.
  • Noot: als u Firefox niet kunt openen of gebruiken, volg dan de instructies in Uw profiel vinden zonder Firefox te openen.
    Houd de profielmap geopend – ga verder naar deel 2.

    Deel 2 – De database aanmaken

    1. Klik boven in het Firefox-venster op de knop Firefox en selecteer AfsluitenKlik boven in het Firefox-venster op het menu Bestand en selecteer AfsluitenKlik in de menubalk op het menu Firefox en selecteer Firefox afsluitenKlik boven in het Firefox-venster op het menu Bestand en selecteer Afsluiten.

      Klik op de menuknop New Fx Menu en klik daarna op AfsluitenAfsluiten Close 29 .

      Wacht totdat Firefox volledig is afgesloten.
    2. Zoek in de profielmap van Firefox naar de bestanden places.sqlite en places.sqlite-journal (als dit bestaat) en hernoem deze.
      • Om een bestand te hernoemen klikt u met de rechtermuisknop op het bestand en selecteert u Naam wijzigen in het menuklikt u eenmaal op het bestand om het te selecteren en vervolgens een tweede keer op de bestandsnaam om deze te bewerken. Voeg daarna .old toe aan het einde van de naam.
    3. Open Firefox daarna opnieuw.
      • Wanneer Firefox opnieuw wordt geopend, zal een nieuwe places-database worden aangemaakt. Uw navigatiegeschiedenis zal verloren zijn gegaan, maar Firefox zal automatisch uw bladwijzers uit het meest recente reservekopiebestand importeren.
      • Als uw bladwijzers niet zijn hersteld na het aanmaken van een nieuwe places-database, probeer dan de stappen in het artikel Verdwenen of ontbrekende bladwijzers herstellen.

    Help! Dit heeft het probleem niet opgelost.

    Dit probleem kent symptomen die vergelijkbaar zijn met die van een aantal andere problemen. Mogelijk beschrijft een van deze artikelen uw probleem beter.



    Deel dit artikel: http://mzl.la/LLcerE

    Was dit artikel nuttig? Een moment geduld…

    Deze aardige mensen hebben dit artikel helpen schrijven: Tonnes. U kunt ook helpen - lees hier hoe.