Showing questions tagged: Show all questions

Audio issues using external devices with Google Meet

I use Google Meet multiple times a day for work meetings. After switching to Firefox from Chrome recently, I have noticed some persistent issues to do with audio from dev… (read more)

I use Google Meet multiple times a day for work meetings. After switching to Firefox from Chrome recently, I have noticed some persistent issues to do with audio from devices external to my laptop. I have a USB external microphone, a USB sound card that powers external speakers, and wired headphones that I use through the laptop's headphone jack. In macOS my default audio input is the external mic, and default output is the wired headphones.

The first issue that I noticed when using Firefox in meetings was that people reported an echoing effect on my audio. Audio from everyone else sounded fine to me. Changing my microphone source in Meet or in macOS did not seem to help, nor did disabling echo canceling in Meet. What did help was disconnecting the USB microphone completely. The impression that I got was that Meet was taking audio from both the USB mic and laptop mic at the same time, even though only the USB mic was selected. This has happened every time I used Meet.

The second issue that I noticed just happened for the first time today. (Note: I now have my USB mic unplugged until I can resolve the mic issue.) In macOS I had my wired headphones set as the audio output device. I joined a meeting, and I was hearing the meeting audio in my headphones and the external speakers (USB sound card) at the same time.

I've used Meet with Chrome for the last few years and never had this type of issue.

Something I have noticed that may be relevant is, when I open Meet in Chrome and go to the Meet settings, it shows my USB sound card and wired headphones as audio input/output options that I can select, in addition to the built-in laptop speakers. But when I open Meet in Firefox, the settings only show the USB sound card and laptop speakers for output - they don't show my wired headphones. FWIW, media.setsink.enabled is set to "true" already - I saw this mentioned as a solution in a similar question from 2022.

Is there anything I can check, or debugging data I can capture when this issue happens, which would help figure out the root cause?

Asked by owen16 33 minutes ago

Streamers on Twitch showing as Offline when they are actually Streaming

I get phone notifications that a streamer is live but when I go to their page on Twitch on my laptop, I see them as offline (screen shot). I've tried clearing cache and … (read more)

I get phone notifications that a streamer is live but when I go to their page on Twitch on my laptop, I see them as offline (screen shot).

I've tried clearing cache and cookies and do not currently have any pluggins that affect Twitch.

Asked by loveforbooks 2 hours ago

Website hangs when loading with firefox but other browsers seem fine.

Firefox seems to get stuck loading pages on the CSO Ireland website For example https://data.cso.ie/table/NIA13 It can be right intermittently but reoccurs again rapidl… (read more)

Firefox seems to get stuck loading pages on the CSO Ireland website For example https://data.cso.ie/table/NIA13

It can be right intermittently but reoccurs again rapidly at random. Other browsers do not seem to have this issue.

Asked by liam_millar 14 hours ago

Dragging web page elements causes them to increase in size

I often drag elements on trello.com. Whenever I drag an element, that element seems to double in size, making it hard to see what is underneath. Attached is an example.… (read more)

I often drag elements on trello.com. Whenever I drag an element, that element seems to double in size, making it hard to see what is underneath. Attached is an example.

I believe this is related to the fact that I am running Linux/X11 and my DPR is 2. From about:support:

  • Window Device Pixel Ratios 2,2,2,2
  • Window Protocol x11
  • OS Linux 6.1.0-13-amd64 #1 SMP PREEMPT_DYNAMIC Debian 6.1.55-1 (2023-09-29)

Is there an about:config setting or anything that will prevent scaling dragged elements?

Asked by jayenashar 2 days ago

Last reply by jayenashar 18 hours ago

  • Solved

Spotify webplayer on Firefox is unuseable after updating to latest version

Majority of the songs do not play and I'm given with a pop-up, "Spotify can't play this right now. If you have the file on your computer you can import it." I will play … (read more)

Majority of the songs do not play and I'm given with a pop-up, "Spotify can't play this right now. If you have the file on your computer you can import it."

I will play a song from a playlist and is given that pop-up, it will continue skipping to the next song until it plays, but only for 9-10 seconds until the song mutes, to specify, the dot (when hovered on the progress bar) will still move, indicating that "it's playing".

Some clarifications: 1. I use Spotify Desktop app (windows), Spotify App (android), and Spotify Webplayer on Chrome and Firefox. Everything works just as fine on all of these, except for Spotify Webplayer on Firefox. 2. Skipping to a later timestamp does not unmute the song. 2. I have Spotify Premium 3. I have no VPN 4. I am running Firefox with an ad blocker 5. I am running Chrome with an ad blocker (same ad blocker in Fifefox) 6. I am running Firefox to the latest version (Firefox 119.0.1 (20231106151204))

What I've done so far: 1. Cleared caches and data. 2. Updated my Windows to the latest update available - Win10 v.22H2 3. Signed-out of Spotify for all my devices, then logging-in first on Spotify Desktop (this automatically redirects to Firefox webplayer) 4. Ran Firefox on "Troubleshoot Mode" 5. Un-checked and re-checked "Play DRM content" setting. 6. Disabled and re-enabled the plug-in "Widevine Content Decryption Module by Google Inc". (this plug-in is last udpated on November 17, 4.10.2710.0

I'm including this link from Spotify's Community page.. where two other users, who commented it is only with Firefox (webplayer), are experiencing the same problem as I am. https://community.spotify.com/t5/Desktop-Windows/Spotify-can-t-play-this-right-now-If-you-have-the-file-on-your/m-p/5679914#M123192

Asked by kit 1 week ago

Answered by zeroknight 1 week ago

Firefox backspace doesn't work in new iCloud Calendar on the web...

Hi all, Apple has revised/updated their iCloud web portal. The backspace key no longer registers in the iCloud Calendar app on the web. This is specific to Firefox on … (read more)

Hi all,

Apple has revised/updated their iCloud web portal. The backspace key no longer registers in the iCloud Calendar app on the web. This is specific to Firefox on Windows - I've tried other web browsers to access iCloud web portal and Chrome's backspace key registers so its not an Apple iCloud problem, just Firefox. Is there a setting or do I have to wait for an update?

Thanks in advance.

Asked by wm_cheng 1 month ago

Last reply by jislonim 1 day ago

Videos can't be played at higher playback speed on Youtube

Videos can't be played at higher playback speed Bug On firefox, I cant play videos at higher playback speed or it'll only play audio or video will endlessly buffer. Usin… (read more)

Videos can't be played at higher playback speed Bug

On firefox, I cant play videos at higher playback speed or it'll only play audio or video will endlessly buffer. Using user-agent spoofer and changing to chrome makes it a little less worse but still the problem sustains. On Brave, the video doesnt have any effect of higher playback speed rather it'll make the video buffer and have very strong red contrast.

Asked by kapish1233 1 day ago

Last reply by zeroknight 1 day ago

dictionary.com not working

Dear Sir/Madam: I am using Firefox Browser 102.15.1esr (64-bit) on a MacBook Pro Ventura 13.5.2. I have been using the www.dictionary.com website for a long time, but r… (read more)

Dear Sir/Madam:

I am using Firefox Browser 102.15.1esr (64-bit) on a MacBook Pro Ventura 13.5.2.

I have been using the www.dictionary.com website for a long time, but recently when I attempt to go there, I keep getting the error message as follows:

Unexpected Application Error! FM.findLast is not a function

WM@https://www.dictionary.com/client.e12a2de6.js:36:305976 $o@https://www.dictionary.com/client.e12a2de6.js:1:26519 ka@https://www.dictionary.com/vendor.60d89d9a.js:1:864941 xu@https://www.dictionary.com/vendor.60d89d9a.js:1:921923 bc@https://www.dictionary.com/vendor.60d89d9a.js:1:910907 yc@https://www.dictionary.com/vendor.60d89d9a.js:1:910835 vc@https://www.dictionary.com/vendor.60d89d9a.js:1:910696 ic@https://www.dictionary.com/vendor.60d89d9a.js:1:907503 oc@https://www.dictionary.com/vendor.60d89d9a.js:1:906055 E@https://www.dictionary.com/vendor.60d89d9a.js:1:996565 P@https://www.dictionary.com/vendor.60d89d9a.js:1:997096

I tried clearing caches under Privacy & Security, but the problem persists.

(Meanwhile, I can visit www.dictionary.com on Safari and Google Chrome.)

Could you please let me know what is going on?

Thank you,

Roland

Asked by rolandlongbow 2 months ago

Last reply by rolandlongbow 2 months ago

  • Solved

Certain websites don't load on my computer, but they do on my laptop

When visiting some smaller and less known websites on my computer it shows the error message "connection has timed out" but on my laptop it loads just fine. Both run fire… (read more)

When visiting some smaller and less known websites on my computer it shows the error message "connection has timed out" but on my laptop it loads just fine. Both run firefox and are sync'd with the same configuration and extensions. I already tried the troubleshoot mode and also checked the firewall. Is there anything else I can try to fix this?

Asked by alnmmrs27 2 days ago

Answered by alnmmrs27 2 days ago

interface problems

Hi, Mozilla team I hope that you have a great day, straight to the point, my UI sometimes crashes or some components glitch or don't even work as it has to This is a vide… (read more)

Hi, Mozilla team I hope that you have a great day, straight to the point, my UI sometimes crashes or some components glitch or don't even work as it has to This is a video below slowed(I couldn't upload the video).

Asked by mabtheoriginal 3 days ago

Last reply by zeroknight 2 days ago

  • Solved

Cannot Log In To Sony Community Website

Hello this is Don. I am using Win10 with Firefox 120.0 64 Bit as my default browser I am having a problem with logging in to The Sony Community Forum where I help Sony us… (read more)

Hello this is Don. I am using Win10 with Firefox 120.0 64 Bit as my default browser I am having a problem with logging in to The Sony Community Forum where I help Sony users. I enter my email as my Sign in ID then press enter to get to the password screen and it goes to the spinning grey circle on a white screen. My Memory and CPU gets really high and my browser locks up and I have to go to task manager and End Task for all Firefox processes to unlock it. I have no problem getting in to the website with MS Edge but I hate using it but I have to in order to sign in to Sony Community Forum and help users. I have have done a full system scan for malware with Norton, MSERT, Malwarebytes and Windows Defender. I have done a REFRESH of Firefox and I have even uninstalled and re-installed Firefox and nothing helps. I have it set to auto clear everything under History including Cache and Cookies. There is something about this Forum that for the past week will not let me in. I have emailed my Sony Advocacy leader and he is having the Web Site Team looking into it. This is the only website I cannot log in to. I have used Firefox for years and do not want to have to go to something else.

Respectfully, Don

Asked by new_aged2perfection 1 week ago

Answered by new_aged2perfection 3 days ago

::before and ::after pseudo-elements override my safety css. How can I override them back?

Animation triggers my migraines. Man websites use transition and animation timing functions such as "ease in-out" to animate the interface. I try to block this. Among ot… (read more)

Animation triggers my migraines.

Man websites use transition and animation timing functions such as "ease in-out" to animate the interface. I try to block this. Among other tools I use userContent,css, including the following:

  • {animation-timing-function: step-start !important}
  • {transition-timing-function: step-start !important}

This works to de-animate regular css elements, but not ::before and ::after pseudo-elements.

The current css standards do not apply user css to pseudo-elements. I've written to the WCAG about the issue.

https://bugzilla.mozilla.org/show_bug.cgi?id=1865572

https://github.com/w3c/wcag3/issues/40

But I really really need some way to de-animate these, because they trigger my migraines. Aside from css fixes, I often reduce the frame rate in about:config, but can't always do that, disable smooth scrolling, disable animated gifs and animated pngs, disable autoplay, block various non-scrolling elements using either css or uBlock Origin, etc.

Asked by MarjaE 4 days ago

Last reply by cor-el 2 days ago

Website Loading as Unsecured, but only in Firefox. Loads with secure certificate on Chrome, Edge and Opera

I'm trying to load https://bfjoy.com/ and only Firefox is redirecting my typing of 'bfjoy.com' as an http: website instead of the correct https: Why is this? I assume D… (read more)

I'm trying to load https://bfjoy.com/ and only Firefox is redirecting my typing of 'bfjoy.com' as an http: website instead of the correct https:

Why is this? I assume DNS but what is Firefox doing to redirect to the unsecured site that other browsers aren't?

Asked by wgarnerjr 5 days ago

Last reply by zeroknight 3 days ago

Firefox tells me to close program because Firefox is already running

Firefox tells me to close program because Firefox is already running. When I close Firefox then re-open Firefox: same message. When I check Firefox in Task Manager, there… (read more)

Firefox tells me to close program because Firefox is already running. When I close Firefox then re-open Firefox: same message. When I check Firefox in Task Manager, there are anywhere from 6 instances of FF running and sometimes up to 24. Something needs fixed.

Asked by Mike Wick 4 days ago

Last reply by zeroknight 3 days ago

Rendering Issues on old Mac Pro

Hi! I am running Firefox on an old MacPro5,1 with MacOS Ventura using Open Core Legacy Patcher. The graphics card is a NVIDIA GeForce GT 630. So overall it's a pretty old… (read more)

Hi! I am running Firefox on an old MacPro5,1 with MacOS Ventura using Open Core Legacy Patcher. The graphics card is a NVIDIA GeForce GT 630. So overall it's a pretty old setup but everything works fine. However, since day one, I've been having rendering issues with some (not all) videos on Firefox. These videos include some but not all YouTube videos, some embedded animations on websites, and every live stream video. The workaround is pretty straightforward: everything works fine on Safari and Chrome. Still, I am wondering what the issue could be, any help would be appreciated. Attached are two screenshot of what the rendering issues look like.

I just realized that my user agent string is wrong (for instance, it says that I am on OS X 10.15, even though I am on 13.6, not sure if that makes any difference at all.

Asked by flattestrat 3 days ago

Websites not responding

What would cause websites not responding. I have no malware and the cache is clean. Could it be in the properties, or whatever. Thank you. It's very frustrating. … (read more)

What would cause websites not responding. I have no malware and the cache is clean. Could it be in the properties, or whatever.

Thank you. It's very frustrating.

Asked by Susan 4 days ago

Last reply by cor-el 4 days ago

Missing data on websites

Hello - I keep searching for various fixes to this, but nothing seems to work. I have the latest version of firefox. Macbook user. Catalina 10.15 I find that with almos… (read more)

Hello - I keep searching for various fixes to this, but nothing seems to work. I have the latest version of firefox. Macbook user. Catalina 10.15 I find that with almost any website that I'm trying to log into, or enter a credit card and other information, the browser does not show these items, pull downs, forms to fill in etc. I'll go thru a whole process of something, and will be directed to click a box or some such that just isnt there. So I move over to Safari, and the entire page loads. I've adjusted the privacy, cleared cache etc. It's like I'm on an ancient browser.

Any help welcome.

Asked by Deborah Goldstein 5 days ago

Last reply by cor-el 4 days ago

  • Solved

Montserrat font ignores font-weight

For some reason Montserrat fonts ignore font-weight for me on all websites. In happens on my main browser profile, with a new clean one with no add-ons and even in Tor Br… (read more)

For some reason Montserrat fonts ignore font-weight for me on all websites. In happens on my main browser profile, with a new clean one with no add-ons and even in Tor Browser. Pictures 1 and 2 illustrate the problem. If i go into page inspector and replace "font-family: 'Montserrat', sans-serif;" with "font-family: 'Segoe UI';" the parameter works as expected and the alternative font is rendered properly.

Reinstalling fonts from fontsource.org didn't help.

OS: Windows 10 1607, FF - 120.0, issue was present for many versions before.

Asked by Burning_Chair 1 week ago

Answered by zeroknight 4 days ago