Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox, left mouse button on certain websites

  • 1 reply
  • 1 has this problem
  • 14 views
  • Last reply by cor-el

more options

Under 'Settings' then 'Privacy & Security', I have selected 'Never remember history'

I goto the website 'amaincycling.com' and click or mouse over the 'person' icon next to the 'shopping cart'. In the popup menu, left clicking on 'Log in' does nothing.

Then I change the history to 'Use custom settings for history' and on 'Always use private browsing mode' is selected.

restart Firefox

I goto the website 'amaincycling.com' and click or mouse over the 'person' icon next to the 'shopping cart'. In the popup menu, left clicking on 'Log in' does nothing.

With history still 'Use custom settings for history', uncheck the 'Always use private browsing mode' and the three sub-choices are NOT checked: 'Remember browsing and download history', 'Remember search and form history' and 'Clear history when Firefox close' (This is the same function as 'Never remember history')

Firefox restarts

I goto the website 'amaincycling.com' and click or mouse over the 'person' icon next to the 'shopping cart'. In the popup menu, left clicking on 'Log in' and NOW the login page opens! BUT, I check settings and NOW the 'Remember seach and form history' is also checked which I never checked!

For interest, I had all three sub-choices checked: 'Remember browsing and download history', 'Remember search and form history' and 'Clear history when Firefox close' which is the same as 'Never

The main issue is the left clicking not working when using 'Never remember history'. Why?

And why does 'Never remember history' apparently enable private browsing mode? What does private browsing have to do with 'Never remember history'?

I have had this issue on random websites and it has been a pain in the ...

If private browsing mode is going to interfere with websites like this then maybe when 'Never remember history' is selected, then a check box option should be shown to to check whether 'Always use private browsing mode'

All Replies (1)

more options

'Never remember history' is short for PB mode, so you do not have to open 'Use custom settings for history'. 'Remember history' clears PB mode and sets the default settings for the history and this includes 'Remember search and form history'. Selecting 'Use custom settings for history' doesn't make any changes to the history settings, but allow to inspect the current settings and possibly modify them. If you use 'Use custom settings for history' to exit PB mode then your original settings are restored. 'Use custom settings for history' stays selected in case one or more settings have been changed from the default as set via 'Remember history' or 'Never remember history' to make you aware you made changes.

In PB mode some features like local storage (indexedDB) do not work and that can break websites that rely on this storage. Also in PB mode different Enhanced Tracking Protection stronger rules might be active what can be a cause for a broken website.