Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Spell Check won't work

  • 6 replies
  • 3 have this problem
  • 7 views
  • Last reply by WestEnd

more options

Hello

The spell check doesn't work anymore in Firefox, so I have followed the advice on line and have upgraded to version 57, added the Eng Dictionary and checked the settings in about:config and changed the value of default spell check to 2 for single and multi line text boxes, but still my spell checker doesn't work, so I wonder if you could please suggest something else to fix this. Thank you.

Elizabeth

All Replies (6)

more options

Hello I also have the issue I had once before where I don't have grab handles on the edge of the browser to resize the screen. I think when I had this before I was advised to install another lower / different version of FF.

more options

Do you have a dictionary installed and selected?

You can see which dictionary is selected if you right-click in a text area and open the Languages sub menu. At least one dictionary should be installed and have a check mark to indicate that it is selected.

  • open the "Add Dictionaries" link to install a dictionary if you do not have one.

The spelling checker is enabled if [X] "Check Spelling" in the right-click context menu has a checkmark.

You can enable or disable spell checking globally:

  • Options/Preferences -> General: Browsing: "Check my spelling as I type"

You can look here for dictionaries:

Make sure to choose a dictionary and not a language pack.

more options

Hello

Thank you for your reply, but I can't even do the first thing to right click on a text area, I have tried in the search of google, and in a few other text areas, but I don't get a sub menu that mentions languages. I have attached a screen shot when I right click in this text box. That said I have added an Eng language and have already checked the Spell as I type is checked, but still no spell checker. Thanks Elizabeth

more options

The language menu gets hidden when the website disables the builtin Firefox spell checker via a spellcheck="false" attribute on that text area, but that shouldn't happen with this website.

Do you have the Firefox en-GB version? Do you see the dictionary in "Add-ons -> Dictionaries" as enabled?


For your other question:

If you can't resize the screen then the Firefox window might be maximized or you run Firefox in Tablet mode and not in Desktop mode.

more options

Hello

Yes I can see the Eng GB Add in.

Elizabeth

more options

Here's my spelling check screen for the EN US version looks like.