Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

form & passwords being saved although set not to be saved

  • 8 balasan
  • 1 ada masalah ini
  • 5 paparan
  • Balasan terakhir oleh daveatkins

more options

As stated above, I set NOT to save passwords & form data, but each login has that information auto filled. The dialog to clear saved passwords says there are none, yet all my logins have them and usernames already filled. Using Linux Mint Cinnamon OS. Firefox on Windows and on my Mobile does not have this problem.

All Replies (8)

more options

Many site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache. Note: This will temporarily log you out of all sites you're logged in to. To clear cache and cookies do the following:

  1. Go to Firefox > History > Clear recent history or (if no Firefox button is shown) go to Tools > Clear recent history.
  2. Under "Time range to clear", select "Everything".
  3. Now, click the arrow next to Details to toggle the Details list active.
  4. From the details list, check Cache, Search & Form History and Cookies and uncheck everything else.
  5. Now click the Clear now button.

Further information can be found in the Clear your cache, history and other personal information in Firefox article.

Did this fix your problems? Please report back soon.

more options

Thanks ComputerWhiz. I had already tried all these things, before posting the question here. My login for this Forum now auto fills also. I have also tried uninstalling and reinstalling Firefox.

more options

Are you automatically reopening windows from the previous session via session restore?

  • Edit > Preferences > General > Startup: "When Firefox Starts": "Show my windows and tabs from last time"

Firefox stores cookies used in tabs that are currently open in the sessionstore.js file as part of saved session data, so those cookies will be restored if Firefox is closed without first closing these tabs.

You can set the browser.sessionstore.privacy_level pref to 2 (never) or 1 (non-HTTPS) on the about:config page to disable saving cookies via session restore.

The browser.sessionstore.privacy_level_deferred pref is used when you do not reopen the previous session automatically via "Show my windows and tabs from last time" and uses the same values.


Details like websites remembering you (log you in automatically) are stored in a cookie, so as long as you have such a cookie then the website will remember (recognize) you.

more options

Thanks cor-el. I start Firefox with a blank page (about:blank) and have that as my home page. Also have setting to delete cookies when Firefox closes.

more options

I think the problem is not with Firefox itself. Looking for other possibilities.

more options

I am sorry that you have already tried my above solution.


Sometimes a problem with Firefox may be a result of malware installed on your computer, that you may not be aware of.

You can try these free programs to scan for malware, which work with your existing antivirus software:

Microsoft Security Essentials is a good permanent antivirus for Windows 7/Vista/XP if you don't already have one.


Further information can be found in the Troubleshoot Firefox issues caused by malware article.

Did this fix your problems? Please report back soon.

more options

Note that the OP is on Linux, so this won't apply and help.

If clearing cookies doesn't work then it is possible that the cookies.sqlite file that stores the cookies is corrupted.

Rename (or delete) cookies.sqlite (cookies.sqlite.old) and delete other present cookie files like cookies.sqlite-journal in the Firefox profile folder in case the file cookies.sqlite got corrupted.


Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over the problem.

more options

Thank you both for your assistance. I have now removed the extensions that I had in Firefox, and that has fixed the problem. When I removed and re-installed Firefox previously, the extensions were re-installed also. Now just have to put them back one by one to discover the cause, I guess.

Thanks again.