Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Site Circumventing Firefox Privacy Settings

  • 5 balasan
  • 1 ada masalah ini
  • 7 paparan
  • Balasan terakhir oleh Oo0Bailey0oO

more options

The site FindTheBest.com appears to be bypassing Firefox's privacy settings, changing it to always allow cookies despite being set to block all cookies.

I've tested this several times and I've verified on other sites that the privacy settings are still being adhered to. I'm not sure how they can change the browser setting like that though.

In my last test, I deleted their cookie, removed the cookie exception, set a new exception to always block, blocked all new cookies, closed the page and re-opened it. Still changing it to allow as a new exception.

Is this possible? How can I control it?

All Replies (5)

more options

Are you blocking cookies from findthebest.com or www.findthebest.com ?

You always need to block cookies from the top domain to be sure to block items from sub domains.

more options

Yes, to clarify above, when I'm blocking the site I'm using www.findthebest.com either automatically by "ask me every time" cookie control pop-ups or manually by typing it into the cookie exception window.

Maybe you can test the site as well and then I can tell if it's specific to me or possibly universal.

Thanks

more options

I see cookies from findthebest.com, so if you only block cookies from the domain with the www. prefix then those aren't blocked.

See this thread for a similar issue with Facebook and cookies and sub domains.

more options

But how is it circumventing Privacy setting of "Ask Me Every Time"? The pop-up never comes up, it just sets itself to always allow. Also, even the www. exception is involuntarily flipped to always allow.

I've just tested it again. Under Page Info when on their site, I set it to block cookies, then I refreshed. When I checked it again, it stayed as block this time.

Then I attempted to click "Default" the area went grey and the box stayed unchecked. I clicked it again and the box checked. After refreshing the page again though, no dialog box came up for Default and "block" was still selected under Page Info.

In effect, the same behaviour as always allow but with block now which suggests something is wrong with Firefox for this specific site and not malicious intent on the site itself.

I tried to reproduce this on this very mozilla page, but it behaves as normal/expected, as every other site has so far too.

more options

I forgot to add, this behaviour occurs under safe mode too.